summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-18 19:43:56 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2022-02-21 20:06:28 -0300
commit30f5ce1d2168389295b4813e01898c2fb0f9bab9 (patch)
treef6f78dbf8e5eef40510739dc1db79d60f05189fb /recipes-multimedia
parenta3b102a9ed12ea03e72f713ed40968da1776c6d3 (diff)
downloadmeta-freescale-30f5ce1d2168389295b4813e01898c2fb0f9bab9.tar.gz
Generalize overrides subsystem for NXP and Mainline support
Essentially, we extend the overrides to a generic-bsp, nxp-bsp, and mainline-bsp. So, for example, the mx8mq override is split into: - imx-generic-bsp: compatible with every i.MX SoC and both BSP variants - imx-nxp-bsp: compatible with every i.MX SoC but specific to NXP BSP - imx-mainline-bsp: compatible with every i.MX SoC but specific to Mainline BSP - mx8-generic-bsp: compatible with every i.MX8 SoC and both BSP variants - mx8-nxp-bsp: compatible with every i.MX8 SoC but specific to NXP BSP - mx8-mainline-bsp: compatible with every i.MX8 SoC but specific to Mainline BSP - mx8m-generic-bsp: compatible with every i.MX8M SoC and both BSP variants - mx8m-nxp-bsp: compatible with every i.MX8M SoC but specific to NXP BSP - mx8m-mainline-bsp: compatible with every i.MX8M SoC but specific to Mainline BSP - mx8mq-generic-bsp: compatible with every i.MX8MQ SoC and both BSP variants - mx8mq-nxp-bsp: compatible with every i.MX8MQ SoC8 but specific to NXP BSP - mx8mq-mainline-bsp: compatible with every i.MX8MQ SoC but specific to Mainline BSP The extender mechanism is responsible for extending the override list to include the generic overrides. We can then use the three different variants to handle the metadata correctly. Generically speaking, the conversion mainly was automated (with a lot of back and forth until getting it right). To convert an existing layer, the following script can be used: ```sh git ls-files classes recipes-* \ | xargs sed -i \ -e 's,:\(mx[6-8]\w*\),:\1-nxp-bsp,g' \ -e 's,(\(mx[6-8]\w*\)),(\1-nxp-bsp),g' \ -e 's,\(mx[6-8]\w*\)|,\1-nxp-bsp|,g' \ -e 's,|\(mx[6-8]\w*\)),|\1-nxp-bsp),g' \ \ -e 's,:\(mx[5s]\w*\),:\1-generic-bsp,g' \ -e 's,(\(mx[5s]\w*\)),(\1-generic-bsp),g' \ -e 's,\(mx[5s]\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(mx[5s]\w*\)),|\1-generic-bsp),g' \ \ -e 's,:\(vf\w*\),:\1-generic-bsp,g' \ -e 's,:\(vf[56]0\w*\),:\1-generic-bsp,g' \ -e 's,\(vf\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(vf\w*\)),|\1-generic-bsp),g' \ -e 's,\(vf[56]0\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(vf[56]0\w*\)),|\1-generic-bsp),g' \ \ -e 's,:\(imx\) ,:\1-nxp-bsp ,g' \ -e 's,(\(imx\)),(\1-nxp-bsp),g' \ -e 's,\(imx\)|,\1-nxp-bsp|,g' \ -e 's,|\(imx\)),|\1-nxp-bsp),g' for d in $(find -type d | egrep '/mx[6-8]w*'); do git mv $d $d-nxp-bsp done for d in $(find -type d | egrep '/imx$'); do git mv $d $d-nxp-bsp done for d in $(find -type d | egrep '/mx[5s]w*'); do git mv $d $d-generic-bsp done ``` Fixes: #791. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/alsa/alsa-lib_%.bbappend4
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-libav_1.18.0.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb8
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.18.0.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.18.0.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb30
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.6.2.bb2
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb2
-rw-r--r--recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb6
-rw-r--r--recipes-multimedia/imx-dspc-asrc/imx-dspc-asrc_1.0.1.bb2
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.6.2.bb2
-rw-r--r--recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.1.bb2
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb2
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb8
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb2
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/daemon.conf (renamed from recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf)0
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/default.pa (renamed from recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa)0
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch (renamed from recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch)0
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio_%.bbappend16
24 files changed, 53 insertions, 53 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend
index d76c45d1..8a13d4c1 100644
--- a/recipes-multimedia/alsa/alsa-lib_%.bbappend
+++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend
@@ -6,6 +6,6 @@ IMX_PATCH = " \
6 file://0005-add-ak4458-conf-for-multichannel-support.patch \ 6 file://0005-add-ak4458-conf-for-multichannel-support.patch \
7 file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ 7 file://0006-add-conf-for-iMX-XCVR-sound-card.patch \
8" 8"
9SRC_URI:append:imx = "${IMX_PATCH}" 9SRC_URI:append:imx-nxp-bsp = "${IMX_PATCH}"
10 10
11PACKAGE_ARCH:imx = "${MACHINE_SOCARCH}" 11PACKAGE_ARCH:imx-nxp-bsp = "${MACHINE_SOCARCH}"
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 96b6392d..634508f9 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -33,4 +33,4 @@ FILES:${PN} += "${libdir}/alsa-lib/libasound_*.so"
33FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug" 33FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug"
34FILES:${PN}-dev += "${libdir}/alsa-lib/*.la" 34FILES:${PN}-dev += "${libdir}/alsa-lib/*.la"
35 35
36COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 36COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.18.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.18.0.bb
index 73d8c429..2d16a3f2 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.18.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.18.0.bb
@@ -23,4 +23,4 @@ inherit meson pkgconfig upstream-version-is-even
23FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" 23FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
24FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" 24FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
25 25
26COMPATIBLE_MACHINE = "(imx)" 26COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
index aec2bb01..c3f4cf25 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
@@ -1,14 +1,14 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc 1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2 2
3DEPENDS:append:imxgpu2d = " virtual/libg2d" 3DEPENDS:append:imxgpu2d = " virtual/libg2d"
4DEPENDS:append:mx8 = " libdrm" 4DEPENDS:append:mx8-nxp-bsp = " libdrm"
5 5
6PACKAGECONFIG:append:mx8 = " kms tinycompress" 6PACKAGECONFIG:append:mx8-nxp-bsp = " kms tinycompress"
7 7
8DEFAULT_PREFERENCE = "-1" 8DEFAULT_PREFERENCE = "-1"
9 9
10PACKAGE_ARCH:imxpxp = "${MACHINE_SOCARCH}" 10PACKAGE_ARCH:imxpxp = "${MACHINE_SOCARCH}"
11PACKAGE_ARCH:mx8 = "${MACHINE_SOCARCH}" 11PACKAGE_ARCH:mx8-nxp-bsp = "${MACHINE_SOCARCH}"
12 12
13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https;branch=master" 13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https;branch=master"
14SRCBRANCH = "MM_04.06.01_2105_L5.10.y" 14SRCBRANCH = "MM_04.06.01_2105_L5.10.y"
@@ -160,4 +160,4 @@ FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
160# include fragment shaders 160# include fragment shaders
161FILES:${PN}-opengl += "/usr/share/*.fs" 161FILES:${PN}-opengl += "/usr/share/*.fs"
162 162
163COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 163COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
index 5dd672bf..d254db0c 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
@@ -99,4 +99,4 @@ def get_opengl_cmdline_list(switch_name, options, d):
99 99
100CVE_PRODUCT += "gst-plugins-base" 100CVE_PRODUCT += "gst-plugins-base"
101 101
102COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 102COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
index 050bc6ee..19248583 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
@@ -74,4 +74,4 @@ EXTRA_OEMESON += " \
74 74
75FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" 75FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
76 76
77COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 77COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
index 41de1369..ed2da34b 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb
@@ -42,8 +42,8 @@ PACKAGECONFIG:append:imxpxp = " pxp"
42# The 2D blitter sinks require an MXC framebuffer, which 42# The 2D blitter sinks require an MXC framebuffer, which
43# is not available anymore on the i.MX8 (since these SoCs 43# is not available anymore on the i.MX8 (since these SoCs
44# now use KMS instead of the old Linux framebuffer). 44# now use KMS instead of the old Linux framebuffer).
45PACKAGECONFIG:append:mx6 = " imx2dvideosink v4l2" 45PACKAGECONFIG:append:mx6-nxp-bsp = " imx2dvideosink v4l2"
46PACKAGECONFIG:append:mx7 = " imx2dvideosink" 46PACKAGECONFIG:append:mx7-nxp-bsp = " imx2dvideosink"
47 47
48PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}" 48PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
49PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled," 49PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
@@ -59,4 +59,4 @@ require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
59# the following line is required to produce one package for each plugin 59# the following line is required to produce one package for each plugin
60PACKAGES_DYNAMIC = "^${PN}-.*" 60PACKAGES_DYNAMIC = "^${PN}-.*"
61 61
62COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx8)" 62COMPATIBLE_MACHINE = "(mx6dl-nxp-bsp|mx6q-nxp-bsp|mx6sl-nxp-bsp|mx6sx-nxp-bsp|mx6ul-nxp-bsp|mx6ull-nxp-bsp|mx7d-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.18.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.18.0.bb
index 0625fbaa..15c17f4f 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.18.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.18.0.bb
@@ -42,4 +42,4 @@ EXTRA_OEMESON += " \
42FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs" 42FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
43FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs" 43FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"
44 44
45COMPATIBLE_MACHINE = "(imx)" 45COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.18.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.18.0.bb
index eaaf078b..4a8d5995 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.18.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.18.0.bb
@@ -29,4 +29,4 @@ GIR_MESON_DISABLE_FLAG = "disabled"
29# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well 29# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well
30require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc 30require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
31 31
32COMPATIBLE_MACHINE = "(imx)" 32COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
index c474f9b0..eabf0f44 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
@@ -79,4 +79,4 @@ CVE_PRODUCT = "gstreamer"
79 79
80PTEST_BUILD_HOST_FILES = "" 80PTEST_BUILD_HOST_FILES = ""
81 81
82COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 82COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index b5fb8890..db3badac 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -8,8 +8,8 @@ LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia" 8SECTION = "multimedia"
9 9
10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" 10DEPENDS = "imx-codec imx-parser gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS:append:mx6 = " imx-lib" 11DEPENDS:append:mx6-nxp-bsp = " imx-lib"
12DEPENDS:append:mx7 = " imx-lib" 12DEPENDS:append:mx7-nxp-bsp = " imx-lib"
13DEPENDS:append:imxvpu = " imx-vpuwrap libdrm" 13DEPENDS:append:imxvpu = " imx-vpuwrap libdrm"
14 14
15# For backwards compatibility 15# For backwards compatibility
@@ -30,14 +30,14 @@ S = "${WORKDIR}/git"
30 30
31inherit meson pkgconfig use-imx-headers 31inherit meson pkgconfig use-imx-headers
32 32
33PLATFORM:mx6 = "MX6" 33PLATFORM:mx6-nxp-bsp = "MX6"
34PLATFORM:mx6sl = "MX6SL" 34PLATFORM:mx6sl-nxp-bsp = "MX6SL"
35PLATFORM:mx6sx = "MX6SX" 35PLATFORM:mx6sx-nxp-bsp = "MX6SX"
36PLATFORM:mx6ul = "MX6UL" 36PLATFORM:mx6ul-nxp-bsp = "MX6UL"
37PLATFORM:mx6sll = "MX6SLL" 37PLATFORM:mx6sll-nxp-bsp = "MX6SLL"
38PLATFORM:mx7= "MX7D" 38PLATFORM:mx7-nxp-bsp= "MX7D"
39PLATFORM:mx7ulp= "MX7ULP" 39PLATFORM:mx7ulp-nxp-bsp= "MX7ULP"
40PLATFORM:mx8 = "MX8" 40PLATFORM:mx8-nxp-bsp = "MX8"
41 41
42# Todo add a mechanism to map possible build targets 42# Todo add a mechanism to map possible build targets
43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \ 43EXTRA_OEMESON = "-Dplatform=${PLATFORM} \
@@ -49,10 +49,10 @@ PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN
49# Add codec list that the beep plugin run-time depended 49# Add codec list that the beep plugin run-time depended
50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis" 50BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux " 51RDEPENDS:${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
52RDEPENDS:${PN}:append:mx8qm = " imx-dsp" 52RDEPENDS:${PN}:append:mx8qm-nxp-bsp = " imx-dsp"
53RDEPENDS:${PN}:append:mx8qxp = " imx-dsp" 53RDEPENDS:${PN}:append:mx8qxp-nxp-bsp = " imx-dsp"
54RDEPENDS:${PN}:append:mx8mp = " imx-dsp" 54RDEPENDS:${PN}:append:mx8mp-nxp-bsp = " imx-dsp"
55RDEPENDS:${PN}:append:mx8ulp = " imx-dsp" 55RDEPENDS:${PN}:append:mx8ulp-nxp-bsp = " imx-dsp"
56 56
57# overlaysink rely on G2D, 57# overlaysink rely on G2D,
58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D 58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
@@ -82,4 +82,4 @@ FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" 82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" 83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84 84
85COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 85COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
index 46a1b225..cdb5a8ac 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
+++ b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
@@ -116,4 +116,4 @@ FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux
116FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" 116FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*"
117 117
118PACKAGE_ARCH = "${MACHINE_ARCH}" 118PACKAGE_ARCH = "${MACHINE_ARCH}"
119COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 119COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
index fe653c18..f34c466c 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp-codec-ext_1.2.0.bb
@@ -18,4 +18,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
18INSANE_SKIP:${PN} = "arch dev-so" 18INSANE_SKIP:${PN} = "arch dev-so"
19 19
20FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm" 20FILES:${PN} += "${libdir}/imx-mm/audio-codec ${datadir}/imx-mm"
21COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8mp|mx8ulp)" 21COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"
diff --git a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
index fe650eb1..eb90f17f 100644
--- a/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
+++ b/recipes-multimedia/imx-dsp/imx-dsp_1.2.0.bb
@@ -19,8 +19,8 @@ EXTRA_OECONF += " \
19RDEPENDS:${PN} += " imx-dsp-codec-ext" 19RDEPENDS:${PN} += " imx-dsp-codec-ext"
20 20
21HIFI4_BIN ?= "hifi4_imx8qmqxp.bin" 21HIFI4_BIN ?= "hifi4_imx8qmqxp.bin"
22HIFI4_BIN:mx8mp = "hifi4_imx8mp.bin" 22HIFI4_BIN:mx8mp-nxp-bsp = "hifi4_imx8mp.bin"
23HIFI4_BIN:mx8ulp = "hifi4_imx8ulp.bin" 23HIFI4_BIN:mx8ulp-nxp-bsp = "hifi4_imx8ulp.bin"
24 24
25do_install:append () { 25do_install:append () {
26 # Rename DSP Firmware into hifi4.bin and remove unneeded binary 26 # Rename DSP Firmware into hifi4.bin and remove unneeded binary
@@ -42,4 +42,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
42INHIBIT_SYSROOT_STRIP = "1" 42INHIBIT_SYSROOT_STRIP = "1"
43 43
44PACKAGE_ARCH = "${MACHINE_ARCH}" 44PACKAGE_ARCH = "${MACHINE_ARCH}"
45COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8mp|mx8ulp)" 45COMPATIBLE_MACHINE = "(mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8mp-nxp-bsp|mx8ulp-nxp-bsp)"
diff --git a/recipes-multimedia/imx-dspc-asrc/imx-dspc-asrc_1.0.1.bb b/recipes-multimedia/imx-dspc-asrc/imx-dspc-asrc_1.0.1.bb
index 83aa656f..7bf6d932 100644
--- a/recipes-multimedia/imx-dspc-asrc/imx-dspc-asrc_1.0.1.bb
+++ b/recipes-multimedia/imx-dspc-asrc/imx-dspc-asrc_1.0.1.bb
@@ -19,4 +19,4 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
19 19
20FILES:${PN} += "/unit_tests ${datadir}/imx-mm" 20FILES:${PN} += "/unit_tests ${datadir}/imx-mm"
21 21
22COMPATIBLE_MACHINE = "(mx8)" 22COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
index 08cdd162..f8ee180e 100644
--- a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
+++ b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
@@ -41,4 +41,4 @@ FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
41 41
42INHIBIT_SYSROOT_STRIP = "1" 42INHIBIT_SYSROOT_STRIP = "1"
43 43
44COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 44COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.1.bb b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.1.bb
index 7fc13c58..d1fc1f76 100644
--- a/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.1.bb
+++ b/recipes-multimedia/imx-sw-pdm/imx-sw-pdm_1.0.1.bb
@@ -15,4 +15,4 @@ INSANE_SKIP:${PN} = "already-stripped"
15 15
16FILES:${PN} += "${datadir}/imx-mm" 16FILES:${PN} += "${datadir}/imx-mm"
17 17
18COMPATIBLE_MACHINE = "(mx8)" 18COMPATIBLE_MACHINE = "(mx8-nxp-bsp)"
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
index 03702b16..24af9e2b 100644
--- a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.6.2.bb
@@ -8,7 +8,7 @@ SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 8LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa"
9 9
10DEPENDS = "virtual/imxvpu" 10DEPENDS = "virtual/imxvpu"
11DEPENDS:append:mx8mp = " imx-vpu-hantro-vc" 11DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
12 12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}" 13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14 14
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
index 2b995b60..97b5f116 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.0.bb
@@ -15,10 +15,10 @@ S = "${WORKDIR}/git"
15 15
16inherit waf pkgconfig use-imx-headers 16inherit waf pkgconfig use-imx-headers
17 17
18IMX_PLATFORM:mx6 = "imx6" 18IMX_PLATFORM:mx6-nxp-bsp = "imx6"
19IMX_PLATFORM:mx8mq = "imx8m" 19IMX_PLATFORM:mx8mq-nxp-bsp = "imx8m"
20IMX_PLATFORM:mx8mm = "imx8mm" 20IMX_PLATFORM:mx8mm-nxp-bsp = "imx8mm"
21IMX_PLATFORM:mx8mp = "imx8mm" 21IMX_PLATFORM:mx8mp-nxp-bsp = "imx8mm"
22 22
23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}" 23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
24 24
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
index 778514fb..660eed3e 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi_git.bb
@@ -16,6 +16,6 @@ S = "${WORKDIR}/git"
16 16
17inherit waf pkgconfig 17inherit waf pkgconfig
18 18
19COMPATIBLE_MACHINE = "(mx6q|mx6dl)" 19COMPATIBLE_MACHINE = "(mx6q-nxp-bsp|mx6dl-nxp-bsp)"
20 20
21EXTRA_OECONF = "--libdir=${libdir}" 21EXTRA_OECONF = "--libdir=${libdir}"
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/daemon.conf
index 9eb954bb..9eb954bb 100644
--- a/recipes-multimedia/pulseaudio/pulseaudio/imx/daemon.conf
+++ b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/daemon.conf
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/default.pa
index 83a6ba8d..83a6ba8d 100644
--- a/recipes-multimedia/pulseaudio/pulseaudio/imx/default.pa
+++ b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/default.pa
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch
index 57c28741..57c28741 100644
--- a/recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch
+++ b/recipes-multimedia/pulseaudio/pulseaudio/imx-nxp-bsp/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
index ae69be4c..c7a4292e 100644
--- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
@@ -1,13 +1,13 @@
1 1
2CACHED_CONFIGUREVARS:append:mx6 = " ax_cv_PTHREAD_PRIO_INHERIT=no" 2CACHED_CONFIGUREVARS:append:mx6-nxp-bsp = " ax_cv_PTHREAD_PRIO_INHERIT=no"
3 3
4FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/imx:" 4FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/imx-nxp-bsp:"
5 5
6SRC_URI:append:mx6 = " file://daemon.conf file://default.pa" 6SRC_URI:append:mx6-nxp-bsp = " file://daemon.conf file://default.pa"
7SRC_URI:append:mx7 = " file://daemon.conf file://default.pa \ 7SRC_URI:append:mx7-nxp-bsp = " file://daemon.conf file://default.pa \
8 file://pulseaudio-remove-the-control-for-speaker-headphone-widge.patch \ 8 file://pulseaudio-remove-the-control-for-speaker-headphone-widge.patch \
9" 9"
10SRC_URI:append:mx8 = " file://daemon.conf file://default.pa" 10SRC_URI:append:mx8-nxp-bsp = " file://daemon.conf file://default.pa"
11 11
12do_install:append() { 12do_install:append() {
13 if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then 13 if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then
@@ -16,6 +16,6 @@ do_install:append() {
16 fi 16 fi
17} 17}
18 18
19PACKAGE_ARCH:mx6 = "${MACHINE_SOCARCH}" 19PACKAGE_ARCH:mx6-nxp-bsp = "${MACHINE_SOCARCH}"
20PACKAGE_ARCH:mx7 = "${MACHINE_SOCARCH}" 20PACKAGE_ARCH:mx7-nxp-bsp = "${MACHINE_SOCARCH}"
21PACKAGE_ARCH:mx8 = "${MACHINE_SOCARCH}" 21PACKAGE_ARCH:mx8-nxp-bsp = "${MACHINE_SOCARCH}"