diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2021-08-06 16:43:29 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 7377f6c87e351ad702485fee1e9da42690f9f5e8 (patch) | |
tree | e07050278e48824c5e4ef51c210b70cfe093df75 /recipes-multimedia | |
parent | 248273e8ade376d389aa862a26284c90d6bdff9d (diff) | |
download | meta-freescale-7377f6c87e351ad702485fee1e9da42690f9f5e8.tar.gz |
layer: More override fixes
Adds fixes for _imx, _imxdpu, _imxdrm, _imxgpu, _imxgpu3d,
virtual PREFERRED_PROVIDER versions
Fix other places for imx/imxdpu/imxdrm overrides
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/alsa/alsa-lib_%.bbappend | 4 | ||||
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | 4 |
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend index 74fcba8a..d76c45d1 100644 --- a/recipes-multimedia/alsa/alsa-lib_%.bbappend +++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend | |||
@@ -6,6 +6,6 @@ IMX_PATCH = " \ | |||
6 | file://0005-add-ak4458-conf-for-multichannel-support.patch \ | 6 | file://0005-add-ak4458-conf-for-multichannel-support.patch \ |
7 | file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ | 7 | file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ |
8 | " | 8 | " |
9 | SRC_URI:append_imx = "${IMX_PATCH}" | 9 | SRC_URI:append:imx = "${IMX_PATCH}" |
10 | 10 | ||
11 | PACKAGE_ARCH_imx = "${MACHINE_SOCARCH}" | 11 | PACKAGE_ARCH:imx = "${MACHINE_SOCARCH}" |
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb index eefa870a..26f25d72 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.0.0.bb | |||
@@ -28,8 +28,8 @@ inherit pkgconfig meson use-imx-headers | |||
28 | # is needed to improve performance. | 28 | # is needed to improve performance. |
29 | LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false" | 29 | LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false" |
30 | LIBG2D_DEPENDENCIES = "virtual/libg2d" | 30 | LIBG2D_DEPENDENCIES = "virtual/libg2d" |
31 | LIBG2D_DPU_OPTION_imxdpu = "-Dg2d-based-on-dpu=true" | 31 | LIBG2D_DPU_OPTION:imxdpu = "-Dg2d-based-on-dpu=true" |
32 | LIBG2D_DEPENDENCIES_imxdpu = "virtual/libg2d libdrm" | 32 | LIBG2D_DEPENDENCIES:imxdpu = "virtual/libg2d libdrm" |
33 | 33 | ||
34 | EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" | 34 | EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" |
35 | 35 | ||