summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-09-05 08:58:15 -0300
committerGitHub <noreply@github.com>2022-09-05 08:58:15 -0300
commit53710450a793e12912913b29828af21758c347be (patch)
tree331ff4458576731ea9d2723acfc2f72498ec376c /recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
parent774b4924c0e1697b6f9195d865507921329648c2 (diff)
parentcc026b37007884e2118b75fc81cca2c7e83ac0c4 (diff)
downloadmeta-freescale-53710450a793e12912913b29828af21758c347be.tar.gz
Merge pull request #1196 from Freescale/backport-1193-to-kirkstone
[Backport kirkstone] Recipes-multimedia from NXP release 5.15.32-2.0.0
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
new file mode 100644
index 00000000..240eab49
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_git.bb
@@ -0,0 +1,28 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright (C) 2017-2021 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Freescale Multimedia VPU wrapper"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011"
9
10DEPENDS = "virtual/imxvpu"
11DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
12
13SRC_URI = "git://github.com/NXP/imx-vpuwrap.git;protocol=https;branch=${SRCBRANCH}"
14SRCBRANCH = "MM_04.07.00_2205_L5.15.y"
15SRCREV = "0e417b0ade3e55b5fb639d20c419b05aa31ab329"
16
17S = "${WORKDIR}/git"
18
19inherit autotools pkgconfig
20
21do_install:append() {
22 # FIXME: Drop examples for now
23 rm -r ${D}${datadir}
24}
25
26PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28COMPATIBLE_MACHINE = "(imxvpu)"