diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2023-01-10 14:57:01 -0700 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2023-01-10 14:57:01 -0700 |
commit | 724670a663dbe11d98b26f02d2b9911f09f92f3b (patch) | |
tree | 41ab67edd2d903c72fd9287f751aa63065a2a143 /recipes-multimedia/imx-parser/imx-parser_4.7.2.bb | |
parent | 9b4d488ec8455315753e2acf1724b00d0d78a723 (diff) | |
download | meta-freescale-724670a663dbe11d98b26f02d2b9911f09f92f3b.tar.gz |
imx-parser: Upgrade 4.7.1 -> 4.7.2
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.7.2.bb')
-rw-r--r-- | recipes-multimedia/imx-parser/imx-parser_4.7.2.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.7.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.7.2.bb new file mode 100644 index 00000000..004c2417 --- /dev/null +++ b/recipes-multimedia/imx-parser/imx-parser_4.7.2.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | # Copyright (C) 2012-2018 O.S. Systems Software LTDA. | ||
2 | # Copyright (C) 2012-2016 Freescale Semiconductor | ||
3 | # Copyright (C) 2017-2021 NXP | ||
4 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
5 | DESCRIPTION = "Freescale Multimedia parser libs" | ||
6 | LICENSE = "Proprietary" | ||
7 | SECTION = "multimedia" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe" | ||
9 | |||
10 | # For backwards compatibility | ||
11 | PROVIDES += "libfslparser" | ||
12 | RREPLACES:${PN} = "libfslparser" | ||
13 | RPROVIDES:${PN} = "libfslparser" | ||
14 | RCONFLICTS:${PN} = "libfslparser" | ||
15 | |||
16 | SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" | ||
17 | SRC_URI[md5sum] = "b4fee8f21ecef727af00f7106620f44b" | ||
18 | SRC_URI[sha256sum] = "745dbc6c9d28bf380b707f0aeb6dfde02a3bcbb34522640510f8756e945c7320" | ||
19 | |||
20 | inherit fsl-eula-unpack autotools pkgconfig | ||
21 | |||
22 | # Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point | ||
23 | EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \ | ||
24 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}" | ||
25 | |||
26 | INHIBIT_PACKAGE_STRIP = "1" | ||
27 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | ||
28 | |||
29 | python __set_insane_skip() { | ||
30 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
31 | # the source we cannot fix it. Disable the insane check for now. | ||
32 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
33 | for p in d.getVar('PACKAGES').split(): | ||
34 | d.setVar("INSANE_SKIP:%s" % p, "ldflags dev-so textrel") | ||
35 | } | ||
36 | |||
37 | do_package_qa[prefuncs] += "__set_insane_skip" | ||
38 | |||
39 | # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those | ||
40 | FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}" | ||
41 | |||
42 | INHIBIT_SYSROOT_STRIP = "1" | ||
43 | |||
44 | COMPATIBLE_MACHINE = "(imx-nxp-bsp)" | ||