summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-31 21:25:03 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-28 11:08:07 -0300
commitaf2d92397ff26a2b7b55d0170f6599c09487fdfe (patch)
treec2ad4258f787f9ec9c71edd7ba6764b610aa878e /recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
parenta6f56f4cba787f71af1ceaea3f8c78ddcf6f8db2 (diff)
downloadmeta-freescale-af2d92397ff26a2b7b55d0170f6599c09487fdfe.tar.gz
imx-parser: upgrade to 4.5.5
NOTE: This version uses v11 EULA from NXP Following commits are added in this release (including command): $ git log --oneline --no-decorate eff47177..72395663 72395663 MA-17095: MP4 PARSER 06.16.07 6abeb330 MA-16391-2: MP4 PARSER 06.16.06 7a8c66d5 MA-16391: MP4 PARSER 06.16.05 support ENCRYPTED_BYTE_BLOCK, SKIP_BYTE_BLOCK, CRYPTO_IV 6f7d785f MA-17070 MP3 PARSER 03.03.03 8fb0fc1a MA-17026 AAC PARSER 03.01.04 8d04d6cd MA-16982: fix cts android.media.cts.DecoderTest#testDecodeMonoOggMkv 1bc9b758 MA-16969 [Android] Q10_2.0.0 cts MediaMuxerTest#testAllTimestampsBVideoOnly fail efa3c12f MMFMWK-8754 MPEG2 PARSER 05.01.02 fbab3462 MA-16828: fix cts android.media.cts.DecoderTest#testTrackSelectionMkv 2e2ca2ad MA-16684: suppoert av1 video format in mkv parser e9cf3560 [configurea.ac] Update version to 4.5.5 for next release 138ef113 MA-16403 Fix ID3 parser return wrong artwork size 782e91e1 MA-16375 MPEG2 PARSER 05.01.01 57207e77 MMFMWK-8725 MP3 PARSER 03.03.01 48581949 MMFMWK-8650 MPG2 PARSER 04.06.03 2f3da775 [configurea.ac] Update version to 4.5.4 for next release Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> Cc: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 10f3833c3cdba45d9c89bcf093e18791bb037556)
Diffstat (limited to 'recipes-multimedia/imx-parser/imx-parser_4.5.5.bb')
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.5.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb b/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
new file mode 100644
index 00000000..ddc83aa2
--- /dev/null
+++ b/recipes-multimedia/imx-parser/imx-parser_4.5.5.bb
@@ -0,0 +1,46 @@
1# Copyright (C) 2012-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2012-2016 Freescale Semiconductor
3# Copyright (C) 2017, 2019 NXP
4# Released under the MIT license (see COPYING.MIT for the terms)
5DESCRIPTION = "Freescale Multimedia parser libs"
6LICENSE = "Proprietary"
7SECTION = "multimedia"
8LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
9
10# For backwards compatibility
11PROVIDES += "libfslparser"
12RREPLACES_${PN} = "libfslparser"
13RPROVIDES_${PN} = "libfslparser"
14RCONFLICTS_${PN} = "libfslparser"
15
16SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
17SRC_URI[md5sum] = "0845c64d2b64c2822328e8bc8442f5b8"
18SRC_URI[sha256sum] = "33b8377a663b2ca749f40ef1164918335913e4de02a3857f2892707647d243de"
19
20inherit fsl-eula-unpack autotools pkgconfig
21
22# Choose between 32-bit and 64-bit binaries and between Soft Float-Point and Hard Float-Point
23EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8', \
24 bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '--enable-fsw', d), d)}"
25
26INHIBIT_PACKAGE_STRIP = "1"
27INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
28
29python __set_insane_skip() {
30 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
31 # the source we cannot fix it. Disable the insane check for now.
32 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
33 for p in d.getVar('PACKAGES').split():
34 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so textrel")
35}
36
37do_package_qa[prefuncs] += "__set_insane_skip"
38
39# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
40FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
41
42PACKAGE_ARCH = "${MACHINE_ARCH}"
43
44INHIBIT_SYSROOT_STRIP = "1"
45
46COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"