diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-08-02 11:01:05 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-12 10:08:24 -0700 |
commit | 59d36c9832702989bfcca8a5af29fb2dff01efcc (patch) | |
tree | b2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-multimedia/imx-codec | |
parent | 72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff) | |
download | meta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz |
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-multimedia/imx-codec')
-rw-r--r-- | recipes-multimedia/imx-codec/imx-codec_4.5.7.bb | 42 |
1 files changed, 21 insertions, 21 deletions
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.5.7.bb b/recipes-multimedia/imx-codec/imx-codec_4.5.7.bb index 76a52f26..f54721d8 100644 --- a/recipes-multimedia/imx-codec/imx-codec_4.5.7.bb +++ b/recipes-multimedia/imx-codec/imx-codec_4.5.7.bb | |||
@@ -21,14 +21,14 @@ EXTRA_OECONF = "${@bb.utils.contains('TUNE_FEATURES', 'aarch64', '--enable-armv8 | |||
21 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '', d), d)}" | 21 | bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--enable-fhw', '', d), d)}" |
22 | 22 | ||
23 | PACKAGECONFIG ?= "" | 23 | PACKAGECONFIG ?= "" |
24 | PACKAGECONFIG_imxvpu = "vpu" | 24 | PACKAGECONFIG:imxvpu = "vpu" |
25 | 25 | ||
26 | # We need to ensure we don't have '-src' package overrided | 26 | # We need to ensure we don't have '-src' package overrided |
27 | PACKAGE_DEBUG_SPLIT_STYLE = 'debug-without-src' | 27 | PACKAGE_DEBUG_SPLIT_STYLE = 'debug-without-src' |
28 | 28 | ||
29 | PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,virtual/imxvpu" | 29 | PACKAGECONFIG[vpu] = "--enable-vpu,--disable-vpu,virtual/imxvpu" |
30 | 30 | ||
31 | do_install_append() { | 31 | do_install:append() { |
32 | # LTIB move the files around or gst-fsl-plugin won't find them | 32 | # LTIB move the files around or gst-fsl-plugin won't find them |
33 | for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do | 33 | for p in $(find ${D}${libdir}/imx-mm -mindepth 2 -maxdepth 2 -not -type d); do |
34 | mv $p ${D}${libdir} | 34 | mv $p ${D}${libdir} |
@@ -46,15 +46,15 @@ python __set_insane_skip() { | |||
46 | for p in d.getVar('PACKAGES').split(): | 46 | for p in d.getVar('PACKAGES').split(): |
47 | # Even though we are packaging libraries those are plugins so we | 47 | # Even though we are packaging libraries those are plugins so we |
48 | # shouldn't rename the packages to follow its sonames. | 48 | # shouldn't rename the packages to follow its sonames. |
49 | d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1") | 49 | d.setVar("DEBIAN_NOAUTONAME:%s" % p, "1") |
50 | 50 | ||
51 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | 51 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have |
52 | # the source we cannot fix it. Disable the insane check for now. | 52 | # the source we cannot fix it. Disable the insane check for now. |
53 | if p == 'imx-codec-test-bin': | 53 | if p == 'imx-codec-test-bin': |
54 | # FIXME: includes the DUT .so files so we need to deploy those | 54 | # FIXME: includes the DUT .so files so we need to deploy those |
55 | d.setVar("INSANE_SKIP_%s" % p, "ldflags textrel libdir file-rdeps") | 55 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel libdir file-rdeps") |
56 | else: | 56 | else: |
57 | d.setVar("INSANE_SKIP_%s" % p, "ldflags textrel") | 57 | d.setVar("INSANE_SKIP:%s" % p, "ldflags textrel") |
58 | } | 58 | } |
59 | 59 | ||
60 | do_package_qa[prefuncs] += "__set_insane_skip" | 60 | do_package_qa[prefuncs] += "__set_insane_skip" |
@@ -70,13 +70,13 @@ python __split_libfslcodec_plugins() { | |||
70 | for pkg in pkgs: | 70 | for pkg in pkgs: |
71 | meta = pkg[10:] | 71 | meta = pkg[10:] |
72 | if meta != '': | 72 | if meta != '': |
73 | d.setVar('RREPLACES_%s' % pkg, ' libfslcodec-%s' % meta) | 73 | d.setVar('RREPLACES:%s' % pkg, ' libfslcodec-%s' % meta) |
74 | d.setVar('RPROVIDES_%s' % pkg, ' libfslcodec-%s' % meta) | 74 | d.setVar('RPROVIDES:%s' % pkg, ' libfslcodec-%s' % meta) |
75 | d.setVar('RCONFLICTS_%s' % pkg, ' libfslcodec-%s' % meta) | 75 | d.setVar('RCONFLICTS:%s' % pkg, ' libfslcodec-%s' % meta) |
76 | else : | 76 | else : |
77 | d.setVar('RREPLACES_%s' % pkg, ' libfslcodec') | 77 | d.setVar('RREPLACES:%s' % pkg, ' libfslcodec') |
78 | d.setVar('RPROVIDES_%s' % pkg, ' libfslcodec') | 78 | d.setVar('RPROVIDES:%s' % pkg, ' libfslcodec') |
79 | d.setVar('RCONFLICTS_%s' % pkg, ' libfslcodec') | 79 | d.setVar('RCONFLICTS:%s' % pkg, ' libfslcodec') |
80 | } | 80 | } |
81 | 81 | ||
82 | python __set_metapkg_rdepends() { | 82 | python __set_metapkg_rdepends() { |
@@ -85,7 +85,7 @@ python __set_metapkg_rdepends() { | |||
85 | codec_pkgs = oe.utils.packages_filter_out_system(d) | 85 | codec_pkgs = oe.utils.packages_filter_out_system(d) |
86 | codec_pkgs = filter(lambda x: x not in ['imx-codec-test-bin', 'imx-codec-test-source'], | 86 | codec_pkgs = filter(lambda x: x not in ['imx-codec-test-bin', 'imx-codec-test-source'], |
87 | codec_pkgs) | 87 | codec_pkgs) |
88 | d.appendVar('RDEPENDS_imx-codec-meta', ' ' + ' '.join(codec_pkgs)) | 88 | d.appendVar('RDEPENDS:imx-codec-meta', ' ' + ' '.join(codec_pkgs)) |
89 | } | 89 | } |
90 | 90 | ||
91 | PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends" | 91 | PACKAGESPLITFUNCS =+ "__split_libfslcodec_plugins __set_metapkg_rdepends" |
@@ -96,24 +96,24 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | |||
96 | 96 | ||
97 | PACKAGES += "${PN}-meta ${PN}-test-bin ${PN}-test-source" | 97 | PACKAGES += "${PN}-meta ${PN}-test-bin ${PN}-test-source" |
98 | 98 | ||
99 | ALLOW_EMPTY_${PN} = "1" | 99 | ALLOW_EMPTY:${PN} = "1" |
100 | ALLOW_EMPTY_${PN}-meta = "1" | 100 | ALLOW_EMPTY:${PN}-meta = "1" |
101 | 101 | ||
102 | # Ensure we get warnings if we miss something | 102 | # Ensure we get warnings if we miss something |
103 | FILES_${PN} = "" | 103 | FILES:${PN} = "" |
104 | 104 | ||
105 | FILES_${PN}-dev += "${libdir}/imx-mm/*/*${SOLIBSDEV} \ | 105 | FILES:${PN}-dev += "${libdir}/imx-mm/*/*${SOLIBSDEV} \ |
106 | ${libdir}/imx-mm/*/*/*${SOLIBSDEV} \ | 106 | ${libdir}/imx-mm/*/*/*${SOLIBSDEV} \ |
107 | ${libdir}/pkgconfig/*.pc ${includedir}/imx-mm/*" | 107 | ${libdir}/pkgconfig/*.pc ${includedir}/imx-mm/*" |
108 | 108 | ||
109 | FILES_${PN}-test-bin += "${datadir}/imx-mm/*/examples/*/bin" | 109 | FILES:${PN}-test-bin += "${datadir}/imx-mm/*/examples/*/bin" |
110 | 110 | ||
111 | FILES_${PN}-test-source += "${datadir}/imx-mm/*" | 111 | FILES:${PN}-test-source += "${datadir}/imx-mm/*" |
112 | 112 | ||
113 | # FIXME: The wrap and lib names does not match | 113 | # FIXME: The wrap and lib names does not match |
114 | FILES_${PN}-oggvorbis += "${libdir}/imx-mm/audio-codec/wrap/lib_vorbisd_wrap_arm*_elinux.so.*" | 114 | FILES:${PN}-oggvorbis += "${libdir}/imx-mm/audio-codec/wrap/lib_vorbisd_wrap_arm*_elinux.so.*" |
115 | FILES_${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux.so.*" | 115 | FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux.so.*" |
116 | FILES_${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" | 116 | FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" |
117 | 117 | ||
118 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 118 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
119 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" | 119 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" |