summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-codec
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
committerAndré Draszik <andre.draszik@jci.com>2019-01-17 14:29:17 +0000
commit74df05a7f0fd698cbbe65b9bf925f186891426ca (patch)
tree169665d86e12f2aa2d6df71a856c1893267972d7 /recipes-multimedia/imx-codec
parent9704df97f08cf5895e2f5bcfb33f1a53d10c7704 (diff)
downloadmeta-freescale-74df05a7f0fd698cbbe65b9bf925f186891426ca.tar.gz
remove True option to getVar calls
getVar() has been defaulting to expanding by default for a long time (2016), thus remove the True option from getVar() calls with a regex search and replace. Search & replace made using the following command: sed -e 's|\(d\.getVar \?\)( \?\([^,()]*\), \?True)|\1(\2)|g' \ -i $(git grep -E 'getVar ?\( ?([^,()]*), ?True\)' \ | cut -d':' -f1 \ | sort -u) Signed-off-by: André Draszik <andre.draszik@jci.com>
Diffstat (limited to 'recipes-multimedia/imx-codec')
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.4.2.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
index 60a3717e..39860c86 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
+++ b/recipes-multimedia/imx-codec/imx-codec_4.4.2.bb
@@ -43,7 +43,7 @@ python __set_insane_skip() {
43 # Ensure we have PACKAGES expanded 43 # Ensure we have PACKAGES expanded
44 bb.build.exec_func("read_subpackage_metadata", d) 44 bb.build.exec_func("read_subpackage_metadata", d)
45 45
46 for p in d.getVar('PACKAGES', True).split(): 46 for p in d.getVar('PACKAGES').split():
47 # Even though we are packaging libraries those are plugins so we 47 # Even though we are packaging libraries those are plugins so we
48 # shouldn't rename the packages to follow its sonames. 48 # shouldn't rename the packages to follow its sonames.
49 d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1") 49 d.setVar("DEBIAN_NOAUTONAME_%s" % p, "1")
@@ -66,7 +66,7 @@ python __split_libfslcodec_plugins() {
66 output_pattern='imx-codec-%s', 66 output_pattern='imx-codec-%s',
67 description='Freescale i.MX Codec (%s)', 67 description='Freescale i.MX Codec (%s)',
68 extra_depends='') 68 extra_depends='')
69 pkgs = d.getVar('PACKAGES', True).split() 69 pkgs = d.getVar('PACKAGES').split()
70 for pkg in pkgs: 70 for pkg in pkgs:
71 meta = pkg[10:] 71 meta = pkg[10:]
72 if meta != '': 72 if meta != '':