summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-06-06 11:44:25 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-06 10:56:47 -0300
commite8035f3ff486a8546152cb9cd0b870023ce44d51 (patch)
tree909a51b8132ca33d48e1f9d708fcfb25b663100a /recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb
parentf66e95cbddcaae0a41e5399b4956c5137cf9fa63 (diff)
downloadmeta-freescale-e8035f3ff486a8546152cb9cd0b870023ce44d51.tar.gz
imx-gst1.0-plugin: Upgrade to v4.3.4
gplay: fix cpu loading high when in background gplay: disable subtitle when use dcss or dpu vpudec: add fullRange to HDR10 metadata Add direct build dependency on libdrm as vpu in imx-gst1.0 plugin includes drm_fourcc.h when doing compile. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb')
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb
new file mode 100644
index 00000000..d166ec36
--- /dev/null
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.3.4.bb
@@ -0,0 +1,86 @@
1# Copyright (C) 2014,2016 Freescale Semiconductor
2# Copyright 2017 NXP
3# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia"
9
10DEPENDS = "imx-codec imx-parser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
11DEPENDS_append_mx6 = " imx-lib"
12DEPENDS_append_mx7 = " imx-lib"
13DEPENDS_append_imxvpu = " imx-vpuwrap libdrm"
14
15# For backwards compatibility
16RREPLACES_${PN} = "gst1.0-fsl-plugin"
17RPROVIDES_${PN} = "gst1.0-fsl-plugin"
18RCONFLICTS_${PN} = "gst1.0-fsl-plugin"
19
20LIC_FILES_CHKSUM = "file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
21 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
22
23IMXGST_SRC ?= "git://source.codeaurora.org/external/imx/imx-gst1.0-plugin.git;protocol=https"
24SRCBRANCH = "MM_04.03.04_1801_L4.9.51_MX8M_GA"
25
26SRC_URI = "${IMXGST_SRC};branch=${SRCBRANCH}"
27SRCREV = "bd40c49abd6494c6439f37c8c7ec5e275576c761"
28
29S = "${WORKDIR}/git"
30
31inherit autotools pkgconfig
32
33# Make sure kernel sources are available
34do_configure[depends] += "virtual/kernel:do_shared_workdir"
35
36PLATFORM_mx6 = "MX6"
37PLATFORM_mx6sl = "MX6SL"
38PLATFORM_mx6sx = "MX6SX"
39PLATFORM_mx6ul = "MX6UL"
40PLATFORM_mx6sll = "MX6SLL"
41PLATFORM_mx7= "MX7D"
42PLATFORM_mx7ulp= "MX7ULP"
43PLATFORM_mx8 = "MX8"
44
45# Todo add a mechanism to map possible build targets
46EXTRA_OECONF = "PLATFORM=${PLATFORM} \
47 CPPFLAGS="-I${STAGING_KERNEL_BUILDDIR}/include/generated/uapi -I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \
48 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
49 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', bb.utils.contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
50
51PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
52
53# Add codec list that the beep plugin run-time depended
54BEEP_RDEPENDS = "imx-codec-aac imx-codec-mp3 imx-codec-oggvorbis"
55RDEPENDS_${PN} += "imx-parser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
56
57# overlaysink rely on G2D,
58# cannot be supported on i.MX6SLL & i.MX6UL & i.MX6ULL & i.MX7D
59PACKAGECONFIG ?= ""
60PACKAGECONFIG_imxgpu2d = "overlaysink"
61
62
63# FIXME: Add all features
64# feature from excluded mm packages
65PACKAGECONFIG[ac3] += ",,imx-ac3codec,imx-ac3codec"
66# feature from special mm packages
67PACKAGECONFIG[aacp] += ",,imx-aacpcodec,imx-aacpcodec"
68MSDEPENDS = "imx-msparser imx-mscodec"
69PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
70PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
71OVDEPENDS = "virtual/libg2d"
72PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
73
74FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
75
76FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
77FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
78FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
79FILES_${PN}-gplay = "${bindir}/gplay-1.0"
80FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
81FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
82FILES_${PN}-grecorder = "${bindir}/grecorder-1.0"
83FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
84FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
85
86COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"