summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
diff options
context:
space:
mode:
authorCristinel Panfir <cristinel.panfir@nxp.com>2019-12-20 13:17:37 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-20 16:54:20 -0300
commitd2f3022132187c7ac4dcd47a96f2f11b336b5d71 (patch)
tree64120fe862844174621fe04e381053ac3ddc02c7 /recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
parent08332c833b69a46e99621b68a67d04443c93e906 (diff)
downloadmeta-freescale-d2f3022132187c7ac4dcd47a96f2f11b336b5d71.tar.gz
gstreamer1.0: Upgrade to 1.16.0
- Switch to MM_04.05.01_1909_L4.19.35 branch. - Drop GST_PROTECTION_UNSPECIFIED_SYSTEM_ID patches, those are included in 1.16 source code. Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
new file mode 100644
index 00000000..8924033e
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.16.imx.bb
@@ -0,0 +1,76 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native elfutils"
10
11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13# This way common/m4/introspection.m4 will come first
14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
15acpaths = "-I ${S}/common/m4 -I ${S}/m4"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
18 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
19
20# Use i.MX fork of GST for customizations
21GST1.0_SRC ?= "gitsm://source.codeaurora.org/external/imx/gstreamer.git;protocol=https"
22SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
23
24SRC_URI = " \
25 ${GST1.0_SRC};branch=${SRCBRANCH} \
26 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
27 file://gtk-doc-tweaks.patch \
28 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
29"
30SRCREV = "a4c220605ac0923596b89f4f07c05d235bc09259"
31
32DEFAULT_PREFERENCE = "-1"
33
34EXTRA_AUTORECONF = ""
35
36PACKAGECONFIG ??= ""
37
38PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
39PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
40PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
41PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
42
43EXTRA_OECONF = " \
44 --disable-dependency-tracking \
45 --disable-examples \
46"
47
48CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no"
49
50# musl libc generates warnings if <sys/poll.h> is included directly
51CACHED_CONFIGUREVARS += "ac_cv_header_sys_poll_h=no"
52
53PACKAGES += "${PN}-bash-completion"
54
55FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
56FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
57FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
58
59RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
60RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
61
62delete_pkg_m4_file() {
63 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
64 rm "${S}/common/m4/pkg.m4" || true
65 rm -f "${S}/common/m4/gtk-doc.m4"
66}
67
68do_configure[prefuncs] += "delete_pkg_m4_file"
69
70do_compile_prepend() {
71 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs"
72}
73
74S = "${WORKDIR}/git"
75
76COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"