summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-03-29 13:11:32 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-04-04 16:57:41 -0500
commit200e8ad05248ef0bdc64a6eb869817a39aac21e9 (patch)
tree4c313007dcb98d9ff3cdca8c486873f9b55f9da8 /recipes-multimedia/gstreamer/gstreamer1.0
parent36589d57ee3fa9d3aac891f42c16d45622b00750 (diff)
downloadmeta-freescale-200e8ad05248ef0bdc64a6eb869817a39aac21e9.tar.gz
gstreamer1.0: Upgrade 1.18.0.imx -> 1.18.5.imx
Also separate the base recipe copy from the overrides for ease of maintenance. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch18
1 files changed, 8 insertions, 10 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch b/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
index 96abef17..5805e8b6 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
+++ b/recipes-multimedia/gstreamer/gstreamer1.0/0002-Remove-unused-valgrind-detection.patch
@@ -1,7 +1,7 @@
1From 598d108e2c438d8f2ecd3bf948fa3ebbd3681490 Mon Sep 17 00:00:00 2001 1From d7f05d09c55d35bbe4e0f856759519ef183d9a56 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com> 2From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com>
3Date: Fri, 14 Aug 2020 16:38:26 +0100 3Date: Fri, 14 Aug 2020 16:38:26 +0100
4Subject: [PATCH 2/3] Remove unused valgrind detection 4Subject: [PATCH] Remove unused valgrind detection
5 5
6Having this just to log a debug message in case we're 6Having this just to log a debug message in case we're
7running inside valgrind doesn't seem very useful, and 7running inside valgrind doesn't seem very useful, and
@@ -12,6 +12,7 @@ Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/59
12Upstream-Status: Backport [a2cbf75523cdf8a4df1baa7007d86ef455972245] 12Upstream-Status: Backport [a2cbf75523cdf8a4df1baa7007d86ef455972245]
13 13
14Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com> 14Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
15
15--- 16---
16 gst/gst_private.h | 2 -- 17 gst/gst_private.h | 2 --
17 gst/gstinfo.c | 39 --------------------------------------- 18 gst/gstinfo.c | 39 ---------------------------------------
@@ -32,12 +33,12 @@ index eefd044d9..8252ede51 100644
32 G_GNUC_INTERNAL void _priv_gst_quarks_initialize (void); 33 G_GNUC_INTERNAL void _priv_gst_quarks_initialize (void);
33 G_GNUC_INTERNAL void _priv_gst_mini_object_initialize (void); 34 G_GNUC_INTERNAL void _priv_gst_mini_object_initialize (void);
34diff --git a/gst/gstinfo.c b/gst/gstinfo.c 35diff --git a/gst/gstinfo.c b/gst/gstinfo.c
35index 5d317877b..097f8b20d 100644 36index eea1a219d..d3035d6db 100644
36--- a/gst/gstinfo.c 37--- a/gst/gstinfo.c
37+++ b/gst/gstinfo.c 38+++ b/gst/gstinfo.c
38@@ -305,36 +305,6 @@ static gboolean pretty_tags = PRETTY_TAGS_DEFAULT; 39@@ -305,36 +305,6 @@ static gboolean pretty_tags = PRETTY_TAGS_DEFAULT;
39 static volatile gint G_GNUC_MAY_ALIAS __default_level = GST_LEVEL_DEFAULT; 40 static gint G_GNUC_MAY_ALIAS __default_level = GST_LEVEL_DEFAULT;
40 static volatile gint G_GNUC_MAY_ALIAS __use_color = GST_DEBUG_COLOR_MODE_ON; 41 static gint G_GNUC_MAY_ALIAS __use_color = GST_DEBUG_COLOR_MODE_ON;
41 42
42-/* FIXME: export this? */ 43-/* FIXME: export this? */
43-gboolean 44-gboolean
@@ -82,7 +83,7 @@ index 5d317877b..097f8b20d 100644
82 env = g_getenv ("GST_DEBUG_OPTIONS"); 83 env = g_getenv ("GST_DEBUG_OPTIONS");
83 if (env != NULL) { 84 if (env != NULL) {
84 if (strstr (env, "full_tags") || strstr (env, "full-tags")) 85 if (strstr (env, "full_tags") || strstr (env, "full-tags"))
85@@ -2503,12 +2470,6 @@ gst_debug_construct_win_color (guint colorinfo) 86@@ -2505,12 +2472,6 @@ gst_debug_construct_win_color (guint colorinfo)
86 return 0; 87 return 0;
87 } 88 }
88 89
@@ -96,7 +97,7 @@ index 5d317877b..097f8b20d 100644
96 _gst_debug_dump_mem (GstDebugCategory * cat, const gchar * file, 97 _gst_debug_dump_mem (GstDebugCategory * cat, const gchar * file,
97 const gchar * func, gint line, GObject * obj, const gchar * msg, 98 const gchar * func, gint line, GObject * obj, const gchar * msg,
98diff --git a/meson.build b/meson.build 99diff --git a/meson.build b/meson.build
99index ce1921aa4..7a84d0981 100644 100index 82a17282b..42ae61790 100644
100--- a/meson.build 101--- a/meson.build
101+++ b/meson.build 102+++ b/meson.build
102@@ -200,7 +200,6 @@ check_headers = [ 103@@ -200,7 +200,6 @@ check_headers = [
@@ -107,6 +108,3 @@ index ce1921aa4..7a84d0981 100644
107 'sys/resource.h', 108 'sys/resource.h',
108 'sys/uio.h', 109 'sys/uio.h',
109 ] 110 ]
110--
1112.29.2
112