summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
diff options
context:
space:
mode:
authorJose Quaresma <jose.quaresma@foundries.io>2023-03-10 11:01:33 +0000
committerJose Quaresma <jose.quaresma@foundries.io>2023-03-10 11:17:50 +0000
commitdb5b46f714bb14a7daa77e20c0121c3e2ba68580 (patch)
tree9155ca31104ab67f811952097a34e3156bebfd07 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
parentba70f6a7139b16984e4e6e29f24dfe86582d09b4 (diff)
downloadmeta-freescale-db5b46f714bb14a7daa77e20c0121c3e2ba68580.tar.gz
gstreamer: rename the version to be imx specific
These recipes are copies of oe-core 1.20.3 that are not available anymore upstream on the master branch. The requirement to have them is because they are dependencies of the other ones imx specific gstreamer forks on the layer. So make their names maching the exisng ones will make it more safe. Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
new file mode 100644
index 00000000..d961c5af
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
@@ -0,0 +1,53 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2require recipes-multimedia/gstreamer/gstreamer1.0-plugins-license.inc
3
4DESCRIPTION = "'Ugly GStreamer plugins"
5HOMEPAGE = "https://gstreamer.freedesktop.org/"
6BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly/-/issues"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
9 file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068"
10
11LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
12LICENSE_FLAGS = "commercial"
13
14SRC_URI = " \
15 https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.xz \
16 "
17SRC_URI[sha256sum] = "8caa20789a09c304b49cf563d33cca9421b1875b84fcc187e4a385fa01d6aefd"
18
19S = "${WORKDIR}/gst-plugins-ugly-${PV}"
20
21DEPENDS += "gstreamer1.0-plugins-base"
22
23GST_PLUGIN_SET_HAS_EXAMPLES = "0"
24
25PACKAGECONFIG ??= " \
26 ${GSTREAMER_ORC} \
27 a52dec mpeg2dec \
28"
29
30PACKAGECONFIG[amrnb] = "-Damrnb=enabled,-Damrnb=disabled,opencore-amr"
31PACKAGECONFIG[amrwb] = "-Damrwbdec=enabled,-Damrwbdec=disabled,opencore-amr"
32PACKAGECONFIG[a52dec] = "-Da52dec=enabled,-Da52dec=disabled,liba52"
33PACKAGECONFIG[cdio] = "-Dcdio=enabled,-Dcdio=disabled,libcdio"
34PACKAGECONFIG[dvdread] = "-Ddvdread=enabled,-Ddvdread=disabled,libdvdread"
35PACKAGECONFIG[mpeg2dec] = "-Dmpeg2dec=enabled,-Dmpeg2dec=disabled,mpeg2dec"
36PACKAGECONFIG[x264] = "-Dx264=enabled,-Dx264=disabled,x264"
37
38GSTREAMER_GPL = "${@bb.utils.filter('PACKAGECONFIG', 'a52dec cdio dvdread mpeg2dec x264', d)}"
39
40EXTRA_OEMESON += " \
41 -Ddoc=disabled \
42 -Dsidplay=disabled \
43"
44
45FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
46FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"
47
48# These recipes are copies of oe-core 1.20.3 that are not available
49# anymore upstream on the master branch.
50# The requirement to have them is because they are dependencies of
51# the other ones imx specific gstreamer forks on the layer.
52# So make their names maching the exisng ones will make it more safe.
53COMPATIBLE_MACHINE = "(imx-nxp-bsp)"