summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-03-07 15:29:13 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2023-03-08 06:12:33 +0000
commitb70890533963c59f4f7a72891da4287cdb7a704a (patch)
treee987a2a4e0d58128e6c840a3095e308868adc4ea /recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb
parentadf69723cf24f81697aa363a093e939f642e60ab (diff)
downloadmeta-freescale-b70890533963c59f4f7a72891da4287cdb7a704a.tar.gz
gstreamer: add recipes for upstream 1.20.3 versions
oe-core has moved to gstreamer 1.22.0 and recipes which don't have an imx version can no longer be built. Add older version of those components to be used with the gstreamer 1.20.3.imx. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb
new file mode 100644
index 00000000..9511984e
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb
@@ -0,0 +1,48 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2require recipes-multimedia/gstreamer/gstreamer1.0-plugins-license.inc
3
4DESCRIPTION = "'Ugly GStreamer plugins"
5HOMEPAGE = "https://gstreamer.freedesktop.org/"
6BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly/-/issues"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
9 file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068"
10
11LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later"
12LICENSE_FLAGS = "commercial"
13
14SRC_URI = " \
15 https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-${PV}.tar.xz \
16 "
17SRC_URI[sha256sum] = "8caa20789a09c304b49cf563d33cca9421b1875b84fcc187e4a385fa01d6aefd"
18
19S = "${WORKDIR}/gst-plugins-ugly-${PV}"
20
21DEPENDS += "gstreamer1.0-plugins-base"
22
23GST_PLUGIN_SET_HAS_EXAMPLES = "0"
24
25PACKAGECONFIG ??= " \
26 ${GSTREAMER_ORC} \
27 a52dec mpeg2dec \
28"
29
30PACKAGECONFIG[amrnb] = "-Damrnb=enabled,-Damrnb=disabled,opencore-amr"
31PACKAGECONFIG[amrwb] = "-Damrwbdec=enabled,-Damrwbdec=disabled,opencore-amr"
32PACKAGECONFIG[a52dec] = "-Da52dec=enabled,-Da52dec=disabled,liba52"
33PACKAGECONFIG[cdio] = "-Dcdio=enabled,-Dcdio=disabled,libcdio"
34PACKAGECONFIG[dvdread] = "-Ddvdread=enabled,-Ddvdread=disabled,libdvdread"
35PACKAGECONFIG[mpeg2dec] = "-Dmpeg2dec=enabled,-Dmpeg2dec=disabled,mpeg2dec"
36PACKAGECONFIG[x264] = "-Dx264=enabled,-Dx264=disabled,x264"
37
38GSTREAMER_GPL = "${@bb.utils.filter('PACKAGECONFIG', 'a52dec cdio dvdread mpeg2dec x264', d)}"
39
40EXTRA_OEMESON += " \
41 -Ddoc=disabled \
42 -Dsidplay=disabled \
43"
44
45FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
46FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"
47
48COMPATIBLE_MACHINE = "(imx-nxp-bsp)"