summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2022-05-11 07:56:54 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2022-06-16 17:01:16 -0300
commit90a162ed22dc6b99bead9be1b326843a1200ae6b (patch)
treeae0a93d414e8ed5aaf1012af6824ecbeee5d8bfb /recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
parentecd2701d519354f2ff57e207a86127d1d87b9eef (diff)
downloadmeta-freescale-90a162ed22dc6b99bead9be1b326843a1200ae6b.tar.gz
gstreamer1.0-plugins-imx: Upgrade to version 2.1.0
* meson: * New sysroot option in case the external sysroot property is unusable Normally, this option should not be needed. However, with some BSPs whose sysroot properties are broken, having this option is useful. * Reduce minimum required Meson version from 0.54.0 to 0.53.2 This is mainly introduced for Yocto Dunfell support. (Meson <0.54 requires the new sysroot property though.) * Cleanup deprecated code * imx2d: UYVY and YUYV formats are supported by G2D if it is emulated on top of the DPU (found in i.MX8 QuadMax and i.MX8 QuadXPlus SocS). * vpu: * Correctly handle case when a stream buffer is not needed * Disable frame reordering if it is not needed * imxvpudec_h264 needs au alignment to guarantee complete frames * Unlock decoder_context on fatal error while decoding * v4l2video: * v4l2videosrc: Skip allocation pools with NULL buffer pool Prevents assertions like: gst_buffer_pool_has_option: assertion 'GST_IS_BUFFER_POOL (pool)' failed See: https://github.com/Freescale/gstreamer-imx/issues/304 * v4l2videosrc: Skip allocation params with NULL allocator Prevents assertions like: gst_object_unref: assertion 'object != NULL' failed See: https://github.com/Freescale/gstreamer-imx/issues/304 * v4l2videosrc: Use correct ioctl for frame intervals * Minor logging fixes Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
new file mode 100644
index 00000000..fb18f1bb
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
@@ -0,0 +1,62 @@
1# Copyright (C) 2018 O.S. Systems Software LTDA.
2DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
3LICENSE = "LGPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia"
6DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libimxdmabuffer"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
10# built (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS)
11RDEPENDS:gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
12RDEPENDS:gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
13RDEPENDS:gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
14
15PV .= "+git${SRCPV}"
16
17SRCBRANCH ?= "master"
18SRCREV = "b1e5cca1a6df9d2c0dc505ae222775798108d340"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20
21S = "${WORKDIR}/git"
22
23inherit pkgconfig meson use-imx-headers
24
25# libg2d on i.MX8 SoCs with a DPU is emulated via the DPU.
26# That particular libg2d .so depends on libdrm, however.
27# Also, due to behavioral differences, an additional flag
28# is needed to improve performance.
29LIBG2D_DPU_OPTION = "-Dg2d-based-on-dpu=false"
30LIBG2D_DEPENDENCIES = "virtual/libg2d"
31LIBG2D_DPU_OPTION:imxdpu = "-Dg2d-based-on-dpu=true"
32LIBG2D_DEPENDENCIES:imxdpu = "virtual/libg2d libdrm"
33
34EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}"
35
36PACKAGECONFIG ?= "uniaudiodec"
37PACKAGECONFIG:append:imxgpu2d = " g2d"
38PACKAGECONFIG:append:imxvpu = " vpu"
39PACKAGECONFIG:append:imxipu = " ipu"
40PACKAGECONFIG:append:imxpxp = " pxp"
41# The custom imxv4l2 elements are only available on the i.MX6.
42# The 2D blitter sinks require an MXC framebuffer, which
43# is not available anymore on the i.MX8 (since these SoCs
44# now use KMS instead of the old Linux framebuffer).
45PACKAGECONFIG:append:mx6-nxp-bsp = " imx2dvideosink v4l2"
46PACKAGECONFIG:append:mx7-nxp-bsp = " imx2dvideosink"
47
48PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
49PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
50PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
51PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
52PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
53PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false,"
54PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
55PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
56
57require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
58
59# the following line is required to produce one package for each plugin
60PACKAGES_DYNAMIC = "^${PN}-.*"
61
62COMPATIBLE_MACHINE = "(mx6dl-nxp-bsp|mx6q-nxp-bsp|mx6sl-nxp-bsp|mx6sx-nxp-bsp|mx6ul-nxp-bsp|mx6ull-nxp-bsp|mx7d-nxp-bsp|mx8-nxp-bsp)"