summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <crg7475@mailbox.org>2020-04-24 09:05:45 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-24 08:13:12 -0300
commitc3bdc608728223ac6d215da616196afea57168cd (patch)
treed331afceb8425777367bd547d752ce43b6300fd7 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
parent5d7e6fbe0e82895ec0b007b6e4dc725c26af290b (diff)
downloadmeta-freescale-c3bdc608728223ac6d215da616196afea57168cd.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.13.1
* Last planned release in the 0.x series. Development now focuses on 2.x. The 2.x series will support i.MX6, i.MX7, and i.MX8. * OE recipe fix to use the correct G2D dependency (imxg2d, not imx-gpu-viv) * waf: Update to version 2.0.12 and switch to Python 3 * misc: * gst_buffer_pool_config_set_allocator() and get_allocator() are transfer-none. Changes to the code address that, fixing various refcount related problems. * Update GstPhysMemoryAllocator support for GStreamer 1.14+ * v4l2video: * v4l2src: Set interlace flags in GstBuffer * v4l2sink: Define V4L2_COLORSPACE_DEFAULT if it doesn't exist * v4l2: Add phys mem meta only if the driver/card is known to support this This makes USB video cameras work with imxv4l2videosrc, because they do not provide any physical address. * v4l2_buffer_pool: First reset the buffer storage in the pool, then queue the buffer. Otherwise it might happen that we dequeue the same buffer in a different thread already *before* we have it reset in the buffer storage, and then run into an assertion because it contains NULL. * vpu: * decoder: Fix for an endless loop at gst_imx_vpu_decoder_finish() when in no_wait mode * decoder: Clear the GST_VIDEO_BUFFER_FLAG_TFF flag in case of IMX_VPU_INTERLACING_MODE_BOTTOM_FIELD_FIRST * decoder: Honour num-additional-framebuffers setting * decoder: Fix leak when input video formats change due to a missing gst_imx_vpu_decoder_close() call * ipu: Reintroduce interlace methods * audio: * Save pointer to codec_data GstBuffer to fix memory leak * Only allocate reordered_channel_positions if needed. If we don't need to reorder the audio channels, we the unnecessary allocation otherwise. * g2dpango: * Add missing header and cleanup a few warnings * Unref video_frame memory after phys_memory check Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
new file mode 100644
index 00000000..35996337
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.13.1.bb
@@ -0,0 +1,71 @@
1# Copyright (C) 2018 O.S. Systems Software LTDA.
2DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
3LICENSE = "LGPLv2+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
5SECTION = "multimedia"
6# gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the
7# GstPhotography headers and libraries
8DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
9# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
10# for the uniaudio decoder, videoparsersbad for the VPU video decoder
11# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is
12# build (it is not a compile-time dependency however, hence RDEPENDS and not DEPENDS)
13RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good"
14RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
15RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
16
17PV .= "+git${SRCPV}"
18
19SRCBRANCH ?= "master"
20SRCREV = "805987bff74af13fcb14ff111955206f1c92554d"
21SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
22
23S = "${WORKDIR}/git"
24
25inherit pkgconfig waf use-imx-headers
26
27# configure the eglvivsink element to use the appropriate EGL platform code
28# Wayland if 'wayland' is present in DISTRO_FEATURES, if not,
29# X11 if x11 is present in DISTRO_FEATURES,
30# Framebuffer otherwise
31EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
32 bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
33 'fb', d),d)}"
34
35EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"
36
37EXTRA_OECONF = "--kernel-headers=${STAGING_INCDIR_IMX} ${PACKAGECONFIG_CONFARGS}"
38
39EGLVIVSINK_DEPENDS = " \
40 virtual/egl virtual/libgles2 \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \
42 bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', \
43 '', d), d)} \
44"
45
46PACKAGECONFIG ?= "uniaudiodec mp3encoder v4l2src v4l2sink"
47PACKAGECONFIG_append_imxgpu3d = " eglvivsink"
48PACKAGECONFIG_append_imxgpu2d = " g2d g2dpango"
49PACKAGECONFIG_append_imxipu = " ipu"
50PACKAGECONFIG_append_imxvpu = " vpu"
51PACKAGECONFIG_append_imxpxp = " pxp"
52
53PACKAGECONFIG[g2d] = ",--disable-g2d,imx-gpu-g2d"
54PACKAGECONFIG[g2dpango] = ",--disable-g2dpango,imx-gpu-g2d pango"
55PACKAGECONFIG[pxp] = ",--disable-pxp,"
56PACKAGECONFIG[ipu] = ",--disable-ipu,"
57PACKAGECONFIG[vpu] = ",--disable-vpu,libimxvpuapi"
58PACKAGECONFIG[eglvivsink] = "${EGL_PLATFORM_CONF},--disable-eglvivsink,${EGLVIVSINK_DEPENDS}"
59PACKAGECONFIG[v4l2src] = ",--disable-imxv4l2videosrc,"
60PACKAGECONFIG[v4l2sink] = ",--disable-imxv4l2videosink,"
61PACKAGECONFIG[uniaudiodec] = ",--disable-uniaudiodec,imx-codec"
62PACKAGECONFIG[mp3encoder] = ",--disable-mp3encoder,imx-codec"
63
64# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
65LIBV = "1.0"
66require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
67
68# the following line is required to produce one package for each plugin
69PACKAGES_DYNAMIC = "^${PN}-.*"
70
71COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d)"