summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-02-22 14:23:56 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-03-03 18:26:17 -0300
commitf7608795ce9273090257f47015e367b7efc69989 (patch)
treee64baeb3ef2dfb42ee3f03735585683aef5f4ffe /recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch
parentcbb7c31aedcb45c813fd1bf5ad071e1ca08bea68 (diff)
downloadmeta-freescale-f7608795ce9273090257f47015e367b7efc69989.tar.gz
gstreamer1.0-plugins-base: Transition to meson based builds
Update gstreamer base plugins to meson build system. This update follows the strategy and description provided in commit [e957fbc5d82368934f721e3773bf3942c5177ed7] from upstream. Autotools patches are dropped from the layer and additional meson-relevant patches are introduced from upstream. In addition, patch required to support meson build of NXP fork is included. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch
deleted file mode 100644
index 23950b67..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/make-gio_unix_2_0-dependency-configurable.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 7ffa6e3d00e1d8a060f3f4c2bb9a72691af05d79 Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Wed, 20 Jan 2016 13:00:00 -0800
4Subject: [PATCH] make gio_unix_2_0 dependency configurable
5
6Prior to 1.7.1, gst-plugins-base accepted a configure option to
7disable gio_unix_2_0, however it was implemented incorrectly using
8AG_GST_CHECK_FEATURE. That was fixed in 1.7.1 by making the
9dependency unconditional.
10
11 http://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=aadefefba88afe4acbe64454650f24e7ce7c8d70
12
13To make builds deterministic, re-instate support for
14--disable-gio_unix_2_0, but implement it using the AC_ARG_ENABLE
15instead of AG_GST_CHECK_FEATURE.
16
17Upstream-Status: Pending
18
19Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
20
21---
22 configure.ac | 7 +++++++
23 1 file changed, 7 insertions(+)
24
25diff --git a/configure.ac b/configure.ac
26index 12807bc..35a0bf3 100644
27--- a/configure.ac
28+++ b/configure.ac
29@@ -806,9 +806,16 @@ AM_CONDITIONAL(HAVE_PNG, test "x$HAVE_PNG" = "xyes")
30 AM_CONDITIONAL(HAVE_JPEG, test "x$HAVE_JPEG" = "xyes")
31
32 dnl *** gio-unix-2.0 for tests/check/pipelines/tcp.c ***
33+AC_ARG_ENABLE([gio_unix_2_0],
34+ [AS_HELP_STRING([--disable-gio_unix_2_0],[disable use of gio_unix_2_0])],
35+ [],
36+ [enable_gio_unix_2_0=yes])
37+
38+if test "x${enable_gio_unix_2_0}" != "xno"; then
39 PKG_CHECK_MODULES(GIO_UNIX_2_0, gio-unix-2.0 >= 2.24,
40 HAVE_GIO_UNIX_2_0="yes",
41 HAVE_GIO_UNIX_2_0="no")
42+fi
43 AM_CONDITIONAL(USE_GIO_UNIX_2_0, test "x$HAVE_GIO_UNIX_2_0" = "xyes")
44
45 dnl *** finalize CFLAGS, LDFLAGS, LIBS