summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/alsa
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2016-04-18 22:57:46 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-05-07 10:07:46 -0300
commit2e38b338f1cdd1cadbf30b6df674238e52b6afbd (patch)
treee77c957c62630121b775d3e79c075f6d2419e9b4 /recipes-multimedia/alsa
parent15aa9c466d0011294c2b88c616d3a5f5dfdc14f1 (diff)
downloadmeta-freescale-2e38b338f1cdd1cadbf30b6df674238e52b6afbd.tar.gz
imx-alsa-plugins: Upgrade to v1.0.26
--Change the recipe name from "fsl-alsa-plugins" to "imx-alsa-plugins" --Add RREPLACE/RPROVIDES/RCONFLICTS for backwards compatibility. --Remove 0001-asrc_pair-update-output-buffer-size.patch as it has been integrated into the package. Change-Id: Id533118f7edbaa560b7a5e8afce4842e9a0971eb Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/alsa')
-rw-r--r--recipes-multimedia/alsa/fsl-alsa-plugins/0001-asrc_pair-update-output-buffer-size.patch47
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb (renamed from recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb)15
2 files changed, 8 insertions, 54 deletions
diff --git a/recipes-multimedia/alsa/fsl-alsa-plugins/0001-asrc_pair-update-output-buffer-size.patch b/recipes-multimedia/alsa/fsl-alsa-plugins/0001-asrc_pair-update-output-buffer-size.patch
deleted file mode 100644
index d76c74d4..00000000
--- a/recipes-multimedia/alsa/fsl-alsa-plugins/0001-asrc_pair-update-output-buffer-size.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From 9acab46fe307ec71d4a4dbe447e356f90b6a4a09 Mon Sep 17 00:00:00 2001
2From: Shengjiu Wang <shengjiu.wang@freescale.com>
3Date: Fri, 12 Dec 2014 14:58:06 +0800
4Subject: [PATCH] [asrc_pair] update output buffer size
5
6When input size larger than DMA_MAX_BYTES the output size should be updated.
7Otherwise the asrc have will not have enough data, then it will be timeout.
8
9Upstream Status: Inappropriate [platform specific]
10
11Signed-off-by: Shengjiu Wang <shengjiu.wang@freescale.com>
12---
13 asrc/asrc_pair.c | 11 ++++++++---
14 1 file changed, 8 insertions(+), 3 deletions(-)
15
16diff --git a/asrc/asrc_pair.c b/asrc/asrc_pair.c
17index e3df027..e74e8b1 100644
18--- a/asrc/asrc_pair.c
19+++ b/asrc/asrc_pair.c
20@@ -139,7 +139,7 @@ asrc_pair *asrc_pair_create(unsigned int channels, ssize_t in_period_frames,
21 config.dma_buffer_size = dma_buffer_size;
22 config.input_sample_rate = in_rate;
23 config.output_sample_rate = out_rate;
24- config.buffer_num = 1;
25+ config.buffer_num = buf_num;
26 config.input_word_width = ASRC_WIDTH_16_BIT;
27 config.output_word_width = ASRC_WIDTH_16_BIT;
28 config.inclk = INCLK_NONE;
29@@ -303,8 +303,13 @@ void asrc_pair_convert_s16(asrc_pair *pair, const int16_t *src, unsigned int src
30
31 while (src_left > 0)
32 {
33- in_len = src_left > pair->buf_size ? pair->buf_size : src_left;
34- out_len = dst_left;
35+ if (src_left > pair->buf_size) {
36+ in_len = pair->buf_size;
37+ out_len = dst_left * in_len/src_left;
38+ } else {
39+ in_len = src_left;
40+ out_len = dst_left;
41+ }
42
43 buf_info.input_buffer_vaddr = s;
44 buf_info.input_buffer_length = in_len;
45--
461.9.1
47
diff --git a/recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 2959c7a6..5ed1fb5e 100644
--- a/recipes-multimedia/alsa/fsl-alsa-plugins_1.0.25.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -1,4 +1,4 @@
1# Copyright (C) 2013 Freescale Semiconductor 1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4DESCRIPTION = "Freescale alsa-lib plugins" 4DESCRIPTION = "Freescale alsa-lib plugins"
@@ -6,6 +6,11 @@ LICENSE = "GPLv2"
6SECTION = "multimedia" 6SECTION = "multimedia"
7DEPENDS = "alsa-lib virtual/kernel" 7DEPENDS = "alsa-lib virtual/kernel"
8 8
9# For backwards compatibility
10RREPLACES_${PN} = "fsl-alsa-plugins"
11RPROVIDES_${PN} = "fsl-alsa-plugins"
12RCONFLICTS_${PN} = "fsl-alsa-plugins"
13
9# Make sure kernel sources are available 14# Make sure kernel sources are available
10do_configure[depends] += "virtual/kernel:do_shared_workdir" 15do_configure[depends] += "virtual/kernel:do_shared_workdir"
11 16
@@ -14,12 +19,8 @@ LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
14inherit autotools pkgconfig 19inherit autotools pkgconfig
15 20
16SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz" 21SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz"
17SRC_URI[md5sum] = "b1ca7a250a8cd5da07062081b30b4118" 22SRC_URI[md5sum] = "8fe4bcfddeca82dd01a9c4c6ce9471df"
18SRC_URI[sha256sum] = "902df92255d755e8eb08b3c3db0c7b9d70d26d9659b219373bee425ffdc34245" 23SRC_URI[sha256sum] = "0a7e8d90fdde2f6780605ecfee674e6e13523915a7bcd64078bc507ac1a8deb8"
19
20SRC_URI_append_mx6 = " file://0001-asrc_pair-update-output-buffer-size.patch"
21SRC_URI_append_mx6ul = " file://0001-asrc_pair-update-output-buffer-size.patch"
22SRC_URI_append_mx7 = " file://0001-asrc_pair-update-output-buffer-size.patch"
23 24
24INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" 25INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
25 26