diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-25 22:44:12 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-10-26 14:23:37 -0300 |
commit | bc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch) | |
tree | ce4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-multimedia/alsa | |
parent | 700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff) | |
download | meta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz |
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The
usual use for this is to share SoC specific packages among different
boards independently of the kernel version it is using, as far it is
ABI compatible with the official version it will just work.
Following recipes has been reworked to make use of the class:
- imx-lib
- imx-test
- imx-vpu-hantro
- imx-vpu
- imx-alsa-plugins
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-imx
- imx-gst1.0-plugin
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/alsa')
-rw-r--r-- | recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb | 7 |
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb index 62aff0fb..c96a8835 100644 --- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb +++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb | |||
@@ -4,7 +4,7 @@ | |||
4 | DESCRIPTION = "Freescale alsa-lib plugins" | 4 | DESCRIPTION = "Freescale alsa-lib plugins" |
5 | LICENSE = "GPLv2" | 5 | LICENSE = "GPLv2" |
6 | SECTION = "multimedia" | 6 | SECTION = "multimedia" |
7 | DEPENDS = "alsa-lib linux-imx-headers" | 7 | DEPENDS = "alsa-lib" |
8 | 8 | ||
9 | # For backwards compatibility | 9 | # For backwards compatibility |
10 | PROVIDES += "fsl-alsa-plugins" | 10 | PROVIDES += "fsl-alsa-plugins" |
@@ -14,7 +14,7 @@ RCONFLICTS_${PN} = "fsl-alsa-plugins" | |||
14 | 14 | ||
15 | LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f" | 15 | LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f" |
16 | 16 | ||
17 | inherit autotools pkgconfig | 17 | inherit autotools pkgconfig use-imx-headers |
18 | 18 | ||
19 | SRCBRANCH = "nxp/master" | 19 | SRCBRANCH = "nxp/master" |
20 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" | 20 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" |
@@ -22,7 +22,7 @@ SRCREV = "9a63071e7734bd164017f3761b8d1944c017611f" | |||
22 | 22 | ||
23 | S = "${WORKDIR}/git" | 23 | S = "${WORKDIR}/git" |
24 | 24 | ||
25 | INCLUDE_DIR = "-I${STAGING_INCDIR}/imx" | 25 | INCLUDE_DIR = "-I${STAGING_INCDIR_IMX}" |
26 | 26 | ||
27 | EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}"" | 27 | EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}"" |
28 | 28 | ||
@@ -33,4 +33,3 @@ FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug" | |||
33 | FILES_${PN}-dev += "${libdir}/alsa-lib/*.la" | 33 | FILES_${PN}-dev += "${libdir}/alsa-lib/*.la" |
34 | 34 | ||
35 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)" | 35 | COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)" |
36 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||