summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-10-25 22:44:12 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-26 14:23:37 -0300
commitbc937ade566528cc097c9321694c0f5f5ef8cbf6 (patch)
treece4a1a56a5082f9c5f6d849963f5bbef4f993733 /recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
parent700abd5d1b9ce55de5c62a8d0a82c08aa6cd6897 (diff)
downloadmeta-freescale-bc937ade566528cc097c9321694c0f5f5ef8cbf6.tar.gz
classes/use-imx-headers: Easy linux-imx-headers use
This allow to easy reuse of binary packages among similar SoCs. The usual use for this is to share SoC specific packages among different boards independently of the kernel version it is using, as far it is ABI compatible with the official version it will just work. Following recipes has been reworked to make use of the class: - imx-lib - imx-test - imx-vpu-hantro - imx-vpu - imx-alsa-plugins - gstreamer1.0-plugins-base - gstreamer1.0-plugins-imx - imx-gst1.0-plugin Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb')
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 62aff0fb..c96a8835 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -4,7 +4,7 @@
4DESCRIPTION = "Freescale alsa-lib plugins" 4DESCRIPTION = "Freescale alsa-lib plugins"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6SECTION = "multimedia" 6SECTION = "multimedia"
7DEPENDS = "alsa-lib linux-imx-headers" 7DEPENDS = "alsa-lib"
8 8
9# For backwards compatibility 9# For backwards compatibility
10PROVIDES += "fsl-alsa-plugins" 10PROVIDES += "fsl-alsa-plugins"
@@ -14,7 +14,7 @@ RCONFLICTS_${PN} = "fsl-alsa-plugins"
14 14
15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f" 15LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
16 16
17inherit autotools pkgconfig 17inherit autotools pkgconfig use-imx-headers
18 18
19SRCBRANCH = "nxp/master" 19SRCBRANCH = "nxp/master"
20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}" 20SRC_URI = "git://source.codeaurora.org/external/imx/imx-alsa-plugins.git;protocol=https;branch=${SRCBRANCH}"
@@ -22,7 +22,7 @@ SRCREV = "9a63071e7734bd164017f3761b8d1944c017611f"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25INCLUDE_DIR = "-I${STAGING_INCDIR}/imx" 25INCLUDE_DIR = "-I${STAGING_INCDIR_IMX}"
26 26
27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}"" 27EXTRA_OECONF = "CFLAGS="${INCLUDE_DIR}""
28 28
@@ -33,4 +33,3 @@ FILES_${PN}-dbg += "${libdir}/alsa-lib/.debug"
33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la" 33FILES_${PN}-dev += "${libdir}/alsa-lib/*.la"
34 34
35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)" 35COMPATIBLE_MACHINE = "(mx6dl|mx6q|mx6sl|mx6sx|mx6ul|mx6ull|mx7d|mx7ulp)"
36PACKAGE_ARCH = "${MACHINE_SOCARCH}"