summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-05 11:01:27 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-01-25 16:30:35 -0200
commit48ace56f12ac0daa67ceb98bd9563d89e7ff0242 (patch)
treeb0a9fde110fac421730e723c7042580543e3af82 /recipes-kernel
parent8cb61858d6aa22bd03c2f8608eabe0fc02540111 (diff)
downloadmeta-freescale-48ace56f12ac0daa67ceb98bd9563d89e7ff0242.tar.gz
linux-qoriq_4.9: ${KERNEL_PACKAGE_NAME} replaces original key "kernel"
*update RDEPENDS to match kernel naming The kernel class now sets RDEPENDS_${KERNEL_PACKAGE_NAME}-base so this include needs to do the same, otherwise bitbake emits a warning and the kernel isn't removed. *FILES_${KERNEL_PACKAGE_NAME}-image () replaces original key FILES_kernel-image Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb
index 3e058c21..84888e05 100644
--- a/recipes-kernel/linux/linux-qoriq_4.9.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.9.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15DEPENDS_append = " libgcc" 15DEPENDS_append = " libgcc"
16# not put Images into /boot of rootfs, install kernel-image if needed 16# not put Images into /boot of rootfs, install kernel-image if needed
17RDEPENDS_kernel-base = "" 17RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
18 18
19KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" 19KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
20KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" 20KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
@@ -60,5 +60,5 @@ do_install_append_qoriq-arm() {
60 ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage 60 ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage
61} 61}
62 62
63FILES_kernel-image += "/boot/zImage*" 63FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
64COMPATIBLE_MACHINE = "(qoriq)" 64COMPATIBLE_MACHINE = "(qoriq)"