summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-05-22 20:22:53 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-25 09:42:11 -0300
commitd76de0c2fb8f6556f9dbdd49ba465d05ee9a143f (patch)
tree19bdae30f2f6ba08a18ba7d73049cc5163f6d052 /recipes-kernel
parent6b6e49349269a8d6bab09b8214034a930c4a2d02 (diff)
downloadmeta-freescale-d76de0c2fb8f6556f9dbdd49ba465d05ee9a143f.tar.gz
linux-imx-headers: fix imx headers missing in sdk
i.MX-specific headers are missing in SDK once generated via image do_populate_sdk task. This was caused by dropped ALLOW_EMPTY package-controlling variable which is required for this recipe in order to indicate that package can have RDEPENDS. Additional RDEPENDS are also required by packages using new mechanisms to include linux-imx-headers, this allows headers to be propagated to the SDK when dependent package is included. Introduce ALLOW_EMPTY in recipe and RDEPENDS in use-imx-headers bbclass to have imx headers to be populated in the SDK. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx-headers_5.4.3.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_5.4.3.bb b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
index 8d52233d..4257c41a 100644
--- a/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
+++ b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
@@ -59,6 +59,14 @@ do_install() {
59 done 59 done
60} 60}
61 61
62# Allow to build empty main package, this is required in order for -dev package
63# to be propagated into the SDK
64#
65# Without this setting the RDEPENDS in other recipes fails to find this
66# package, therefore causing the -dev package also to be skipped effectively not
67# populating it into SDK
68ALLOW_EMPTY_${PN} = "1"
69
62INHIBIT_DEFAULT_DEPS = "1" 70INHIBIT_DEFAULT_DEPS = "1"
63DEPENDS += "unifdef-native bison-native rsync-native" 71DEPENDS += "unifdef-native bison-native rsync-native"
64 72