diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2020-10-16 20:15:50 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-10-16 19:25:42 -0300 |
commit | 05ccae0dbdaa7c96d33e7c955578afb8d990519a (patch) | |
tree | f0efcb69948ba66d897657e006b6cd7db4e05bca /recipes-kernel | |
parent | 9d5bf93c7a768e92283a2ef019e0a0be909e9fde (diff) | |
download | meta-freescale-05ccae0dbdaa7c96d33e7c955578afb8d990519a.tar.gz |
linux-fslc-imx: update to v5.4.71
Kernel repository has been upgraded to v5.4.71 from stable korg.
Following commits are included in this version:
----
85b0841aab15 Linux 5.4.71
22e6625babfc net_sched: commit action insertions together
a5de4ee6d055 net_sched: defer tcf_idr_insert() in tcf_action_init_1()
dbb763107d3e net: usb: rtl8150: set random MAC address when set_ethernet_addr() fails
6c9edf2d855a Input: ati_remote2 - add missing newlines when printing module parameters
536c767b14e3 net/mlx5e: Fix driver's declaration to support GRE offload
8dc5025c6a44 net/tls: race causes kernel panic
a42dbd059ef6 net/core: check length before updating Ethertype in skb_mpls_{push,pop}
e39c9eba9bef tcp: fix receive window update in tcp_add_backlog()
2729afe17987 mm: khugepaged: recalculate min_free_kbytes after memory hotplug as expected by khugepaged
d94c1505fa91 mmc: core: don't set limits.discard_granularity as 0
760c7a948bea perf: Fix task_function_call() error handling
b750f86a62d1 rxrpc: Fix server keyring leak
ae1a085b4aac rxrpc: The server keyring isn't network-namespaced
513dd1609c9d rxrpc: Fix some missing _bh annotations on locking conn->state_lock
422f5c5d3ef9 rxrpc: Downgrade the BUG() for unsupported token type in rxrpc_read()
7e1f39b5c1d5 rxrpc: Fix rxkad token xdr encoding
9a52da3f61b4 net/mlx5e: Fix VLAN create flow
6b9752d85e72 net/mlx5e: Fix VLAN cleanup flow
47e83c69fe14 net/mlx5e: Add resiliency in Striding RQ mode for packets larger than MTU
1e7a94724b78 net/mlx5: Fix request_irqs error flow
073fff810206 net/mlx5: Avoid possible free of command entry while timeout comp handler
0955c774f32d virtio-net: don't disable guest csum when disable LRO
15f84bdf6185 net: usb: ax88179_178a: fix missing stop entry in driver_info
70877d04d41f r8169: fix RTL8168f/RTL8411 EPHY config
7a96cbd74fcd mlxsw: spectrum_acl: Fix mlxsw_sp_acl_tcam_group_add()'s error path
f3b35c3782ed mdio: fix mdio-thunder.c dependency & build error
8d103b1f9ce5 bonding: set dev->needed_headroom in bond_setup_by_slave()
3ce96a55b756 net: ethernet: cavium: octeon_mgmt: use phy_start and phy_stop
e987ea087fd2 iavf: Fix incorrect adapter get in iavf_resume
029ced5cce89 iavf: use generic power management
84ab35eacdf2 xfrm: Use correct address family in xfrm_state_find
4d3edb2e4d6e platform/x86: fix kconfig dependency warning for FUJITSU_LAPTOP
dd2786a3e521 net: stmmac: removed enabling eee in EEE set callback
e9a12de5a2be xfrm: clone whole liftime_cur structure in xfrm_do_migrate
7ea7436c406c xfrm: clone XFRMA_SEC_CTX in xfrm_do_migrate
c1becfebe33e xfrm: clone XFRMA_REPLAY_ESN_VAL in xfrm_do_migrate
0bea401a9a5a xfrm: clone XFRMA_SET_MARK in xfrm_do_migrate
f825fd534f8b iommu/vt-d: Fix lockdep splat in iommu_flush_dev_iotlb()
bdffb36bcd38 drm/amdgpu: prevent double kfree ttm->sg
4034664a733e openvswitch: handle DNAT tuple collision
f89128ad358e net: team: fix memory leak in __team_options_register
003269d8d6de team: set dev->needed_headroom in team_setup_by_port()
fb3681c20fbf sctp: fix sctp_auth_init_hmacs() error path
040e3110d49c i2c: owl: Clear NACK and BUS error bits
abe997f632d1 i2c: meson: fixup rate calculation with filter delay
6db69c390622 i2c: meson: fix clock setting overwrite
209549c1c0f0 cifs: Fix incomplete memory allocation on setxattr path
0afdda28eb2b xfrmi: drop ignore_df check before updating pmtu
49af88ac6534 nvme-tcp: check page by sendpage_ok() before calling kernel_sendpage()
15cac17d9d39 tcp: use sendpage_ok() to detect misused .sendpage
d23dd3864b4c net: introduce helper sendpage_ok() in include/linux/net.h
5c62d335317c mm/khugepaged: fix filemap page_to_pgoff(page) != offset
1317469fa05b macsec: avoid use-after-free in macsec_handle_frame()
20f96fee81c6 nvme-core: put ctrl ref when module ref get fail
c0f3c5386995 btrfs: allow btrfs_truncate_block() to fallback to nocow for data space reservation
e531fd7f8b3a btrfs: fix RWF_NOWAIT write not failling when we need to cow
1f90600e259b btrfs: Ensure we trim ranges across block group boundary
6a0f5da2db3b btrfs: volumes: Use more straightforward way to calculate map length
5aefd1fa9f4d Btrfs: send, fix emission of invalid clone operations within the same file
19d8412679f2 Btrfs: send, allow clone operations within the same file
f02dc39bbb20 arm64: dts: stratix10: add status to qspi dts node
e8e1d16e0b89 i2c: i801: Exclude device from suspend direct complete optimization
2118c7ba5f2a perf top: Fix stdio interface input handling with glibc 2.28+
2499c15115ac perf test session topology: Fix data path
7c1847aa4932 driver core: Fix probe_count imbalance in really_probe()
3fd2647f9d68 platform/x86: thinkpad_acpi: re-initialize ACPI buffer size when reuse
da4cdc87dfeb platform/x86: intel-vbtn: Switch to an allow-list for SW_TABLET_MODE reporting
6440fb9bda91 bpf: Prevent .BTF section elimination
67a57230b4bf bpf: Fix sysfs export of empty BTF section
9bd694ccfd44 platform/x86: thinkpad_acpi: initialize tp_nvram_state variable
d101961ce588 platform/x86: intel-vbtn: Fix SW_TABLET_MODE always reporting 1 on the HP Pavilion 11 x360
2293272345ff Platform: OLPC: Fix memleak in olpc_ec_probe
ce8432912f1b usermodehelper: reset umask to default before executing user process
920a61ddd3b5 vhost: Use vhost_get_used_size() in vhost_vring_set_addr()
57b47abc1a4a vhost: Don't call access_ok() when using IOTLB
456d77c1bdfa drm/nouveau/mem: guard against NULL pointer access in mem_del
8ece83bf754f net: wireless: nl80211: fix out-of-bounds access in nl80211_del_key()
ee413b2915bf io_uring: Fix double list add in io_queue_async_work()
efb1cef27d59 io_uring: Fix remove irrelevant req from the task_list
75524f753318 io_uring: Fix missing smp_mb() in io_cancel_async_work()
d9e81b2fb372 io_uring: Fix resource leaking when kill the process
4f46ef7bec86 Revert "ravb: Fixed to be able to unload modules"
1b2fcd82c0ca fbcon: Fix global-out-of-bounds read in fbcon_get_font()
f51ec3fd7128 Fonts: Support FONT_EXTRA_WORDS macros for built-in fonts
eebe3685701b fbdev, newport_con: Move FONT_EXTRA_WORDS macros into linux/font.h
----
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_5.4.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb index 940076b4..33aa7071 100644 --- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb +++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb | |||
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v5.4.70 | 31 | # tag: v5.4.71 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
@@ -73,17 +73,17 @@ LICENSE = "GPLv2" | |||
73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 73 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
74 | 74 | ||
75 | SRCBRANCH = "5.4-2.1.x-imx" | 75 | SRCBRANCH = "5.4-2.1.x-imx" |
76 | SRCREV = "2d1241e38347784c5328fc45e790c435c78b4583" | 76 | SRCREV = "4236f3c63f99cbd22601f4158f8a6166688af5b3" |
77 | 77 | ||
78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 78 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
79 | # required by kernel-yocto.bbclass. | 79 | # required by kernel-yocto.bbclass. |
80 | # | 80 | # |
81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 81 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
82 | # should be updated once patchlevel is merged. | 82 | # should be updated once patchlevel is merged. |
83 | LINUX_VERSION = "5.4.70" | 83 | LINUX_VERSION = "5.4.71" |
84 | 84 | ||
85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. | 85 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. |
86 | LOCALVERSION = "-imx_5.4.24_2.1.0" | 86 | LOCALVERSION = "-imx-5.4.24-2.1.0" |
87 | 87 | ||
88 | DEFAULT_PREFERENCE = "1" | 88 | DEFAULT_PREFERENCE = "1" |
89 | 89 | ||