diff options
author | Gary Thomas <gary@mlbassoc.com> | 2015-10-06 10:03:47 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:20 -0300 |
commit | 6e12eca32dc1316689a74f929e334f02feac06ab (patch) | |
tree | 3245277ccd3ce0d7b922adad1f6628af84f0d8d2 /recipes-kernel | |
parent | aed74dcf5c43b5a7dd78ee7ec705558b947e34d4 (diff) | |
download | meta-freescale-6e12eca32dc1316689a74f929e334f02feac06ab.tar.gz |
kernel-module-imx-gpu-viv: Better work-around for change in name of busfreq-imx.h
The renaming of include/linux/busfreq-imx6.h to include/linux/busfreq-imx.h
is not consistent over the many kernel versions currently being built. This
changeset works around this inconsistency by creating a local symbolic link
to whatever file is actually present in the kernel sources.
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Diffstat (limited to 'recipes-kernel')
3 files changed, 38 insertions, 36 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch deleted file mode 100644 index 3dc06176..00000000 --- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | From 617bdbec386a1237e2a148989318cc4a1360788a Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Tue, 18 Aug 2015 23:08:48 +0000 | ||
4 | Subject: [PATCH] platform: Fix kernel version check for 3.14-based kernels | ||
5 | Organization: O.S. Systems Software LTDA. | ||
6 | |||
7 | The build fail about the bus frequency header (linux/busfreq-imx6.h) | ||
8 | not being found is caused by the mistaken check for the wrong kernel | ||
9 | version. | ||
10 | |||
11 | This patch fixes it by adding the right kernel version to be checked. | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
16 | --- | ||
17 | .../os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c b/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
21 | index a2e72ff..241614a 100644 | ||
22 | --- a/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
23 | +++ b/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
24 | @@ -40,7 +40,7 @@ | ||
25 | #include <linux/pm_runtime.h> | ||
26 | #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0) | ||
27 | #include <mach/busfreq.h> | ||
28 | -#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 14, 0) | ||
29 | +#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 15, 0) | ||
30 | #include <linux/busfreq-imx6.h> | ||
31 | #include <linux/reset.h> | ||
32 | #else | ||
33 | -- | ||
34 | 2.1.4 | ||
35 | |||
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/work-around-include-file-rename.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/work-around-include-file-rename.patch new file mode 100644 index 00000000..5b923924 --- /dev/null +++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/work-around-include-file-rename.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 3ec514cf260b82f4701b6fed521ce470d9faf8c9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Gary Thomas <gary@mlbassoc.com> | ||
3 | Date: Tue, 6 Oct 2015 09:32:22 -0600 | ||
4 | Subject: [PATCH] kernel-module-imx-gpu-viv: Better work-around for change in name of busfreq-imx.h | ||
5 | |||
6 | The renaming of include/linux/busfreq-imx6.h to include/linux/busfreq-imx.h | ||
7 | is not consistent over the many kernel versions currently being built. This | ||
8 | changeset works around this inconsistency by creating a local symbolic link | ||
9 | to whatever file is actually present in the kernel sources. | ||
10 | |||
11 | Signed-off-by: Gary Thomas <gary@mlbassoc.com> | ||
12 | Upstream-status: Innapropriate [requires OE recipe support] | ||
13 | ---- | ||
14 | Index: kernel-module-imx-gpu-viv-5.0.11.p7.1/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
15 | =================================================================== | ||
16 | --- kernel-module-imx-gpu-viv-5.0.11.p7.1.orig/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
17 | +++ kernel-module-imx-gpu-viv-5.0.11.p7.1/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | ||
18 | @@ -74,11 +74,8 @@ | ||
19 | #include <linux/pm_runtime.h> | ||
20 | #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0) | ||
21 | #include <mach/busfreq.h> | ||
22 | -#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 14, 0) | ||
23 | -#include <linux/busfreq-imx6.h> | ||
24 | -#include <linux/reset.h> | ||
25 | #else | ||
26 | -#include <linux/busfreq-imx.h> | ||
27 | +#include "busfreq-imx.h" | ||
28 | #include <linux/reset.h> | ||
29 | #endif | ||
30 | #endif | ||
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb index 3218b4e5..7e8414b3 100644 --- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb +++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb | |||
@@ -10,7 +10,14 @@ inherit module | |||
10 | 10 | ||
11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz \ | 11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz \ |
12 | file://updatemakefile.patch \ | 12 | file://updatemakefile.patch \ |
13 | file://platform-Fix-kernel-version-check-for-3.14-based-ker.patch" | 13 | file://work-around-include-file-rename.patch \ |
14 | " | ||
14 | 15 | ||
15 | SRC_URI[md5sum] = "a251a94390986371f75b338ad938e46f" | 16 | SRC_URI[md5sum] = "a251a94390986371f75b338ad938e46f" |
16 | SRC_URI[sha256sum] = "9aaef0a62bc2be69dc568228192b060c54970b5c700fee602d83a4d13e04a9b3" | 17 | SRC_URI[sha256sum] = "9aaef0a62bc2be69dc568228192b060c54970b5c700fee602d83a4d13e04a9b3" |
18 | |||
19 | # Work around inconsistent naming of <linux/busfreq-imx.h> | ||
20 | do_compile_prepend () { | ||
21 | ln -sf ${STAGING_KERNEL_DIR}/include/linux/busfreq-imx*.h kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/busfreq-imx.h | ||
22 | } | ||
23 | |||