summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-06-14 11:54:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-06-23 10:49:15 -0300
commit21b9f1e354d9df1b9a7381d4c11de42157eff2c0 (patch)
treed09472fbe26c75a05893654a2ec530898bc67532 /recipes-kernel
parent84bda66788bb25b9c100c5384ad296450aaabe22 (diff)
downloadmeta-freescale-21b9f1e354d9df1b9a7381d4c11de42157eff2c0.tar.gz
Move some recipes to dynamic-layers folder
The following packages depend on extend Yocto community layers, move related recipes to dynamic-layers. * ipsec-demo asf fmc usdpaa-apps web-sysmon Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/asf/asf_git.bb37
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
deleted file mode 100644
index 34308e2d..00000000
--- a/recipes-kernel/asf/asf_git.bb
+++ /dev/null
@@ -1,37 +0,0 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=sdk-v1.9.x"
7SRCREV = "9580a629d3aec3ab3c5e152c6693846b96787906"
8
9RDEPENDS_${PN} += "ipsec-tools"
10
11inherit module qoriq_build_64bit_kernel
12
13S = "${WORKDIR}/git/asfmodule"
14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
16export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
17
18INHIBIT_PACKAGE_STRIP = "1"
19
20do_configure[depends] += "virtual/kernel:do_shared_workdir"
21do_configure_prepend () {
22 find ${S} -name Makefile -exec \
23 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
24}
25
26do_install(){
27 install -d ${D}/${libexecdir}
28 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
30 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
31 cp -rf ${S}/../scripts ${D}/${libexecdir}/
32 find ${D}/lib -depth -type d -exec rmdir --ignore-fail-on-non-empty {} \;
33}
34
35FILES_${PN} += "${libexecdir}"
36
37COMPATIBLE_MACHINE = "(qoriq)"