summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-02-11 17:32:16 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2023-04-12 20:09:28 -0300
commit88399694f0d4bd8da30b562ba69a6e9d76d5046c (patch)
treef0176429493ef7e01f5158ae8e9628d78ad4f9d0 /recipes-kernel
parent56ba9c32d6b3029fb1c2b3fc8ea8778d62f396a8 (diff)
downloadmeta-freescale-88399694f0d4bd8da30b562ba69a6e9d76d5046c.tar.gz
linux-*-mfgtool, u-boot-*-mfgtool: Remove specific recipesrework/remove-mfgtool-specific-recipes
The use of a specific recipes are not need anymore. For the U-Boot specific case, the UBOOT_CONFIG mechanism allows multiple binaries using different configurations so we can remove this recipes and default to the IMX_DEFAULT_BOOTLOADER as provider. The Linux specific case is completely unnecessary as the USB gadget is supported in all versions we support. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb15
-rw-r--r--recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb15
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_6.1.bb15
-rw-r--r--recipes-kernel/linux/linux-imx.inc3
-rw-r--r--recipes-kernel/linux/linux-mfgtool.inc7
5 files changed, 3 insertions, 52 deletions
diff --git a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb
deleted file mode 100644
index 95dd72fb..00000000
--- a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3
4SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc-lts_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb b/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb
deleted file mode 100644
index 09d35c91..00000000
--- a/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3
4SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb b/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb
deleted file mode 100644
index 26298fd9..00000000
--- a/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright (C) 2017-2023 NXP
4
5SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
6DESCRIPTION = "Linux Kernel provided and supported by NXP that produces a \
7Manufacturing Tool compatible Linux Kernel to be used in updater environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-imx:"
10require linux-imx_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-imx.inc b/recipes-kernel/linux/linux-imx.inc
index b386e058..1a37bf20 100644
--- a/recipes-kernel/linux/linux-imx.inc
+++ b/recipes-kernel/linux/linux-imx.inc
@@ -11,6 +11,9 @@ LOCALVERSION ?= ""
11SCMVERSION ?= "y" 11SCMVERSION ?= "y"
12SRCBRANCH ?= "" 12SRCBRANCH ?= ""
13 13
14# Allow use of kernel as linux-mfgtool provider.
15PROVIDES += "linux-mfgtool"
16
14# Set the PV to the correct kernel version to satisfy the kernel version sanity check 17# Set the PV to the correct kernel version to satisfy the kernel version sanity check
15PV = "${LINUX_VERSION}+git${SRCPV}" 18PV = "${LINUX_VERSION}+git${SRCPV}"
16 19
diff --git a/recipes-kernel/linux/linux-mfgtool.inc b/recipes-kernel/linux/linux-mfgtool.inc
deleted file mode 100644
index 93a27d8c..00000000
--- a/recipes-kernel/linux/linux-mfgtool.inc
+++ /dev/null
@@ -1,7 +0,0 @@
1# Produces a Manufacturing Tool compatible Linux Kernel
2#
3# Copyright (C) 2014, 2015, 2018 O.S. Systems Software LTDA.
4
5PROVIDES = "linux-mfgtool"
6
7KERNEL_PACKAGE_NAME = "linux-mfgtool"