summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorDominic Sacré <dominic.sacre@gmx.de>2016-11-21 16:53:25 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2016-11-23 08:09:34 -0200
commit5495f2b9bc4d90c9f4197574a547df43c664a928 (patch)
treeaa3097999885af5231af41d093fbbee2cbc0ea83 /recipes-kernel
parent9edfccbf06ad8fac57df10c00ba581409862593a (diff)
downloadmeta-freescale-5495f2b9bc4d90c9f4197574a547df43c664a928.tar.gz
linux-fslc-imx-rt: Add patch to support external imx-gpu-viv driver
Export functions swait_prepare_locked() and swait_finish_locked() to make them available to the external imx-gpu-viv driver module. Remove the check whether MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE is set; both the built-in driver and the external module now work with the RT kernel. Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx-rt/0004-export-swait-locked-functions.patch31
-rw-r--r--recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb7
2 files changed, 32 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx-rt/0004-export-swait-locked-functions.patch b/recipes-kernel/linux/linux-fslc-imx-rt/0004-export-swait-locked-functions.patch
new file mode 100644
index 00000000..1a616aa3
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx-rt/0004-export-swait-locked-functions.patch
@@ -0,0 +1,31 @@
1From 2460dd985b0cf477f74396de92d1bc5df496abdc Mon Sep 17 00:00:00 2001
2From: Julio Cruz <jcsistemas2001@gmail.com>
3Date: Wed, 20 Jan 2016 19:26:44 +0800
4Subject: [PATCH] Export symbols for iMX-GPU-VIV module
5
6---
7 kernel/sched/wait-simple.c | 2 ++
8 1 file changed, 2 insertions(+)
9
10diff --git a/kernel/sched/wait-simple.c b/kernel/sched/wait-simple.c
11index 7dfa86d..a3776ee 100644
12--- a/kernel/sched/wait-simple.c
13+++ b/kernel/sched/wait-simple.c
14@@ -40,6 +40,7 @@ void swait_prepare_locked(struct swait_head *head, struct swaiter *w)
15 if (list_empty(&w->node))
16 __swait_enqueue(head, w);
17 }
18+EXPORT_SYMBOL(swait_prepare_locked);
19
20 void swait_prepare(struct swait_head *head, struct swaiter *w, int state)
21 {
22@@ -58,6 +59,7 @@ void swait_finish_locked(struct swait_head *head, struct swaiter *w)
23 if (w->task)
24 __swait_dequeue(w);
25 }
26+EXPORT_SYMBOL(swait_finish_locked);
27
28 void swait_finish(struct swait_head *head, struct swaiter *w)
29 {
30--
312.1.0
diff --git a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
index fbb32d81..10610a5a 100644
--- a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
+++ b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-2.0.x.bb
@@ -16,16 +16,11 @@ SRC_URI += " \
16 file://0001-fix-build.patch \ 16 file://0001-fix-build.patch \
17 file://0002-no-split-ptlocks.patch \ 17 file://0002-no-split-ptlocks.patch \
18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \ 18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \
19 file://0004-export-swait-locked-functions.patch \
19" 20"
20 21
21SRC_URI[rt-patch.md5sum] = "6dd1193203cdf6a1a4758fc8baf07a4a" 22SRC_URI[rt-patch.md5sum] = "6dd1193203cdf6a1a4758fc8baf07a4a"
22SRC_URI[rt-patch.sha256sum] = "427e736022e59f83c9489eda889559fcd4fe4abb5646570ade32f2128f2fa725" 23SRC_URI[rt-patch.sha256sum] = "427e736022e59f83c9489eda889559fcd4fe4abb5646570ade32f2128f2fa725"
23 24
24python () {
25 using_builtin_driver = (d.getVar("MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE", True) or "") != "1"
26 if not using_builtin_driver:
27 raise bb.parse.SkipPackage('You must use the builtin driver with the Linux RT patch as the external module does not yet include support for it. Set "MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE" accordingly.')
28}
29
30 25
31COMPATIBLE_MACHINE = "(mx6|mx7)" 26COMPATIBLE_MACHINE = "(mx6|mx7)"