diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-01-26 09:44:11 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-01-26 08:22:36 -0300 |
commit | 1f1a29eaf56113b7d0dcff755cb4729cac3b013d (patch) | |
tree | 18f379494b91160df7901a98c9c46940f91117df /recipes-kernel | |
parent | 86ce755de5549bda519e60e875356b1120c5d6d4 (diff) | |
download | meta-freescale-1f1a29eaf56113b7d0dcff755cb4729cac3b013d.tar.gz |
linux-fslc-imx: update to v5.4.92
Kernel repository has been upgraded to v5.4.92 from stable korg.
Following upstream commits are included in this version:
----
09f983f0c7fc Linux 5.4.92
e2d69319b713 spi: cadence: cache reference clock rate during probe
d04c7938d0f8 mac80211: check if atf has been disabled in __ieee80211_schedule_txq
d46996cb4b16 mac80211: do not drop tx nulldata packets on encrypted links
56e8947bcf81 tipc: fix NULL deref in tipc_link_xmit()
55bac51762c3 net, sctp, filter: remap copy_from_user failure error
52e0b20c8c57 rxrpc: Fix handling of an unsupported token type in rxrpc_read()
5c466480d7d4 net: avoid 32 x truesize under-estimation for tiny skbs
f6499a78e581 net: sit: unregister_netdevice on newlink's error path
a3870cf8a7a2 net: stmmac: Fixed mtu channged by cache aligned
c213d85cae39 rxrpc: Call state should be read with READ_ONCE() under some circumstances
6d57b582fb35 net: dcb: Accept RTM_GETDCB messages carrying set-like DCB commands
d52f5929d997 net: dcb: Validate netlink message in DCB handler
814e04776211 esp: avoid unneeded kmap_atomic call
0ff06dd1b949 rndis_host: set proper input size for OID_GEN_PHYSICAL_MEDIUM request
c897c10e4334 net: mvpp2: Remove Pause and Asym_Pause support
18c29e175e30 mlxsw: core: Increase critical threshold for ASIC thermal zone
7680783452ce mlxsw: core: Add validation of transceiver temperature thresholds
ff6d4e8da7c6 net: ipv6: Validate GSO SKB before finish IPv6 processing
b41352a93c16 net: skbuff: disambiguate argument and member for skb_list_walk_safe helper
aa350dbe3a1e net: introduce skb_list_walk_safe for skb segment walking
760e9fd4f7ab netxen_nic: fix MSI/MSI-x interrupts
982e763ea3c3 udp: Prevent reuseport_select_sock from reading uninitialized socks
bd4793843c85 bpf: Fix helper bpf_map_peek_elem_proto pointing to wrong callback
79ce12cfa56a bpf: Don't leak memory in bpf getsockopt when optlen == 0
4aef760c28e8 nfsd4: readdirplus shouldn't return parent of export
9b72d5ba50f1 spi: npcm-fiu: Disable clock in probe error path
6ef67f59263e spi: npcm-fiu: simplify the return expression of npcm_fiu_probe()
fa6de8d82d9c scsi: lpfc: Make lpfc_defer_acc_rsp static
e82b58aa6471 scsi: lpfc: Make function lpfc_defer_pt2pt_acc static
5e6b88828526 elfcore: fix building with clang
ac29c052654f xen/privcmd: allow fetching resource sizes
dd113b79ee7e compiler.h: Raise minimum version of GCC to 5.1 for arm64
24cea7d70516 usb: ohci: Make distrust_firmware param default to false
----
Link: https://lore.kernel.org/r/20210122135733.565501039@linuxfoundation.org
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_5.4.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb index 9c817b5b..535b41b9 100644 --- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb +++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb | |||
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v5.4.91 | 31 | # tag: v5.4.92 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
@@ -79,14 +79,14 @@ LICENSE = "GPLv2" | |||
79 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 79 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
80 | 80 | ||
81 | SRCBRANCH = "5.4-2.2.x-imx" | 81 | SRCBRANCH = "5.4-2.2.x-imx" |
82 | SRCREV = "05e17a07c24e0dc7bddcc32fa1e01420da9500ef" | 82 | SRCREV = "9335a2fd4a7f8f789838c5198ca6da5944c44fa5" |
83 | 83 | ||
84 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 84 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
85 | # required by kernel-yocto.bbclass. | 85 | # required by kernel-yocto.bbclass. |
86 | # | 86 | # |
87 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 87 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
88 | # should be updated once patchlevel is merged. | 88 | # should be updated once patchlevel is merged. |
89 | LINUX_VERSION = "5.4.91" | 89 | LINUX_VERSION = "5.4.92" |
90 | 90 | ||
91 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. | 91 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. |
92 | LOCALVERSION = "-imx-5.4.47-2.2.0" | 92 | LOCALVERSION = "-imx-5.4.47-2.2.0" |