summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:10:20 +0100
committerRoland Hieber <rhi@pengutronix.de>2021-11-23 16:29:24 +0100
commit182b4a6a6e6dd0c86e0e15f1152bb1c65f746015 (patch)
tree546351390398988de37214a21ae47b884ce33627 /recipes-kernel
parent727fd8df20c8ee58474ce15cd5e1459f14bee977 (diff)
downloadmeta-freescale-182b4a6a6e6dd0c86e0e15f1152bb1c65f746015.tar.gz
recipes: use https protocol and add explicit branch parameter
Due to https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git it is required to use https protocol for github repo accessing. Update created with oe-core/scripts/contrib/convert-srcuri.py (see [0]) Fixes: WARNING: /work/meta-freescale/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb: URL: git://github.com/Freescale/u-boot-fslc.git;branch=2021.07+fslc uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url. [0] - https://git.openembedded.org/openembedded-core/tree/scripts/contrib/convert-srcuri.py Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com> (cherry picked from commit bef00d6e4f25b4a9d3272e0d69db7545590ed204)
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-qoriq_5.4.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
index af0b2d60..3e3f8aff 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.4+fslc.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
10PV .= "+git${SRCPV}" 10PV .= "+git${SRCPV}"
11 11
12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749" 12SRCREV = "f2e8483fbda59bf2482f77efb0804c014848f749"
13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https" 13SRC_URI = "git://github.com/Freescale/kernel-module-imx-gpu-viv.git;protocol=https;branch=master"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb b/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
index eb8cf0c4..a82483c3 100644
--- a/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-qoriq_5.4.bb
@@ -14,4 +14,4 @@ LINUX_VERSION = "5.4.64"
14 14
15SRCBRANCH = "5.4.y+qoriq+fslc" 15SRCBRANCH = "5.4.y+qoriq+fslc"
16SRCREV = "4c04c442c0e91e7cf01f830aca524f09b5613f29" 16SRCREV = "4c04c442c0e91e7cf01f830aca524f09b5613f29"
17SRC_URI := "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH}" 17SRC_URI := "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH};protocol=https"
diff --git a/recipes-kernel/linux/linux-fslc.inc b/recipes-kernel/linux/linux-fslc.inc
index f6d04d59..7315df0d 100644
--- a/recipes-kernel/linux/linux-fslc.inc
+++ b/recipes-kernel/linux/linux-fslc.inc
@@ -5,6 +5,6 @@ require recipes-kernel/linux/linux-imx.inc
5 5
6DEPENDS += "lzop-native bc-native" 6DEPENDS += "lzop-native bc-native"
7 7
8SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH} \ 8SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${SRCBRANCH};protocol=https \
9 file://defconfig" 9 file://defconfig"
10LOCALVERSION = "-fslc" 10LOCALVERSION = "-fslc"