diff options
author | Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2020-04-13 20:40:26 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-16 10:32:45 -0300 |
commit | 824690b0cba597a943d883b72d26b968ff508ded (patch) | |
tree | cd3b667d507419008f543449c67825f40fe52c6c /recipes-kernel | |
parent | de1d22018ee020bc11f88e853934b28b3f205cd2 (diff) | |
download | meta-freescale-824690b0cba597a943d883b72d26b968ff508ded.tar.gz |
linux-imx-headers: upgrade to version 5.4.3-1.0.0 from NXP
Upgrade linux headers recipe 4.19.35 -> 5.4.3 and drop the old recipe.
Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-imx-headers_4.19.35.bb | 57 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx-headers_5.4.3.bb | 67 |
2 files changed, 67 insertions, 57 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_4.19.35.bb b/recipes-kernel/linux/linux-imx-headers_4.19.35.bb deleted file mode 100644 index 64337953..00000000 --- a/recipes-kernel/linux/linux-imx-headers_4.19.35.bb +++ /dev/null | |||
@@ -1,57 +0,0 @@ | |||
1 | # Copyright 2017-20189 NXP | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Installs i.MX-specific kernel headers" | ||
5 | DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \ | ||
6 | New headers are installed in ${includedir}/imx." | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
9 | |||
10 | SRCBRANCH = "imx_4.19.35_1.1.0" | ||
11 | LOCALVERSION = "-1.1.0" | ||
12 | SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" | ||
13 | SRCREV = "a51dda8feec03e8c675230786d64ee050944dbfd" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_compile[noexec] = "1" | ||
18 | |||
19 | IMX_UAPI_HEADERS = " \ | ||
20 | dma-buf.h \ | ||
21 | hantrodec.h \ | ||
22 | hx280enc.h \ | ||
23 | ion.h \ | ||
24 | ipu.h \ | ||
25 | isl29023.h \ | ||
26 | mxc_asrc.h \ | ||
27 | mxc_dcic.h \ | ||
28 | mxc_mlb.h \ | ||
29 | mxc_sim_interface.h \ | ||
30 | mxc_v4l2.h \ | ||
31 | mxcfb.h \ | ||
32 | pxp_device.h \ | ||
33 | pxp_dma.h \ | ||
34 | videodev2.h \ | ||
35 | " | ||
36 | |||
37 | do_install() { | ||
38 | # We install all headers inside of B so we can copy only the | ||
39 | # whitelisted ones, and there is no risk of a new header to be | ||
40 | # installed by mistake. | ||
41 | oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix} | ||
42 | |||
43 | # FIXME: The ion.h is still on staging so "promote" it for now | ||
44 | cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux | ||
45 | |||
46 | # Install whitelisted headers only | ||
47 | for h in ${IMX_UAPI_HEADERS}; do | ||
48 | install -D -m 0644 ${B}${includedir}/linux/$h \ | ||
49 | ${D}${includedir}/imx/linux/$h | ||
50 | done | ||
51 | } | ||
52 | |||
53 | ALLOW_EMPTY_${PN} = "1" | ||
54 | |||
55 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
56 | COMPATIBLE_HOST_imx = ".*" | ||
57 | COMPATIBLE_HOST ?= "(none)" | ||
diff --git a/recipes-kernel/linux/linux-imx-headers_5.4.3.bb b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb new file mode 100644 index 00000000..ff5f238e --- /dev/null +++ b/recipes-kernel/linux/linux-imx-headers_5.4.3.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | # Copyright 2017-2019 NXP | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "Installs i.MX-specific kernel headers" | ||
5 | DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \ | ||
6 | New headers are installed in ${includedir}/imx." | ||
7 | LICENSE = "GPLv2" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | ||
9 | |||
10 | SRCBRANCH = "lf-5.4.y" | ||
11 | LOCALVERSION = "-1.0.0" | ||
12 | SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" | ||
13 | SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | do_configure[noexec] = "1" | ||
18 | |||
19 | do_compile[noexec] = "1" | ||
20 | |||
21 | IMX_UAPI_HEADERS = " \ | ||
22 | dma-buf.h \ | ||
23 | hantrodec.h \ | ||
24 | hx280enc.h \ | ||
25 | ion.h \ | ||
26 | ipu.h \ | ||
27 | isl29023.h \ | ||
28 | mxc_asrc.h \ | ||
29 | mxc_dcic.h \ | ||
30 | mxc_mlb.h \ | ||
31 | mxc_sim_interface.h \ | ||
32 | mxc_v4l2.h \ | ||
33 | mxcfb.h \ | ||
34 | pxp_device.h \ | ||
35 | pxp_dma.h \ | ||
36 | version.h \ | ||
37 | videodev2.h \ | ||
38 | " | ||
39 | |||
40 | do_install() { | ||
41 | # We install all headers inside of B so we can copy only the | ||
42 | # whitelisted ones, and there is no risk of a new header to be | ||
43 | # installed by mistake. | ||
44 | oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix} | ||
45 | |||
46 | # Kernel should not be exporting this header | ||
47 | rm -f ${D}${exec_prefix}/include/scsi/scsi.h | ||
48 | |||
49 | # The ..install.cmd conflicts between various configure runs | ||
50 | find ${D}${includedir} -name ..install.cmd | xargs rm -f | ||
51 | |||
52 | # FIXME: The ion.h is still on staging so "promote" it for now | ||
53 | cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux | ||
54 | |||
55 | # Install whitelisted headers only | ||
56 | for h in ${IMX_UAPI_HEADERS}; do | ||
57 | install -D -m 0644 ${B}${includedir}/linux/$h \ | ||
58 | ${D}${includedir}/imx/linux/$h | ||
59 | done | ||
60 | } | ||
61 | |||
62 | INHIBIT_DEFAULT_DEPS = "1" | ||
63 | DEPENDS += "unifdef-native bison-native rsync-native" | ||
64 | |||
65 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | ||
66 | COMPATIBLE_HOST_imx = ".*" | ||
67 | COMPATIBLE_HOST ?= "(none)" | ||