summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-05 11:01:28 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-01-25 16:30:35 -0200
commit7513b411b1ec4f9a1aefdb0053440ac236670baa (patch)
tree31a3f2ecafb7ad0306607a3dc783e2b5519cde62 /recipes-kernel
parent48ace56f12ac0daa67ceb98bd9563d89e7ff0242 (diff)
downloadmeta-freescale-7513b411b1ec4f9a1aefdb0053440ac236670baa.tar.gz
linux-qoriq_4.4: ${KERNEL_PACKAGE_NAME} replaces original key "kernel"
*update RDEPENDS to match kernel naming The kernel class now sets RDEPENDS_${KERNEL_PACKAGE_NAME}-base so this include needs to do the same, otherwise bitbake emits a warning and the kernel isn't removed. *FILES_${KERNEL_PACKAGE_NAME}-image () replaces original key FILES_kernel-image Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.4.bb b/recipes-kernel/linux/linux-qoriq_4.4.bb
index 0dfda199..89e6dfd6 100644
--- a/recipes-kernel/linux/linux-qoriq_4.4.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.4.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15DEPENDS_append = " libgcc" 15DEPENDS_append = " libgcc"
16# not put Images into /boot of rootfs, install kernel-image if needed 16# not put Images into /boot of rootfs, install kernel-image if needed
17RDEPENDS_kernel-base = "" 17RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
18 18
19KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" 19KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
20KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" 20KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
@@ -59,5 +59,5 @@ do_install_prepend_fsl-lsch2-32b() {
59 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 59 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
60} 60}
61 61
62FILES_kernel-image += "/boot/zImage*" 62FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
63COMPATIBLE_MACHINE = "(qoriq)" 63COMPATIBLE_MACHINE = "(qoriq)"