diff options
author | Jens Rehsack <sno@netbsd.org> | 2020-04-07 12:32:47 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-04-07 16:09:42 -0300 |
commit | 6f63fe25adb4935a71255823891749fed0fbdeb9 (patch) | |
tree | 119bfd012a0bd58c89d6a6985ef16dd7bb334569 /recipes-kernel | |
parent | 69652b4462808810ac189af030d9fc13a89e3b27 (diff) | |
download | meta-freescale-6f63fe25adb4935a71255823891749fed0fbdeb9.tar.gz |
linux-qoriq: harmonize kernel recipes
Move everything which is common used of linux-qoriq kernels into
linux-qoriq.inc and require it from both existing kernel recipes.
This should avoid copy'n'waste even for future kernels.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-qoriq.inc | 65 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.14.bb | 64 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.19.bb | 68 |
3 files changed, 68 insertions, 129 deletions
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc new file mode 100644 index 00000000..7f70260a --- /dev/null +++ b/recipes-kernel/linux/linux-qoriq.inc | |||
@@ -0,0 +1,65 @@ | |||
1 | inherit kernel qoriq_build_64bit_kernel siteinfo | ||
2 | inherit fsl-kernel-localversion | ||
3 | |||
4 | SUMMARY = "Linux Kernel for NXP QorIQ platforms" | ||
5 | SECTION = "kernel" | ||
6 | LICENSE = "GPLv2" | ||
7 | |||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | DEPENDS_append = " libgcc" | ||
11 | # not put Images into /boot of rootfs, install kernel-image if needed | ||
12 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" | ||
13 | |||
14 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
15 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
16 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
17 | |||
18 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
19 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
20 | |||
21 | SCMVERSION ?= "y" | ||
22 | LOCALVERSION = "" | ||
23 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
24 | DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " | ||
25 | DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " | ||
26 | DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " | ||
27 | |||
28 | do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot" | ||
29 | do_merge_delta_config[dirs] = "${B}" | ||
30 | |||
31 | do_merge_delta_config() { | ||
32 | # create config with make config | ||
33 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | ||
34 | |||
35 | # check if bigendian is enabled | ||
36 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | ||
37 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | ||
38 | echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config | ||
39 | fi | ||
40 | |||
41 | # add config fragments | ||
42 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
43 | if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then | ||
44 | oe_runmake -C ${S} O=${B} ${deltacfg} | ||
45 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
46 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
47 | elif [ -f "${deltacfg}" ]; then | ||
48 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
49 | fi | ||
50 | done | ||
51 | cp .config ${WORKDIR}/defconfig | ||
52 | } | ||
53 | addtask merge_delta_config before do_preconfigure after do_patch | ||
54 | |||
55 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | ||
56 | do_compile_prepend_fsl-lsch2-32b() { | ||
57 | ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
58 | } | ||
59 | |||
60 | do_install_prepend_fsl-lsch2-32b() { | ||
61 | rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
62 | } | ||
63 | |||
64 | FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" | ||
65 | COMPATIBLE_MACHINE = "(qoriq)" | ||
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb index 36c2e96b..33361131 100644 --- a/recipes-kernel/linux/linux-qoriq_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq_4.14.bb | |||
@@ -1,9 +1,3 @@ | |||
1 | inherit kernel qoriq_build_64bit_kernel siteinfo | ||
2 | inherit fsl-kernel-localversion | ||
3 | |||
4 | SUMMARY = "Linux Kernel for NXP QorIQ platforms" | ||
5 | SECTION = "kernel" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | 1 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" |
8 | 2 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 3 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
@@ -12,60 +6,4 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nob | |||
12 | " | 6 | " |
13 | SRCREV = "d39cc9ffcbe5638b50f5f45698eb87a6c3a96eb3" | 7 | SRCREV = "d39cc9ffcbe5638b50f5f45698eb87a6c3a96eb3" |
14 | 8 | ||
15 | S = "${WORKDIR}/git" | 9 | require recipes-kernel/linux/linux-qoriq.inc |
16 | |||
17 | DEPENDS_append = " libgcc" | ||
18 | # not put Images into /boot of rootfs, install kernel-image if needed | ||
19 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" | ||
20 | |||
21 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
22 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
23 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
24 | |||
25 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
26 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
27 | |||
28 | SCMVERSION ?= "y" | ||
29 | LOCALVERSION = "" | ||
30 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
31 | DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " | ||
32 | DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " | ||
33 | DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " | ||
34 | |||
35 | do_merge_delta_config[dirs] = "${B}" | ||
36 | |||
37 | do_merge_delta_config() { | ||
38 | # create config with make config | ||
39 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | ||
40 | |||
41 | # check if bigendian is enabled | ||
42 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | ||
43 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | ||
44 | echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config | ||
45 | fi | ||
46 | |||
47 | # add config fragments | ||
48 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
49 | if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then | ||
50 | oe_runmake -C ${S} O=${B} ${deltacfg} | ||
51 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
52 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
53 | elif [ -f "${deltacfg}" ]; then | ||
54 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
55 | fi | ||
56 | done | ||
57 | cp .config ${WORKDIR}/defconfig | ||
58 | } | ||
59 | addtask merge_delta_config before do_preconfigure after do_patch | ||
60 | |||
61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | ||
62 | do_compile_prepend_fsl-lsch2-32b() { | ||
63 | ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
64 | } | ||
65 | |||
66 | do_install_prepend_fsl-lsch2-32b() { | ||
67 | rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
68 | } | ||
69 | |||
70 | FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" | ||
71 | COMPATIBLE_MACHINE = "(qoriq)" | ||
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb index 4c45f2c9..433e1b07 100644 --- a/recipes-kernel/linux/linux-qoriq_4.19.bb +++ b/recipes-kernel/linux/linux-qoriq_4.19.bb | |||
@@ -1,72 +1,8 @@ | |||
1 | inherit kernel qoriq_build_64bit_kernel siteinfo | ||
2 | inherit fsl-kernel-localversion | ||
3 | |||
4 | SUMMARY = "Linux Kernel for NXP QorIQ platforms" | ||
5 | SECTION = "kernel" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 1 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
8 | 2 | ||
9 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ | 3 | SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \ |
4 | file://0001-Makfefile-add-cflags.patch \ | ||
10 | " | 5 | " |
11 | SRCREV = "c5f3ab9ac163f5c86a5c1ed163afaf24f2eea669" | 6 | SRCREV = "c5f3ab9ac163f5c86a5c1ed163afaf24f2eea669" |
12 | 7 | ||
13 | SRC_URI += " file://0001-Makfefile-add-cflags.patch \ | 8 | require recipes-kernel/linux/linux-qoriq.inc |
14 | " | ||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | DEPENDS_append = " libgcc" | ||
18 | # not put Images into /boot of rootfs, install kernel-image if needed | ||
19 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base = "" | ||
20 | |||
21 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
22 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
23 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
24 | |||
25 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
26 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
27 | |||
28 | SCMVERSION ?= "y" | ||
29 | LOCALVERSION = "" | ||
30 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
31 | DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " | ||
32 | DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config " | ||
33 | DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " | ||
34 | |||
35 | do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot bison-native:do_populate_sysroot" | ||
36 | do_merge_delta_config[dirs] = "${B}" | ||
37 | |||
38 | do_merge_delta_config() { | ||
39 | # create config with make config | ||
40 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | ||
41 | |||
42 | # check if bigendian is enabled | ||
43 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | ||
44 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | ||
45 | echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config | ||
46 | fi | ||
47 | |||
48 | # add config fragments | ||
49 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
50 | if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then | ||
51 | oe_runmake -C ${S} O=${B} ${deltacfg} | ||
52 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
53 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
54 | elif [ -f "${deltacfg}" ]; then | ||
55 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
56 | fi | ||
57 | done | ||
58 | cp .config ${WORKDIR}/defconfig | ||
59 | } | ||
60 | addtask merge_delta_config before do_preconfigure after do_patch | ||
61 | |||
62 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | ||
63 | do_compile_prepend_fsl-lsch2-32b() { | ||
64 | ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
65 | } | ||
66 | |||
67 | do_install_prepend_fsl-lsch2-32b() { | ||
68 | rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
69 | } | ||
70 | |||
71 | FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*" | ||
72 | COMPATIBLE_MACHINE = "(qoriq)" | ||