diff options
author | fvo <voit@zuhause-plattform.de> | 2019-12-11 09:59:53 +0100 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2019-12-11 11:25:55 -0300 |
commit | 6e0b6f295fa7f62484b7a448fb729fbd32191a6b (patch) | |
tree | 0ccb26ac26ef22edc2efe9ff916769d7ae26c425 /recipes-kernel | |
parent | 2c386f1dd2ea11db2cb2cf44300461cb244697eb (diff) | |
download | meta-freescale-6e0b6f295fa7f62484b7a448fb729fbd32191a6b.tar.gz |
linux-qoriq recipes: reorder merge_delta_config task
I've tried build linux-variscite where the maintainers seem to have
copied the 'merge_delta_config' task from the linux-qoriq recipe from
meta-freescale.
When i tried to use that task to add some linux kernel config flags it
did not work. It seems like the 'do_preconfigure' task inherited by the
'fsl-kernel-localversion' class deletes all content of the '.config'
file AFTER it has been merged by the 'merge_delta_config' task.
I reordered the tasks so that merge_delta_config is run after
preconfigure:
addtask merge_delta_config before do_configure after do_patch
do_preconfigure
which solved the problem for me. The flags were then added and compiled
into the kernel.
Signed-off-by: Florian Voit <voit@zuhause-plattform.de>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-qoriq-rt_4.14.bb | 4 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.14.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.19.bb | 2 |
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-rt_4.14.bb b/recipes-kernel/linux/linux-qoriq-rt_4.14.bb index e880081a..5a1147e5 100644 --- a/recipes-kernel/linux/linux-qoriq-rt_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq-rt_4.14.bb | |||
@@ -37,7 +37,7 @@ do_merge_delta_config[dirs] = "${B}" | |||
37 | do_merge_delta_config() { | 37 | do_merge_delta_config() { |
38 | # create config with make config | 38 | # create config with make config |
39 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} | 39 | oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG} |
40 | 40 | ||
41 | # check if bigendian is enabled | 41 | # check if bigendian is enabled |
42 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then | 42 | if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then |
43 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config | 43 | echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config |
@@ -56,7 +56,7 @@ do_merge_delta_config() { | |||
56 | done | 56 | done |
57 | cp .config ${WORKDIR}/defconfig | 57 | cp .config ${WORKDIR}/defconfig |
58 | } | 58 | } |
59 | addtask merge_delta_config before do_preconfigure after do_patch | 59 | addtask merge_delta_config before do_configure after do_patch do_preconfigure |
60 | 60 | ||
61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
62 | do_compile_prepend_fsl-lsch2-32b() { | 62 | do_compile_prepend_fsl-lsch2-32b() { |
diff --git a/recipes-kernel/linux/linux-qoriq_4.14.bb b/recipes-kernel/linux/linux-qoriq_4.14.bb index f2e0a4b8..8a28918c 100644 --- a/recipes-kernel/linux/linux-qoriq_4.14.bb +++ b/recipes-kernel/linux/linux-qoriq_4.14.bb | |||
@@ -56,7 +56,7 @@ do_merge_delta_config() { | |||
56 | done | 56 | done |
57 | cp .config ${WORKDIR}/defconfig | 57 | cp .config ${WORKDIR}/defconfig |
58 | } | 58 | } |
59 | addtask merge_delta_config before do_preconfigure after do_patch | 59 | addtask merge_delta_config before do_configure after do_patch do_preconfigure |
60 | 60 | ||
61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 61 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
62 | do_compile_prepend_fsl-lsch2-32b() { | 62 | do_compile_prepend_fsl-lsch2-32b() { |
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb index aed29df6..78125352 100644 --- a/recipes-kernel/linux/linux-qoriq_4.19.bb +++ b/recipes-kernel/linux/linux-qoriq_4.19.bb | |||
@@ -57,7 +57,7 @@ do_merge_delta_config() { | |||
57 | done | 57 | done |
58 | cp .config ${WORKDIR}/defconfig | 58 | cp .config ${WORKDIR}/defconfig |
59 | } | 59 | } |
60 | addtask merge_delta_config before do_preconfigure after do_patch | 60 | addtask merge_delta_config before do_configure after do_patch do_preconfigure |
61 | 61 | ||
62 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | 62 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) |
63 | do_compile_prepend_fsl-lsch2-32b() { | 63 | do_compile_prepend_fsl-lsch2-32b() { |