diff options
author | Fabio Berton <fabio.berton@ossystems.com.br> | 2016-09-26 13:57:23 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-09-26 14:49:24 -0300 |
commit | cc1e0fbed5c64920d5b22c3fb25e59eaec2d74d0 (patch) | |
tree | fc3d96af6f36f45f205ff0fe057e1ad83f009ec7 /recipes-kernel | |
parent | 5ffdc39fd21a2c01ac2005a763c7b719d3bcdb47 (diff) | |
download | meta-freescale-cc1e0fbed5c64920d5b22c3fb25e59eaec2d74d0.tar.gz |
linux-fslc-imx: Bump revision to df9f1f6
This includes the following changes:
- df9f1f6 net: fec: align IP
- 7395912 net: fec: enable RACC on imx6ul
- 61da160 net: fec: remove QUIRK_HAS_RACC from i.mx27
- c01a8d6 net: fec: remove QUIRK_HAS_RACC from i.mx25
- 9e47e1d Merge tag 'v4.1.33' into 4.1-1.0.x-imx
- 04cb720 (tag: v4.1.33) Linux 4.1.33
- 131f437 Revert "ARC: mm: don't loose PTE_SPECIAL in pte_modify()"
- 706f890 x86/AMD: Apply erratum 665 on machines without a BIOS fix
- 8fdbea4 x86/paravirt: Do not trace _paravirt_ident_*() functions
- 7a17327 ovl: listxattr: use strnlen()
- 02b7c97 ovl: remove posix_acl_default from workdir
- 29c4d8d serial: 8250: added acces i/o products quad and octal serial cards
- 8f96009 sysfs: correctly handle read offset on PREALLOC attrs
- f53680b sysfs: correctly handle short reads on PREALLOC attrs.
- 33d720d kernfs: don't depend on d_find_any_alias() when generating notifications
- e185718 dm crypt: fix free of bad values after tfm allocation failure
- af26eb1 dm crypt: fix error with too large bios
- 14afdb2 dm log writes: fix check of kthread_run() return value
- 6f3e5e4 dm log writes: fix bug with too large bios
- 0fe7182 dm log writes: move IO accounting earlier to fix error path
- 99663cd NFSv4.x: Fix a refcount leak in nfs_callback_up_net
- f6b02c5 xfs: prevent dropping ioend completions during buftarg wait
- d023f70 xfs: fix superblock inprogress check
- 206538f USB: serial: option: add WeTelecom 0x6802 and 0x6803 products
- b3e7cf0 USB: avoid left shift by -1
- f3c7748 pNFS: The client must not do I/O to the DS if it's lease has expired
- 47998eb iio: accel: kxsd9: Fix raw read return
- a29b7c9 staging: comedi: ni_mio_common: fix AO inttrig backwards compatibility
- f27b803 staging: comedi: ni_mio_common: fix wrong insn_write handler
- 33f100b staging: comedi: daqboard2000: bug fix board type matching code
- f8ce587 USB: serial: option: add WeTelecom WM-D200
- b1918a0 usb: chipidea: udc: don't touch DP when controller is in host mode
- 1898b62 USB: serial: mos7840: fix non-atomic allocation in write path
- 9f4cc3b USB: serial: mos7720: fix non-atomic allocation in write path
- 24628b5 cpuset: make sure new tasks conform to the current config of the cpuset
- 214b2da ovl: don't copy up opaqueness
- b9ee45d dmaengine: usb-dmac: check CHCR.DE bit in usb_dmac_isr_channel()
- 0a6f797 ext4: validate that metadata blocks do not overlap superblock
- 469a242 [PATCH] arm: fix handling of F_OFD_... in oabi_fcntl64()
- 871499e staging: comedi: comedi_test: fix timer race conditions
- efaf365 Merge tag 'v4.1.32' into 4.1-1.0.x-imx
- 3b60b86 (tag: v4.1.32) Linux 4.1.32
- dfd742c PCI: Limit config space size for Netronome NFP4000
- 8d3cd03 PCI: Add Netronome NFP4000 PF device ID
- 2ca638d PCI: Limit config space size for Netronome NFP6000 family
- ebcd021 PCI: Add Netronome vendor and device IDs
- 8847401 PCI: Support PCIe devices with short cfg_size
- f7bb9ba fs/seq_file: fix out-of-bounds read
- 942d5c0 clocksource/drivers/sun4i: Clear interrupts after stopping timer in
probe function
- 917f153 dm flakey: fix reads to be issued if drop_writes configured
- 1d6a6dc xenbus: don't look up transaction IDs for ordinary writes
- 083e76a x86/apic: Do not init irq remapping if ioapic is disabled
- a3f914b timekeeping: Cap array access in timekeeping_debug
- 0c7b2c2 timekeeping: Avoid taking lock in NMI path with CONFIG_DEBUG_TIMEKEEPING
- 2d701be um: Don't discard .text.exit section
- befdc6e ubifs: Fix assertion in layout_in_gaps()
- d9a5bd9 vhost/scsi: fix reuse of &vq->iov[out] in response
- f85090f Input: tegra-kbc - fix inverted reset logic
- bdd62ec ALSA: line6: Fix POD sysfs attributes segfault
- 571d361 ALSA: line6: Give up on the lock while URBs are released.
- c717f88 ALSA: line6: Remove double line6_pcm_release() after failed acquire.
- 6c000a4 drm: Reject page_flip for !DRIVER_MODESET
- f4eaf28 parisc: Fix order of EREFUSED define in errno.h
- 66751ff ARC: export __udivdi3 for modules
- 871b20f ARC: Support syscall ABI v4
- 35de4db ARC: use correct offset in pt_regs for saving/restoring user mode r25
- 0798beb ARCv2: STAR 9000808988: signals involving Delay Slot
- bc78e69 Input: i8042 - set up shared ps2_cmd_mutex for AUX ports
- 146ed73 drm/radeon: fix radeon_move_blit on 32bit systems
- bb6cf2c gpio: Fix OF build problem on UM
- cb515bd bcache: RESERVE_PRIO is too small by one when prio_buckets() is a
power of two.
- 220360d bcache: register_bcache(): call blkdev_put() when cache_alloc() fails
- 35b8f91 drm/radeon: only apply the SS fractional workaround to RS[78]80
- 388bf26 drm/radeon: don't use fractional dividers on RS[78]80 if SS is enabled
- 31df338 uprobes: Fix the memcg accounting
- 26390c7 block: Fix race triggered by blk_set_queue_dying()
- 0df5268 ASoC: atmel_ssc_dai: Don't unconditionally reset SSC on stream startu
- 7ae87ee ARC: Elide redundant setup of DMA callbacks
- 0e16c54 ARC: Call trace_hardirqs_on() before enabling irqs
- e1052fb usb: xhci: Fix panic if disconnect
- 23c50b2 xhci: always handle "Command Ring Stopped" events
- 9fd7c33 cdc-acm: fix wrong pipe type on rx interrupt xfers
- 1a8eadf usb: misc: usbtest: add fix for driver hang
- 79e3a23 usb: renesas_usbhs: Use dmac only if the pipe type is bulk
- 80a979e usb: renesas_usbhs: clear the BRDYSTS in usbhsg_ep_enable()
- 03b78ea drm/i915: fix aliasing_ppgtt leak
- 46c9df4 pinctrl/amd: Remove the default de-bounce time
- f079b0e usb: dwc3: pci: add Intel Kabylake PCI ID
- f034f1c usb: dwc3: pci: add support for Intel Broxton SOC
- 888ea95 usb: dwc3: pci: trivial: Formatting
- b424684 usb: dwc3: gadget: always cleanup all TRBs
- a694f3f usb: dwc3: gadget: fix for short pkts during chained xfers
- 60b8bcf usb: dwc3: gadget: increment request->actual once
- d3c1edb s390/dasd: fix hanging device after clear subchannel
- 5bd6b61 usb: ehci: change order of register cleanup during shutdown
- fdcdf5b usb: hub: Fix unbalanced reference count/memory leak/deadlocks
- aca7803 crypto: caam - fix non-hmac hashes
- e989e0c aacraid: Check size values after double-fetch from user
- 6a19c73 USB: serial: fix memleak in driver-registration error path
- 61882ca USB: serial: option: add support for Telit LE920A4
- 2980f14 USB: serial: ftdi_sio: add device ID for WICED USB UART dev board
- 65b2f0a USB: serial: ftdi_sio: add PIDs for Ivium Technologies devices
- cbae576 USB: serial: option: add D-Link DWM-156/A3
- 4bb0dda mac80211: fix purging multicast PS buffer queue
- 2dd916f tcp: enable per-socket rate limiting of all 'challenge acks'
- 2b21117 tcp: make challenge acks less predictable
- beebc82 powerpc/eeh: eeh_pci_enable(): fix checking of post-request state
- 99f614a Linux 4.1.31
- 432273c MIPS: KVM: Propagate kseg0/mapped tlb fault errors
- 7fe3930 MIPS: KVM: Fix gfn range check in kseg0 tlb faults
- 0fbddc0 MIPS: KVM: Add missing gfn range check
- 342b88e MIPS: KVM: Fix mapped fault broken commpage handling
- 867df5e ext4: verify extent header depth
- cd51084 ALSA: timer: Fix leak in events via snd_timer_user_tinterrupt
- 1fbc4fd ALSA: timer: Fix leak in events via snd_timer_user_ccallback
- 1b7d7bc ALSA: timer: Fix leak in SNDRV_TIMER_IOCTL_PARAMS
- c65b5c9 USB: OHCI: Don't mark EDs as ED_OPER if scheduling fails
- 6412c3a ovl: verify upper dentry before unlink and rename
- 40b9a8f iio:ad7266: Fix probe deferral for vref
- fb079b4 iio:ad7266: Fix support for optional regulators
- 44cdc9f iio:ad7266: Fix broken regulator error handling
- 94f9384 iio: accel: kxsd9: fix the usage of spi_w8r8()
- b2372ff staging: iio: accel: fix error check
- c1a8303 iio: proximity: as3935: fix buffer stack trashing
- 9db892c iio: proximity: as3935: remove triggered buffer processing
- e2a296e9 iio: proximity: as3935: correct IIO_CHAN_INFO_RAW output
- f247adf iio:st_pressure: fix sampling gains (bring inline with ABI)
- 3bdfc8b iio: Fix error handling in iio_trigger_attach_poll_func
- f3c7b15 perf/x86: Fix undefined shift on 32-bit kernels
- 7ceedf5 virtio_balloon: fix PFN format for virtio-1
- 4dbc156 virtio_balloon: do not change memory amount visible via /proc/meminfo
- 55f883c arm64: Rework valid_user_regs
- 5c46424 cdc_ncm: workaround for EM7455 "silent" data interface
- 28a6d04 nfsd: check permissions when setting ACLs
- 173f43c posix_acl: Add set_posix_acl
- 63933c7 powerpc/pseries: Fix PCI config address for DDW
- 049de19 powerpc/iommu: Remove the dependency on EEH struct in DDW mechanism
- d9ee963 block: fix use-after-free in seq file
- 403f056 metag: Fix __cmpxchg_u32 asm constraint for CMP
- a2036fb ALSA: hda - Fix headset mic detection problem for two dell machines
- 31ebbeb ALSA: hda - Fix the headset mic that will not work on Dell desktop
machine
- 0224028 ALSA: hda: Fix krealloc() with __GFP_ZERO usage
- df75887 ALSA: hda: add AMD Bonaire AZ PCI ID with proper driver caps
- 333c2cf MIPS: mm: Fix definition of R6 cache instruction
- e2b438f sysv, ipc: fix security-layer leaking
- 4ef5c9a mm/hugetlb: avoid soft lockup in set_max_huge_pages()
- 834ced1 dm: set DMF_SUSPENDED* _before_ clearing DMF_NOFLUSH_SUSPENDING
- 655fe78 dm rq: fix the starting and stopping of blk-mq queues
- 980b655 dm flakey: error READ bios during the down_interval
- 0d88572 ftrace/recordmcount: Work around for addition of metag magic but
not relocations
- 2876b1b balloon: check the number of available pages in leak balloon
- c6657f7 x86/syscalls/64: Add compat_sys_keyctl for 32-bit userspace
- 10855c6 ALSA: hda/realtek - Can't adjust speaker's volume on a Dell AIO
- 6cdb164 ALSA: hda/realtek: Enable HP amp and mute LED on HP Folio 9480m [v3]
- baea0d6 drm/nouveau/gr/nv3x: fix instobj write offsets in gr setup
- c1b4d25 drm/nouveau/fbcon: fix font width not divisible by 8
- c027bc0 ubi: Make volume resize power cut aware
- 304e915 ubi: Fix early logging
- ae32d1b ubi: Fix race condition between ubi device creation and udev
- eb61bdd fuse: fix wrong assignment of ->flags in fuse_send_init()
- 614c339 fuse: fuse_flush must check mapping->flags for errors
- 3fc4a4a fuse: fsync() did not return IO errors
- 93c0b00 ARC: mm: don't loose PTE_SPECIAL in pte_modify()
- ae9c7f3 drm/radeon: fix firmware info version checks
- 7afd374 KEYS: 64-bit MIPS needs to use compat_sys_keyctl for 32-bit userspace
- bd89870 KVM: PPC: Book3S HV: Save/restore TM state in H_CEDE
- ae40dad KVM: PPC: Book3S HV: Pull out TM state save/restore into separate
procedures
- a3b180a CIFS: Fix a possible invalid memory access in smb2_query_symlink()
- b7e61a1 fs/cifs: make share unaccessible at root level mountable
- b5e8e7f Input: i8042 - break load dependency between atkbd/psmouse and i8042
- e9071d0 Documentation/module-signing.txt: Note need for version info if
reusing a key
- 6ac9857 module: Invalidate signatures on force-loaded modules
- 7e6f0e1 net/irda: fix NULL pointer dereference on memory allocation failure
- 7d06f7f fs/dcache.c: avoid soft-lockup in dput()
- 49e3c9a MIPS: Don't register r4k sched clock when CPUFREQ enabled
- 0e2cbad6 nfs: don't create zero-length requests
- e1cc075 gpio: intel-mid: Remove potentially harmful code
- 7f5a3c7 iscsi-target: Fix panic when adding second TCP connection to iSCSI
session
- 634a3fc audit: fix a double fetch in audit_log_single_execve_arg()
- a4664af Fix broken audit tests for exec arg len
- a49b282 audit: Fix check of return value of strnlen_user()
- dd26566 cifs: fix crash due to race in hmac(md5) handling
- b9090fe target: Fix race between iscsi-target connection shutdown + ABORT_TASK
- 6c631d3 target: Fix missing complete during ABORT_TASK + CMD_T_FABRIC_STOP
- 80d341f mtd: nand: fix bug writing 1 byte less than page size
- 8ae0073 arm64: debug: unmask PSTATE.D earlier
- f88ded2 rtc: s3c: Add s3c_rtc_{enable/disable}_clk in s3c_rtc_setfreq()
- abf9569 dm: fix second blk_delay_queue() parameter to be in msec units not
jiffies
- 8129259 crypto: scatterwalk - Fix test in scatterwalk_done
- 98953c4 Bluetooth: Fix l2cap_sock_setsockopt() with optname BT_RCVMTU
- 5436aa6 KVM: VMX: handle PML full VMEXIT that occurs during event delivery
- aef1e06 USB: serial: option: add support for Telit LE910 PID 0x1206
- 4af80d9 powerpc/tm: Fix stack pointer corruption in __tm_recheckpoint()
- 572c8b6 powerpc/tm: Avoid SLB faults in treclaim/trecheckpoint when RI=0
- 881052c ext4: short-cut orphan cleanup on error
- 3f7ed29 drm/radeon: support backlight control for UNIPHY3
- 6c2ca21 KVM: nVMX: Fix memory corruption when using VMCS shadowing
- 53bb06c usb: quirks: Add no-lpm quirk for Elan
- bd0702f USB: quirks: Fix another ELAN touchscreen
- 256679c s390/mm: fix gmap tlb flush issues
- 9b01eaf cifs: Check for existing directory when opening file with O_CREAT
- bdf3214 [media] media: usbtv: prevent access to free'd resources
- 47c1628 Bluetooth: Add support of 13d3:3490 AR3012 device
- 6e2c93c Bluetooth: Add USB ID 13D3:3487 to ath3k
- 434d638 [media] Fix RC5 decoding with Fintek CIR chipset
- 2342f6e [media] media: dvb_ringbuffer: Add memory barriers
- 7235df9 drm/radeon: Poll for both connect/disconnect on analog connectors
- 4613d5f drm/radeon: add a delay after ATPX dGPU power off
- 073435a spi: pxa2xx: Clear all RFT bits in reset_sccr1() on Intel Quark
- d4d783d ext4: validate s_reserved_gdt_blocks on mount
- d579705 iwlwifi: add new 8260 PCI IDs
- 2fc0cdf ARM: dts: sunxi: Add a startup delay for fixed regulator enabled phys
- e19f0ec5 ext4: don't call ext4_should_journal_data() on the journal inode
- 906d6f4 ext4: fix deadlock during page writeback
- 547df96 SUNRPC: Don't allocate a full sockaddr_storage for tracing
- c580d82 ext4: check for extents that wrap around
- 988777b mfd: qcom_rpm: Parametrize also ack selector size
- e6b04eb mfd: qcom_rpm: Fix offset error for msm8660
- 6997496 usb: renesas_usbhs: protect the CFIFOSEL setting in usbhsg_ep_enable()
- 83335cb usb: renesas_usbhs: fix NULL pointer dereference in xfer_work()
- 542330f hp-wmi: Fix wifi cannot be hard-unblocked
- 230dc3e serial: samsung: Fix ERR pointer dereference on deferred probe
- cf61375 tty/serial: atmel: fix RS485 half duplex with DMA
- ebe1398 tty/serial: at91: remove bunch of macros to access UART registers
- 343c4ef of: fix memory leak related to safe_name()
- 8431378 crypto: gcm - Filter out async ghash if necessary
- b42d378 usb: dwc3: fix for the isoc transfer EP_BUSY flag
- 4426cc6 pinctrl: cherryview: prevent concurrent access to GPIO controllers
- 440357fd pinctrl: cherryview: Use raw_spinlock for locking
- ba42156 pinctrl: cherryview: Serialize all register access
- e057773 Update my main e-mails at the Kernel tree
- 10dd8c10 gpio: pca953x: Fix NBANK calculation for PCA9536
- 27b5490 PCI: Mark Atheros AR9485 and QCA9882 to avoid bus reset
- b378007 Revert "drm/i915/ilk: Don't disable SSC source if it's in use"
- 7a85bf9 netlabel: add address family checks to netlbl_{sock,req}_delattr()
- 85470a5 s5p-mfc: Add release callback for memory region devs
- 1dd12c3 s5p-mfc: Set device name for reserved memory region devs
- fce6716 HID: uhid: fix timeout when probe races with IO
- 223b391 arm64: kernel: Save and restore addr_limit on exception entry
- 5c57645 fs/proc/task_mmu.c: fix mm_access() mode parameter in pagemap_read()
- 6a46873 netfilter: nf_nat_redirect: add missing NULL pointer check
- 558ba5f (tag: v4.1.30) Linux 4.1.30
- 629d045 x86/quirks: Reintroduce scanning of secondary buses
- f2da7df x86/quirks: Apply nvidia_bugs quirk only on root bus
- 6264b57 Revert "MIPS: Reserve nosave data for hibernation"
- 84d0821 Revert "sparc64: Fix numa node distance initialization"
- bd6d85d pps: do not crash when failed to register
- bea9acd radix-tree: fix radix_tree_iter_retry() for tagged iterators.
- 6831c98 libceph: apply new_state before new_up_client on incrementals
- 5210f97 libceph: set 'exists' flag for newly up osd
- 87076a0 ovl: verify upper dentry in ovl_remove_and_whiteout()
- 9524cc4 tty/vt/keyboard: fix OOB access in do_compute_shiftstate()
- e77df44 libata: LITE-ON CX1-JB256-HP needs lower max_sectors
- c30e87b mmc: block: fix packed command header endianness
- ce05d31 media: fix airspy usb probe error path
- 371ac20 vmlinux.lds: account for destructor sections
- fe071fb mm, compaction: prevent VM_BUG_ON when terminating freeing scanner
- ca0d868 mm, compaction: simplify handling restart position in free pages scanner
- 1602957 drm/i915: Update ifdeffery for mutex->owner
- 627ec70 ALSA: hda: add AMD Stoney PCI ID with proper driver caps
- 282f757 ALSA: hda - fix use-after-free after module unload
- f8e3078 posix_cpu_timer: Exit early when process has been reaped
- 47eec48 x86/quirks: Add early quirk to reset Apple AirPort card
- 2533406 net: mvneta: set real interrupt per packet for tx_done
- 43506e7 ALSA: pcm: Free chmap at PCM free callback, too
- 6b9d561 ALSA: ctl: Stop notification after disconnection
- fb10485 ALSA: hda/realtek - add new pin definition in alc225 pin quirk table
- 31534f8 ovl: Copy up underlying inode's ->i_mode to overlay inode
- cb75f65 ovl: handle ATTR_KILL*
- 97f2887 drm/ttm: Make ttm_bo_mem_compat available
- 07761df Input: xpad - validate USB endpoint count during probe
- 70aaf49 ARM: mvebu: fix HW I/O coherency related deadlocks
- 2686f12 netfilter: x_tables: speed up jump target validation0357fd pinctrl:
cherryview: Use raw_spinlock for locking
Change-Id: Idb8f3a797b74e866074a9d551587027d21022b72
Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb b/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb index f69eb718..80a472dc 100644 --- a/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb +++ b/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb | |||
@@ -11,6 +11,6 @@ include linux-fslc.inc | |||
11 | PV .= "+git${SRCPV}" | 11 | PV .= "+git${SRCPV}" |
12 | 12 | ||
13 | SRCBRANCH = "4.1-1.0.x-imx" | 13 | SRCBRANCH = "4.1-1.0.x-imx" |
14 | SRCREV = "59b38c323bd9f4cc9661bde977ebb92a8c141244" | 14 | SRCREV = "df9f1f6ae4b3c32e53de030eb3616a6899b00741" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(mx6|mx7)" | 16 | COMPATIBLE_MACHINE = "(mx6|mx7)" |