summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-12-21 21:18:42 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-21 19:30:57 -0300
commite828e1b284eadb604d2b3f990eed9cecb0b3ae58 (patch)
treefaceb96f77800919f8a1b1e0d5623226cf319da4 /recipes-kernel
parentca6d3c464b28a18b328b842a4ef6ea4f72d21f3f (diff)
downloadmeta-freescale-e828e1b284eadb604d2b3f990eed9cecb0b3ae58.tar.gz
linux-fslc-imx: update to v5.4.85
Kernel repository has been upgraded to v5.4.85 from stable korg. Following conflicts were resolved during merge: ---- - drivers/net/ethernet/stmicro/stmmac/stmmac_main.c: Ustream commit 318d902 ("net: stmmac: free tx skb buffer in stmmac_resume()") overlapped NXP commit dd7c2b7 ("MLK-24217 net: ethernet: stmmac: free tx skb buffer in stmmac_resume()"), causing double-declaration of the function to be present in the code. Replace the NXP commit with upstream one. ---- Following upstream commits are included in this version: ---- 19d1c763e849 Linux 5.4.85 484ac6279ad2 x86/resctrl: Fix incorrect local bandwidth when mba_sc is enabled eb3f42cf5e67 x86/resctrl: Remove unused struct mbm_state::chunks_bw c4f909407015 membarrier: Explicitly sync remote cores when SYNC_CORE is requested a840e37ef800 Revert "selftests/ftrace: check for do_sys_openat2 in user-memory test" aa17a20d640d KVM: mmu: Fix SPTE encoding of MMIO generation upper half bb07f4c93e62 serial: 8250_omap: Avoid FIFO corruption caused by MDR1 access 14482dc42c28 ALSA: pcm: oss: Fix potential out-of-bounds shift c94a31c19225 USB: sisusbvga: Make console support depend on BROKEN 4ad8fc6cce01 USB: UAS: introduce a quirk to set no_write_same 397d0ae4cb90 xhci-pci: Allow host runtime PM as default for Intel Alpine Ridge LP 32c820e016b4 xhci: Give USB2 ports time to enter U3 in bus suspend 5828ae0c1920 ALSA: usb-audio: Fix control 'access overflow' errors from chmap e72a55ea7168 ALSA: usb-audio: Fix potential out-of-bounds shift 56339afa39e5 USB: add RESET_RESUME quirk for Snapscan 1212 52c2ada6fe5e USB: dummy-hcd: Fix uninitialized array use in init() 497993377bca ktest.pl: If size of log is too big to email, email error message a8d28a541500 net: stmmac: delete the eee_ctrl_timer after napi disabled ee08543f4598 net: stmmac: dwmac-meson8b: fix mask definition of the m250_sel mux 5ae78c6926cc net: ll_temac: Fix potential NULL dereference in temac_probe() 717a140a3635 net/mlx4_en: Handle TX error CQE d0363dcabbd1 lan743x: fix for potential NULL pointer dereference with bare card d4107a0f8802 net/mlx4_en: Avoid scheduling restart task if it is already running add880d788f0 tcp: fix cwnd-limited bug for TSO deferral where we send nothing 5189c070a0d7 tcp: select sane initial rcvq_space.space for big MSS 318d90218b21 net: stmmac: free tx skb buffer in stmmac_resume() d8d39e13668a bridge: Fix a deadlock when enabling multicast snooping cb327f83cf5e enetc: Fix reporting of h/w packet counters 408c8213ee97 udp: fix the proto value passed to ip_protocol_deliver_rcu for the segments f7a756fc7cb9 net: hns3: remove a misused pragma packed 2ef23e860e76 vrf: packets with lladdr src needs dst at input with orig_iif when needs strict cae90bd22cff net: bridge: vlan: fix error return code in __vlan_add() 2e6a15b0b3d4 mac80211: mesh: fix mesh_pathtbl_init() error path 1fe6b822b335 ipv4: fix error return code in rtm_to_fib_config() 8b4f08f28015 ptrace: Prevent kernel-infoleak in ptrace_get_syscall_info() ---- Link: https://lore.kernel.org/r/20201219125341.384025953@linuxfoundation.org Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
index 8c94189d..d64ba9b6 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
28# ------------------------------------------------------------------------------ 28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s)) 29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------ 30# ------------------------------------------------------------------------------
31# tag: v5.4.83 31# tag: v5.4.85
32# 32#
33# ------------------------------------------------------------------------------ 33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s)) 34# 2. NXP-specific (tag or SHA(s))
@@ -79,14 +79,14 @@ LICENSE = "GPLv2"
79LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 79LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
80 80
81SRCBRANCH = "5.4-2.2.x-imx" 81SRCBRANCH = "5.4-2.2.x-imx"
82SRCREV = "95aec312c79e477bcbeb85c79f6e40aea06f4172" 82SRCREV = "350a71f471076717373c68fbe9dc5e6d3773bf57"
83 83
84# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 84# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
85# required by kernel-yocto.bbclass. 85# required by kernel-yocto.bbclass.
86# 86#
87# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 87# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
88# should be updated once patchlevel is merged. 88# should be updated once patchlevel is merged.
89LINUX_VERSION = "5.4.83" 89LINUX_VERSION = "5.4.85"
90 90
91# Local version indicates the branch name in the NXP kernel tree where patches are collected from. 91# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
92LOCALVERSION = "-imx-5.4.47-2.2.0" 92LOCALVERSION = "-imx-5.4.47-2.2.0"