summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-29 15:53:31 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:14 -0300
commit5d7917902628b84919ac9dfc332fd46a4d579e60 (patch)
tree035d9fbe202c886c75a9f7850926126b445e4309 /recipes-kernel
parente69642c47bff780e9b65f4c6853b67e5e7d271c7 (diff)
downloadmeta-freescale-5d7917902628b84919ac9dfc332fd46a4d579e60.tar.gz
cryptodev: Avoid contamination OE-Core recipe
The QorIQ version of cryptodev needs to use another recipe name and have a common provider, which is than choosen for QorIQ-based machines. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-linux_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-module_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb (renamed from recipes-kernel/cryptodev/cryptodev-tests_1.7.bb)6
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc (renamed from recipes-kernel/cryptodev/cryptodev_1.7.inc)0
4 files changed, 15 insertions, 3 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
index 92ccd717..a388b4c8 100644
--- a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.7.bb
@@ -1,7 +1,9 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A /dev/crypto device driver header file" 3SUMMARY = "A /dev/crypto device driver header file"
4 4
5PROVIDES = "cryptodev-linux"
6
5do_compile[noexec] = "1" 7do_compile[noexec] = "1"
6 8
7# Just install cryptodev.h which is the only header file needed to be exported 9# Just install cryptodev.h which is the only header file needed to be exported
@@ -10,3 +12,5 @@ do_install() {
10} 12}
11 13
12ALLOW_EMPTY_${PN} = "1" 14ALLOW_EMPTY_${PN} = "1"
15
16COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
index e6b1f27c..df2e5464 100644
--- a/recipes-kernel/cryptodev/cryptodev-module_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.7.bb
@@ -1,10 +1,14 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A /dev/crypto device driver kernel module" 3SUMMARY = "A /dev/crypto device driver kernel module"
4 4
5PROVIDES = "cryptodev-module"
6
5inherit module qoriq_build_64bit_kernel 7inherit module qoriq_build_64bit_kernel
6 8
7# Header file provided by a separate package 9# Header file provided by a separate package
8DEPENDS += "cryptodev-linux" 10DEPENDS += "cryptodev-linux"
9 11
10EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
13
14COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
index 128ccc99..dd0afecd 100644
--- a/recipes-kernel/cryptodev/cryptodev-tests_1.7.bb
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.7.bb
@@ -1,8 +1,10 @@
1require cryptodev_${PV}.inc 1require cryptodev-qoriq_${PV}.inc
2 2
3SUMMARY = "A test suite for /dev/crypto device driver" 3SUMMARY = "A test suite for /dev/crypto device driver"
4DEPENDS = "openssl" 4DEPENDS = "openssl"
5 5
6PROVIDES = "cryptodev-tests"
7
6EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"' 8EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
7 9
8do_compile() { 10do_compile() {
@@ -15,3 +17,5 @@ do_install() {
15 17
16FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug" 18FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
17FILES_${PN} = "${bindir}/tests_cryptodev/*" 19FILES_${PN} = "${bindir}/tests_cryptodev/*"
20
21COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
diff --git a/recipes-kernel/cryptodev/cryptodev_1.7.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc
index 6b65f729..6b65f729 100644
--- a/recipes-kernel/cryptodev/cryptodev_1.7.inc
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq_1.7.inc