summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-18 19:43:56 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2022-02-21 20:06:28 -0300
commit30f5ce1d2168389295b4813e01898c2fb0f9bab9 (patch)
treef6f78dbf8e5eef40510739dc1db79d60f05189fb /recipes-kernel
parenta3b102a9ed12ea03e72f713ed40968da1776c6d3 (diff)
downloadmeta-freescale-30f5ce1d2168389295b4813e01898c2fb0f9bab9.tar.gz
Generalize overrides subsystem for NXP and Mainline support
Essentially, we extend the overrides to a generic-bsp, nxp-bsp, and mainline-bsp. So, for example, the mx8mq override is split into: - imx-generic-bsp: compatible with every i.MX SoC and both BSP variants - imx-nxp-bsp: compatible with every i.MX SoC but specific to NXP BSP - imx-mainline-bsp: compatible with every i.MX SoC but specific to Mainline BSP - mx8-generic-bsp: compatible with every i.MX8 SoC and both BSP variants - mx8-nxp-bsp: compatible with every i.MX8 SoC but specific to NXP BSP - mx8-mainline-bsp: compatible with every i.MX8 SoC but specific to Mainline BSP - mx8m-generic-bsp: compatible with every i.MX8M SoC and both BSP variants - mx8m-nxp-bsp: compatible with every i.MX8M SoC but specific to NXP BSP - mx8m-mainline-bsp: compatible with every i.MX8M SoC but specific to Mainline BSP - mx8mq-generic-bsp: compatible with every i.MX8MQ SoC and both BSP variants - mx8mq-nxp-bsp: compatible with every i.MX8MQ SoC8 but specific to NXP BSP - mx8mq-mainline-bsp: compatible with every i.MX8MQ SoC but specific to Mainline BSP The extender mechanism is responsible for extending the override list to include the generic overrides. We can then use the three different variants to handle the metadata correctly. Generically speaking, the conversion mainly was automated (with a lot of back and forth until getting it right). To convert an existing layer, the following script can be used: ```sh git ls-files classes recipes-* \ | xargs sed -i \ -e 's,:\(mx[6-8]\w*\),:\1-nxp-bsp,g' \ -e 's,(\(mx[6-8]\w*\)),(\1-nxp-bsp),g' \ -e 's,\(mx[6-8]\w*\)|,\1-nxp-bsp|,g' \ -e 's,|\(mx[6-8]\w*\)),|\1-nxp-bsp),g' \ \ -e 's,:\(mx[5s]\w*\),:\1-generic-bsp,g' \ -e 's,(\(mx[5s]\w*\)),(\1-generic-bsp),g' \ -e 's,\(mx[5s]\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(mx[5s]\w*\)),|\1-generic-bsp),g' \ \ -e 's,:\(vf\w*\),:\1-generic-bsp,g' \ -e 's,:\(vf[56]0\w*\),:\1-generic-bsp,g' \ -e 's,\(vf\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(vf\w*\)),|\1-generic-bsp),g' \ -e 's,\(vf[56]0\w*\)|,\1-generic-bsp|,g' \ -e 's,|\(vf[56]0\w*\)),|\1-generic-bsp),g' \ \ -e 's,:\(imx\) ,:\1-nxp-bsp ,g' \ -e 's,(\(imx\)),(\1-nxp-bsp),g' \ -e 's,\(imx\)|,\1-nxp-bsp|,g' \ -e 's,|\(imx\)),|\1-nxp-bsp),g' for d in $(find -type d | egrep '/mx[6-8]w*'); do git mv $d $d-nxp-bsp done for d in $(find -type d | egrep '/imx$'); do git mv $d $d-nxp-bsp done for d in $(find -type d | egrep '/mx[5s]w*'); do git mv $d $d-generic-bsp done ``` Fixes: #791. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4+fslc.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb2
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-imx/imx-nxp-bsp/defconfig (renamed from recipes-kernel/linux/linux-fslc-imx/imx/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-fslc-imx/mx8-nxp-bsp/defconfig (renamed from recipes-kernel/linux/linux-fslc-imx/mx8/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-lts/mxs-generic-bsp/defconfig (renamed from recipes-kernel/linux/linux-fslc-lts/mxs/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-fslc-lts_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc/mxs-generic-bsp/defconfig (renamed from recipes-kernel/linux/linux-fslc/mxs/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-fslc_5.15.bb2
-rw-r--r--recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig (renamed from recipes-kernel/linux/linux-imx/imx/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig (renamed from recipes-kernel/linux/linux-imx/mx8/defconfig)0
-rw-r--r--recipes-kernel/linux/linux-imx_5.10.bb2
13 files changed, 7 insertions, 7 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4+fslc.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4+fslc.bb
index 18144f41..459f88d4 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4+fslc.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4+fslc.bb
@@ -17,4 +17,4 @@ S = "${WORKDIR}/git"
17inherit module 17inherit module
18 18
19KERNEL_MODULE_AUTOLOAD = "galcore" 19KERNEL_MODULE_AUTOLOAD = "galcore"
20COMPATIBLE_MACHINE = "(imx)" 20COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb
index a3433b7c..37b6d2f7 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.3.p2.4.bb
@@ -23,4 +23,4 @@ inherit module
23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m" 23EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
24 24
25KERNEL_MODULE_AUTOLOAD = "galcore" 25KERNEL_MODULE_AUTOLOAD = "galcore"
26COMPATIBLE_MACHINE = "(imx)" 26COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb
index e9a09ad7..71265e53 100644
--- a/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-isp-vvcam_4.2.2.16.0.bb
@@ -16,4 +16,4 @@ S = "${WORKDIR}/git/vvcam/v4l2"
16 16
17inherit module 17inherit module
18 18
19COMPATIBLE_MACHINE = "(mx8mp)" 19COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"
diff --git a/recipes-kernel/linux/linux-fslc-imx/imx/defconfig b/recipes-kernel/linux/linux-fslc-imx/imx-nxp-bsp/defconfig
index 6ca0833e..6ca0833e 100644
--- a/recipes-kernel/linux/linux-fslc-imx/imx/defconfig
+++ b/recipes-kernel/linux/linux-fslc-imx/imx-nxp-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-fslc-imx/mx8/defconfig b/recipes-kernel/linux/linux-fslc-imx/mx8-nxp-bsp/defconfig
index ab8c97e3..ab8c97e3 100644
--- a/recipes-kernel/linux/linux-fslc-imx/mx8/defconfig
+++ b/recipes-kernel/linux/linux-fslc-imx/mx8-nxp-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.10.bb b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
index 5078efa4..3025840d 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
@@ -87,4 +87,4 @@ LOCALVERSION = "-5.10.52-2.1.0"
87 87
88DEFAULT_PREFERENCE = "1" 88DEFAULT_PREFERENCE = "1"
89 89
90COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 90COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"
diff --git a/recipes-kernel/linux/linux-fslc-lts/mxs/defconfig b/recipes-kernel/linux/linux-fslc-lts/mxs-generic-bsp/defconfig
index a913c0dd..a913c0dd 100644
--- a/recipes-kernel/linux/linux-fslc-lts/mxs/defconfig
+++ b/recipes-kernel/linux/linux-fslc-lts/mxs-generic-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-fslc-lts_5.10.bb b/recipes-kernel/linux/linux-fslc-lts_5.10.bb
index c3410a59..ab2ee4b7 100644
--- a/recipes-kernel/linux/linux-fslc-lts_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc-lts_5.10.bb
@@ -24,4 +24,4 @@ LINUX_VERSION = "5.10.93"
24KBRANCH = "5.10.x+fslc" 24KBRANCH = "5.10.x+fslc"
25SRCREV = "de6a8455baae279feddb56c99056aa075175cd68" 25SRCREV = "de6a8455baae279feddb56c99056aa075175cd68"
26 26
27COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)" 27COMPATIBLE_MACHINE = "(mxs-generic-bsp|mx5-generic-bsp|mx6-nxp-bsp|vf-generic-bsp|use-mainline-bsp)"
diff --git a/recipes-kernel/linux/linux-fslc/mxs/defconfig b/recipes-kernel/linux/linux-fslc/mxs-generic-bsp/defconfig
index 67e47841..67e47841 100644
--- a/recipes-kernel/linux/linux-fslc/mxs/defconfig
+++ b/recipes-kernel/linux/linux-fslc/mxs-generic-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-fslc_5.15.bb b/recipes-kernel/linux/linux-fslc_5.15.bb
index 1e88adba..40d44b8b 100644
--- a/recipes-kernel/linux/linux-fslc_5.15.bb
+++ b/recipes-kernel/linux/linux-fslc_5.15.bb
@@ -24,4 +24,4 @@ LINUX_VERSION = "5.15.16"
24KBRANCH = "5.15.x+fslc" 24KBRANCH = "5.15.x+fslc"
25SRCREV = "d084d166324389d09f73d8f2e91b989d69432335" 25SRCREV = "d084d166324389d09f73d8f2e91b989d69432335"
26 26
27COMPATIBLE_MACHINE = "(mxs|mx5|mx6|vf|use-mainline-bsp)" 27COMPATIBLE_MACHINE = "(mxs-generic-bsp|mx5-generic-bsp|mx6-nxp-bsp|vf-generic-bsp|use-mainline-bsp)"
diff --git a/recipes-kernel/linux/linux-imx/imx/defconfig b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig
index 6ca0833e..6ca0833e 100644
--- a/recipes-kernel/linux/linux-imx/imx/defconfig
+++ b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-imx/mx8/defconfig b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig
index 775fd503..775fd503 100644
--- a/recipes-kernel/linux/linux-imx/mx8/defconfig
+++ b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig
diff --git a/recipes-kernel/linux/linux-imx_5.10.bb b/recipes-kernel/linux/linux-imx_5.10.bb
index e287fa39..79506b38 100644
--- a/recipes-kernel/linux/linux-imx_5.10.bb
+++ b/recipes-kernel/linux/linux-imx_5.10.bb
@@ -30,4 +30,4 @@ LINUX_VERSION = "5.10.72"
30 30
31DEFAULT_PREFERENCE = "1" 31DEFAULT_PREFERENCE = "1"
32 32
33COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 33COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)"