diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-05-27 07:38:30 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-05-27 08:20:43 -0300 |
commit | 733e1683ce8895a960c01a3ee1fce40118d82982 (patch) | |
tree | 7a9c59fddd13e85910d6d5d72969688db99d046f /recipes-kernel | |
parent | 1d7ecadd16126cd6bdd311a0dac2d646927c1a30 (diff) | |
download | meta-freescale-733e1683ce8895a960c01a3ee1fce40118d82982.tar.gz |
linux-fslc-imx: update to v5.4.122
Kernel repository has been upgraded to v5.4.122 from stable korg.
Following commit is included separately in this version:
----
ff9d9347c331 mmc: core: fix missing reserved indexes
----
Following upstream commits are included in this version:
----
67154cff6258 Linux 5.4.122
f97257cde764 Bluetooth: SMP: Fail if remote and local public keys are identical
46b4a9c68572 video: hgafb: correctly handle card detect failure during probe
3c18dc7de2bc nvmet: use new ana_log_size instead the old one
a6f5ef8c1717 Bluetooth: L2CAP: Fix handling LE modes by L2CAP_OPTIONS
d3d648163a03 ext4: fix error handling in ext4_end_enable_verity()
829203752441 nvme-multipath: fix double initialization of ANA state
2dea1e9ae5cf tty: vt: always invoke vc->vc_sw->con_resize callback
cf52b24b172e vt: Fix character height handling with VT_RESIZEX
971b3fb5b9a6 vgacon: Record video mode changes with VT_RESIZEX
f0c9d29f232a video: hgafb: fix potential NULL pointer dereference
44fe392e1adc qlcnic: Add null check after calling netdev_alloc_skb
4914c67f1a62 leds: lp5523: check return value of lp5xx_read and jump to cleanup code
171b3c1afaeb ics932s401: fix broken handling of errors when word reading fails
d14cd329d83b net: rtlwifi: properly check for alloc_workqueue() failure
533ac32a80c0 scsi: ufs: handle cleanup correctly on devm_reset_control_get error
9e38cf9c3070 net: stmicro: handle clk_prepare() failure during init
9d59d4364dfb ethernet: sun: niu: fix missing checks of niu_pci_eeprom_read()
8f2efd687d19 Revert "niu: fix missing checks of niu_pci_eeprom_read"
04a064b36576 Revert "qlcnic: Avoid potential NULL pointer dereference"
6d53d54ff5be Revert "rtlwifi: fix a potential NULL pointer dereference"
7fb963895513 Revert "media: rcar_drif: fix a memory disclosure"
6f2e5eb82557 cdrom: gdrom: initialize global variable at init time
283cd246bcc1 cdrom: gdrom: deallocate struct gdrom_unit fields in remove_gdrom
7e230e5ed8fd Revert "gdrom: fix a memory leak bug"
6ef6f8cd1d34 Revert "scsi: ufs: fix a missing check of devm_reset_control_get"
9c24899f1fae Revert "ecryptfs: replace BUG_ON with error handling code"
a1f0e2bb4975 Revert "video: imsttfb: fix potential NULL pointer dereferences"
bd2a12549fc2 Revert "hwmon: (lm80) fix a missing check of bus read in lm80 probe"
5c463887edb3 Revert "leds: lp5523: fix a missing check of return value of lp55xx_read"
1cb9f88cde8c Revert "net: stmicro: fix a missing check of clk_prepare"
6f2a72774f38 Revert "video: hgafb: fix potential NULL pointer dereference"
3471a221f308 dm snapshot: fix crash with transient storage and zero chunk size
198ee66478b3 xen-pciback: reconfigure also from backend watch handler
f1d3c63c3f12 mmc: sdhci-pci-gli: increase 1.8V regulator wait
d9e9ec363560 drm/amdgpu: update sdma golden setting for Navi12
e3be683d5e4e drm/amdgpu: update gc golden setting for Navi12
1f0495355b60 drm/amdgpu: disable 3DCGCG on picasso/raven1 to avoid compute hang
c11d59e5edba Revert "serial: mvebu-uart: Fix to avoid a potential NULL pointer dereference"
d55df42ef369 rapidio: handle create_workqueue() failure
9f2a613e4b0b Revert "rapidio: fix a NULL pointer dereference when create_workqueue() fails"
cdd91637d4ef uio_hv_generic: Fix a memory leak in error handling paths
b0fc59e62bf9 ALSA: hda/realtek: Add fixup for HP Spectre x360 15-df0xxx
c4e7ed4fa1b1 ALSA: hda/realtek: Add fixup for HP OMEN laptop
2331f2592879 ALSA: hda/realtek: Fix silent headphone output on ASUS UX430UA
1c783bfa7f8d ALSA: hda/realtek: Add some CLOVE SSIDs of ALC293
be1f7f30b66b ALSA: hda/realtek: reset eapd coeff to default value for alc287
b2297d1b9511 ALSA: firewire-lib: fix check for the size of isochronous packet payload
f95aabb6aed4 Revert "ALSA: sb8: add a check for request_region"
2ed8227ebd84 ALSA: hda: fixup headset for ASUS GU502 laptop
7ef36d303592 ALSA: bebob/oxfw: fix Kconfig entry for Mackie d.2 Pro
844faf4a9675 ALSA: usb-audio: Validate MS endpoint descriptors
c7456fc35dc8 ALSA: firewire-lib: fix calculation for size of IR context payload
7981c124e34d ALSA: dice: fix stream format at middle sampling rate for Alesis iO 26
f72b96ff7935 ALSA: line6: Fix racy initialization of LINE6 MIDI
048840df6de8 ALSA: intel8x0: Don't update period unless prepared
a67a88f9e667 ALSA: dice: fix stream format for TC Electronic Konnekt Live at high sampling transfer frequency
34413f21acea cifs: fix memory leak in smb2_copychunk_range
20197d327560 btrfs: avoid RCU stalls while running delayed iputs
845c2b9d99b6 locking/mutex: clear MUTEX_FLAGS if wait_list is empty due to signal
439ce949ee90 nvmet: seset ns->file when open fails
670d34d54320 ptrace: make ptrace() fail if the tracee changed its pid unexpectedly
88128a5054f1 RDMA/uverbs: Fix a NULL vs IS_ERR() bug
6fa78a6b9a3b platform/x86: dell-smbios-wmi: Fix oops on rmmod dell_smbios
6e90ff540a7b platform/mellanox: mlxbf-tmfifo: Fix a memory barrier issue
66abc4ef6a8b RDMA/core: Don't access cm_id after its destruction
73e25a2d51bb RDMA/mlx5: Recover from fatal event in dual port mode
8d8b8016e0af scsi: qla2xxx: Fix error return code in qla82xx_write_flash_dword()
07865459eb62 scsi: ufs: core: Increase the usable queue depth
a62225d951d7 RDMA/rxe: Clear all QP fields if creation failed
257f132342ea RDMA/siw: Release xarray entry
a19bb4c0566c RDMA/siw: Properly check send and receive CQ pointers
a03676848886 openrisc: Fix a memory leak
50fd584fbbb3 firmware: arm_scpi: Prevent the ternary sign expansion bug
----
Link: https://lore.kernel.org/r/20210524152326.447759938@linuxfoundation.org
Link: https://github.com/Freescale/linux-fslc/pull/355
Link: https://github.com/Freescale/linux-fslc/pull/359
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-fslc-imx_5.4.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.4.bb b/recipes-kernel/linux/linux-fslc-imx_5.4.bb index e759106a..672e0a3d 100644 --- a/recipes-kernel/linux/linux-fslc-imx_5.4.bb +++ b/recipes-kernel/linux/linux-fslc-imx_5.4.bb | |||
@@ -28,7 +28,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community." | |||
28 | # ------------------------------------------------------------------------------ | 28 | # ------------------------------------------------------------------------------ |
29 | # 1. Stable (tag or SHA(s)) | 29 | # 1. Stable (tag or SHA(s)) |
30 | # ------------------------------------------------------------------------------ | 30 | # ------------------------------------------------------------------------------ |
31 | # tag: v5.4.121 | 31 | # tag: v5.4.122 |
32 | # | 32 | # |
33 | # ------------------------------------------------------------------------------ | 33 | # ------------------------------------------------------------------------------ |
34 | # 2. NXP-specific (tag or SHA(s)) | 34 | # 2. NXP-specific (tag or SHA(s)) |
@@ -71,14 +71,14 @@ LICENSE = "GPLv2" | |||
71 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" | 71 | LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" |
72 | 72 | ||
73 | KBRANCH = "5.4-2.3.x-imx" | 73 | KBRANCH = "5.4-2.3.x-imx" |
74 | SRCREV = "52ae115cca1fa0c3a96ea9563dd962bec3d23fa2" | 74 | SRCREV = "f1aad6febd86b718e6b34d87eb245026d704ae94" |
75 | 75 | ||
76 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition | 76 | # PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition |
77 | # required by kernel-yocto.bbclass. | 77 | # required by kernel-yocto.bbclass. |
78 | # | 78 | # |
79 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and | 79 | # LINUX_VERSION define should match to the kernel version referenced by SRC_URI and |
80 | # should be updated once patchlevel is merged. | 80 | # should be updated once patchlevel is merged. |
81 | LINUX_VERSION = "5.4.121" | 81 | LINUX_VERSION = "5.4.122" |
82 | 82 | ||
83 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. | 83 | # Local version indicates the branch name in the NXP kernel tree where patches are collected from. |
84 | LOCALVERSION = "-imx-5.4.70-2.3.0" | 84 | LOCALVERSION = "-imx-5.4.70-2.3.0" |