diff options
author | Chunrong Guo <chunrong.guo@nxp.com> | 2017-10-18 13:06:31 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-10-18 11:42:30 -0200 |
commit | 672b2873c7e35732d2ca5acff75af7fea0e7018e (patch) | |
tree | 339f8dd0632045d6d5c96dd1fabd603e29444477 /recipes-kernel | |
parent | a9574035ad7bb46f37817f0c07611778017760ca (diff) | |
download | meta-freescale-672b2873c7e35732d2ca5acff75af7fea0e7018e.tar.gz |
linux-qoriq: Upgrade kernel to v4.9
Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r-- | recipes-kernel/linux/linux-qoriq_4.9.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb new file mode 100644 index 00000000..db0d29bc --- /dev/null +++ b/recipes-kernel/linux/linux-qoriq_4.9.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | inherit kernel qoriq_build_64bit_kernel | ||
2 | inherit fsl-kernel-localversion | ||
3 | |||
4 | SUMMARY = "Linux Kernel for Freescale QorIQ platforms" | ||
5 | SECTION = "kernel" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" | ||
8 | |||
9 | SRC_URI = "git://github.com/qoriq-open-source/linux.git;nobranch=1 \ | ||
10 | " | ||
11 | SRCREV = "1e65b659831680691ffcfca687f568367122873e" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS_append = " libgcc" | ||
16 | # not put Images into /boot of rootfs, install kernel-image if needed | ||
17 | RDEPENDS_kernel-base = "" | ||
18 | |||
19 | KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}" | ||
20 | KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}" | ||
21 | KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}" | ||
22 | |||
23 | ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}" | ||
24 | ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME" | ||
25 | |||
26 | SCMVERSION ?= "y" | ||
27 | LOCALVERSION = "" | ||
28 | DELTA_KERNEL_DEFCONFIG ?= "" | ||
29 | DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config " | ||
30 | DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config lsdk.config multi_v8.config " | ||
31 | DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config " | ||
32 | |||
33 | do_merge_delta_config() { | ||
34 | # copy desired defconfig so we pick it up for the real kernel_do_configure | ||
35 | cp ${KERNEL_DEFCONFIG} .config | ||
36 | |||
37 | # add config fragments | ||
38 | for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do | ||
39 | if [ -f "${deltacfg}" ]; then | ||
40 | ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg} | ||
41 | elif [ -f "${WORKDIR}/${deltacfg}" ]; then | ||
42 | ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} | ||
43 | elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then | ||
44 | ${S}/scripts/kconfig/merge_config.sh -m .config \ | ||
45 | ${S}/arch/${ARCH}/configs/${deltacfg} | ||
46 | fi | ||
47 | done | ||
48 | cp .config ${WORKDIR}/defconfig | ||
49 | } | ||
50 | addtask merge_delta_config before do_preconfigure after do_patch | ||
51 | |||
52 | # The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b) | ||
53 | do_compile_prepend_fsl-lsch2-32b() { | ||
54 | ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale | ||
55 | } | ||
56 | |||
57 | do_install_append_qoriq-arm() { | ||
58 | install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} | ||
59 | ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage | ||
60 | } | ||
61 | |||
62 | FILES_kernel-image += "/boot/zImage*" | ||
63 | COMPATIBLE_MACHINE = "(qoriq)" | ||