summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-07-16 01:42:34 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit3b078cb194577d3f1fb88be4638191a3bd7e5403 (patch)
treeab2b3fc37188a2e5916c1a3d68106f739735d622 /recipes-kernel
parent81ab9b5e13b39c504005b77fe094d9853fae9915 (diff)
downloadmeta-freescale-3b078cb194577d3f1fb88be4638191a3bd7e5403.tar.gz
linux-qoriq: add merge_delta_config task
fsl-kernel-localversion added a separate task in which defconfig is needed. But qoriq boards don't have a unified defconfig, different KERNEL_DEFCONFIG should be copied as ${WORKDIR}/defconfig. add a merge_delta_config task to merge kernel delta configs. for ls1043ardb and ls2080ardb, freescale.config should be appended first. Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.1.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.1.bb b/recipes-kernel/linux/linux-qoriq_4.1.bb
index d2c821f2..97611feb 100644
--- a/recipes-kernel/linux/linux-qoriq_4.1.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.1.bb
@@ -31,8 +31,10 @@ ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
31SCMVERSION ?= "y" 31SCMVERSION ?= "y"
32LOCALVERSION = "" 32LOCALVERSION = ""
33DELTA_KERNEL_DEFCONFIG ?= "" 33DELTA_KERNEL_DEFCONFIG ?= ""
34DELTA_KERNEL_DEFCONFIG_prepend_ls1043ardb = "freescale.config "
35DELTA_KERNEL_DEFCONFIG_prepend_ls2080ardb = "freescale.config "
34 36
35do_configure_prepend() { 37do_merge_delta_config() {
36 # copy desired defconfig so we pick it up for the real kernel_do_configure 38 # copy desired defconfig so we pick it up for the real kernel_do_configure
37 cp ${KERNEL_DEFCONFIG} .config 39 cp ${KERNEL_DEFCONFIG} .config
38 40
@@ -44,11 +46,12 @@ do_configure_prepend() {
44 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg} 46 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
45 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then 47 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then
46 ${S}/scripts/kconfig/merge_config.sh -m .config \ 48 ${S}/scripts/kconfig/merge_config.sh -m .config \
47 ${S}/arch/powerpc/configs/${deltacfg} 49 ${S}/arch/${ARCH}/configs/${deltacfg}
48 fi 50 fi
49 done 51 done
50 cp .config ${WORKDIR}/defconfig 52 cp .config ${WORKDIR}/defconfig
51} 53}
54addtask merge_delta_config before do_preconfigure after do_patch
52 55
53do_install_append_qoriq-arm() { 56do_install_append_qoriq-arm() {
54 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION} 57 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION}