summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/pkc-host
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-kernel/pkc-host
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/pkc-host')
-rw-r--r--recipes-kernel/pkc-host/pkc-host_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-kernel/pkc-host/pkc-host_git.bb b/recipes-kernel/pkc-host/pkc-host_git.bb
new file mode 100644
index 00000000..2609adb7
--- /dev/null
+++ b/recipes-kernel/pkc-host/pkc-host_git.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "pkc host driver"
2SECTION = "pkc-host"
3LICENSE = "BSD & GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=99803d8e9a595c0bdb45ca710f353813"
5
6inherit module qoriq_build_64bit_kernel
7RDEPENDS_${PN} += "cryptodev-module bc"
8
9# Currently pkc-host does not support RSA_KEYGEN, remove this
10# if it is fixed.
11REQUIRED_DISTRO_FEATURES = "c29x_pkc"
12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1"
14SRCREV = "564f535d596f43eb2901a7ff77bbe529a118c16e"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
19
20do_install() {
21 oe_runmake INSTALL_MOD_PATH="${D}" modules_install
22 install -d ${D}/etc/crypto
23 install -d ${D}/${bindir}
24 cp ${S}/crypto.cfg ${D}/etc/crypto
25 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto
26 cp ${S}/apps/cli/cli ${D}/${bindir}
27 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir}
28}
29
30
31FILES_${PN} = "${bindir}/cli \
32 ${bindir}/c29x_driver_perf_profile.sh \
33 /etc/crypto/crypto.cfg \
34 /etc/crypto/pkc-firmware.bin \
35"