summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/pkc-host
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-01-31 12:46:33 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-02-06 10:02:16 -0200
commitffd0cd5ef1a1101da4b271a9e08223b72e08884e (patch)
treeef4b78988dc56827a1452d39e9ffb838f58a7611 /recipes-kernel/pkc-host
parent0f1a091da3c7a598588bcc4c1ffbe1ee1843c599 (diff)
downloadmeta-freescale-ffd0cd5ef1a1101da4b271a9e08223b72e08884e.tar.gz
pkc-host: remove
This pkg will not be supported anymore. Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/pkc-host')
-rw-r--r--recipes-kernel/pkc-host/pkc-host_git.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/recipes-kernel/pkc-host/pkc-host_git.bb b/recipes-kernel/pkc-host/pkc-host_git.bb
deleted file mode 100644
index ece2a613..00000000
--- a/recipes-kernel/pkc-host/pkc-host_git.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1DESCRIPTION = "pkc host driver"
2SECTION = "pkc-host"
3LICENSE = "BSD & GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=99803d8e9a595c0bdb45ca710f353813"
5
6inherit module qoriq_build_64bit_kernel
7RDEPENDS_${PN} += "cryptodev-module bc"
8
9# Currently pkc-host does not support RSA_KEYGEN, remove this
10# if it is fixed.
11REQUIRED_DISTRO_FEATURES = "c29x_pkc"
12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;branch=sdk-v2.0.x"
14SRCREV = "e021464d700b3259d7114fb6e5e54a9f9c3ee326"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
19
20do_compile_prepend() {
21 sed -i 's#-Werror##g' ${S}/Makefile
22}
23
24do_install() {
25 oe_runmake INSTALL_MOD_PATH="${D}" modules_install
26 install -d ${D}/etc/crypto
27 install -d ${D}/${bindir}
28 cp ${S}/crypto.cfg ${D}/etc/crypto
29 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto
30 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir}
31}
32
33
34FILES_${PN} = "${bindir}/cli \
35 ${bindir}/c29x_driver_perf_profile.sh \
36 /etc/crypto/crypto.cfg \
37 /etc/crypto/pkc-firmware.bin \
38"
39
40COMPATIBLE_MACHINE = "(qoriq-ppc)"
41PACKAGE_ARCH = "${MACHINE_SOCARCH}"
42