summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-11-13 13:01:03 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-11-16 11:09:27 -0200
commitb9c19a6d1ab14fd86dc89ea07f307a849af1673a (patch)
treeb84b1875f54c326e6954d1a5f5180e67c5c23bde /recipes-kernel/linux
parent3e27bd71605502fce20a00e5a4f29a35ed51e487 (diff)
downloadmeta-freescale-b9c19a6d1ab14fd86dc89ea07f307a849af1673a.tar.gz
linux-qoriq_4.4: remove do_install and do_deploy for qoriq-arm
*qoriq-arm support kernel itb types so remove do_deploy and do_install for zImage Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.4.bb11
1 files changed, 0 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.4.bb b/recipes-kernel/linux/linux-qoriq_4.4.bb
index 55c616a5..70e3bf6c 100644
--- a/recipes-kernel/linux/linux-qoriq_4.4.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.4.bb
@@ -59,16 +59,5 @@ do_install_prepend_fsl-lsch2-32b() {
59 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale 59 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
60} 60}
61 61
62do_install_append_qoriq-arm() {
63 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION}
64 ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage
65}
66
67do_deploy_append_qoriq-arm() {
68 install -m 0644 arch/${ARCH}/boot/zImage ${DEPLOYDIR}/${ZIMAGE_BASE_NAME}.bin
69 ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage-${MACHINE}.bin
70 ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage
71}
72
73FILES_kernel-image += "/boot/zImage*" 62FILES_kernel-image += "/boot/zImage*"
74COMPATIBLE_MACHINE = "(qoriq)" 63COMPATIBLE_MACHINE = "(qoriq)"