summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.19.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-04-01 14:17:13 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-04-11 09:00:13 -0300
commit14e1ea04d72a6f0df3538db33f5c6d8fef7f5ab2 (patch)
tree33254c348ccd874961dda3d46f03b4c57c70dc5c /recipes-kernel/linux/linux-qoriq_4.19.bb
parent9524d32736f3f627461cdad250f3e2280f78173e (diff)
downloadmeta-freescale-14e1ea04d72a6f0df3538db33f5c6d8fef7f5ab2.tar.gz
linux-qoriq/4.19 : add recipes
*Update to lsdk 1903 tag include the following changes: c0c2141 - vfio/fsl-mc: Reset container on last reference release 628aca9 - Revert "net: phy: aquantia: add pause frame support" 99f8355 - Update the year of NXP copyright 66ca144 - powerpc/dts/fsl: add crypto node alias for B4 1d98121 - arm64: dts: ls1043a: add crypto node alias also for qds bef16ab - soc: fsl: dpio: Increase timeout for QBMan Management Commands deb34f2 - soc: fsl: qbman: avoid race in clearing QMan interrupt ab14cd9 - i2c: imx: defer probing on dma channel request a48d147 - i2c: imx: fix dma_request_chan error handling a8e3023 - i2c: imx: improve the error handling in i2c_imx_dma_request() dd6f891 - i2c: imx: notify about real errors on dma i2c_imx_dma_request 9335f72 - crypto: caam - fix building job ring as module 0bc1219 - soc/fsl/bqman: page align iommu mapping sizes aabe1ef - sdk: dts: remove dma-coherent from sdk dts for QE 68aad5f - net: phy: aquantia: add pause frame support 4f96e7e - staging: fsl-dpaa2/mac: Fix bug in pause frame advertising 1f10c93 - staging: fsl-dpaa2/mac: add pause frames support for managed phys 81c18ad - dpaa2-eth: Update pause frames settings on link up 473f1b9 - dpaa2-eth: fix race condition with bql frame accounting 0ccd3c2 - dpaa2-eth: configure the cache stashing amount on a queue 8992d4e - crypto: caam - move shared symbols in a common location f8d1f310 - dmaengine: fsl-edma: dma map slave device address 75ea596 - arm64: dts: lx2160a: add flextimer entry Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.19.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.19.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.19.bb b/recipes-kernel/linux/linux-qoriq_4.19.bb
new file mode 100644
index 00000000..c5105d02
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq_4.19.bb
@@ -0,0 +1,72 @@
1inherit kernel qoriq_build_64bit_kernel siteinfo
2inherit fsl-kernel-localversion
3
4SUMMARY = "Linux Kernel for NXP QorIQ platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
8
9SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/linux;nobranch=1 \
10"
11SRCREV = "c0c2141106240d61e7b9d7c80284711d54f6ae91"
12
13SRC_URI += " file://0001-Makfefile-add-cflags.patch \
14"
15S = "${WORKDIR}/git"
16
17DEPENDS_append = " libgcc"
18# not put Images into /boot of rootfs, install kernel-image if needed
19RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
20
21KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
22KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
23KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
24
25ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
26ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
27
28SCMVERSION ?= "y"
29LOCALVERSION = ""
30DELTA_KERNEL_DEFCONFIG ?= ""
31DELTA_KERNEL_DEFCONFIG_prepend_qoriq-arm64 = "lsdk.config "
32DELTA_KERNEL_DEFCONFIG_prepend_fsl-lsch2-32b = "multi_v7_lpae.config multi_v8.config lsdk.config "
33DELTA_KERNEL_DEFCONFIG_prepend_ls102xa = "multi_v7_lpae.config lsdk.config "
34
35do_merge_delta_config[depends] += "virtual/${TARGET_PREFIX}gcc:do_populate_sysroot"
36do_merge_delta_config[dirs] = "${B}"
37
38do_merge_delta_config() {
39 # create config with make config
40 oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG}
41
42 # check if bigendian is enabled
43 if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then
44 echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config
45 echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config
46 fi
47
48 # add config fragments
49 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
50 if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then
51 oe_runmake -C ${S} O=${B} ${deltacfg}
52 elif [ -f "${WORKDIR}/${deltacfg}" ]; then
53 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
54 elif [ -f "${deltacfg}" ]; then
55 ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg}
56 fi
57 done
58 cp .config ${WORKDIR}/defconfig
59}
60addtask merge_delta_config before do_preconfigure after do_patch
61
62# The link of dts folder is needed for 32b compile of aarch64 targets(e.g. ls1043ardb-32b)
63do_compile_prepend_fsl-lsch2-32b() {
64 ln -sfT ${STAGING_KERNEL_DIR}/arch/arm64/boot/dts/freescale ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
65}
66
67do_install_prepend_fsl-lsch2-32b() {
68 rm -f ${STAGING_KERNEL_DIR}/arch/arm/boot/dts/freescale
69}
70
71FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
72COMPATIBLE_MACHINE = "(qoriq)"