summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-09-29 16:59:52 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-01 13:51:02 -0300
commitdef0ba123a5d9fe7ec805ec2ef19d78a6be80279 (patch)
tree02280eca3b34d7f56028a16daa3d9cc55357a162 /recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
parentde30c1e2d675f9fb73588dc5c0c495a3464f7ab2 (diff)
downloadmeta-freescale-def0ba123a5d9fe7ec805ec2ef19d78a6be80279.tar.gz
linux-qoriq/4.9: update to e8b01fb
*update to lsdk 1809 tag include the following changes: e8b01fb - Merge branch 'linux-4.9-nxp' into linux-4.9 on Sep 18, 2018 b4e1e65 - staging: fsl_ppfe/eth: handle ls1012a errata_a010897 08fbe85 - staging: fsl_ppfe/eth: disable CRC removal b8cccb6 - staging: fsl_ppfe/eth: remove jumbo frame enable from gemac init 70d99b6 - staging: fsl_ppfe/eth: define pfe ndo_change_mtu function 2b5471a - staging: fsl_ppfe/eth: use mask for rx max frame len 6f5a39f - staging: fsl_ppfe/eth: reorganize pfe_netdev_ops 7fcc6a4 - sdk_dpaa: ls1043a errata: move comment b24a3d7 - sdk_dpaa: ls1043a errata: align skb_shinfo 9eb7396 - Merge branch 'linux-4.9-nxp' into linux-4.9 on Sep 17, 2018 5f51ee4 - mtd: fsl-quadspi: introduce variable to fix different invalid master Id for different platform a868c814 - encrypted_keys: Adds support for secure key-type as master key. 9262d84 - Merge branch 'linux-4.9-nxp' into linux-4.9 on Sep 13, 2018 b2a7693 - crypto: caam - fix DMA mapping direction for RSA forms 2 & 3 1263e51 - crypto: caam/jr - fix descriptor DMA unmapping 2b246c3 - sdk_dpaa: store the skb backpointer in the skb headroom f958c10 - powerpc/mpc85xx: fix issues in clock node 3840325 - Fix compiling error b750b6e - security/keys/secure_key: Adds the secure key support based on CAAM. 233cfc7 - tee: optee: making OPTEE_SHM_NUM_PRIV_PAGES configurable via Kconfig bd42cc4 - Merge branch 'linux-4.9-nxp' into linux-4.9 on Sep 5, 2018 82f6df6 - fmd: use "fsl,fman-ptp-timer" compatible for ptp probe fe785fb - sdk_dpaa: fix jumboframe issue de252a4 - Merge branch 'linux-4.9-nxp' into linux-4.9 on Sep 4, 2018 10e02ba - arm64: dts: updates for Unified Backplane driver eb39c2c - arm64: dts: ls1046: add support for 10GBase-KR dcd820f - arm64: dts: ls1088a: add backplane support d0a2671 - arm64: dts: ls2088a: update backplane support with dpmac connections 4a2312c - staging: fsl-dpaa2/eth: Delay netdev_register() call ba1a544 - crypto: tcrypt - reschedule during speed tests 6fee36b - Merge branch 'linux-4.9-nxp' into linux-4.9 on Aug 30, 2018 c15a4ca - Merge Linaro LSK linux-4.9.124 into linux-4.9 7ca5139 - Merge tag 'v4.9.124' into linux-linaro-lsk-v4.9 *refresh patches Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch')
-rw-r--r--recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
new file mode 100644
index 00000000..b4c4aed8
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq/0001-Makefile-fix-gcc-8-build-error.patch
@@ -0,0 +1,25 @@
1From 5066b8f46b0f2348881923491b93825ac04d13d2 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Sat, 29 Sep 2018 14:12:34 +0800
4Subject: [PATCH] Makefile: fix gcc-8 build error
5
6Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
7---
8 Makefile | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/Makefile b/Makefile
12index 53d57ac..b7c5fd4 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -395,6 +395,7 @@ LINUXINCLUDE += $(filter-out $(LINUXINCLUDE),$(USERINCLUDE))
16 KBUILD_AFLAGS := -D__ASSEMBLY__
17 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
18 -fno-strict-aliasing -fno-common \
19+ -Wno-packed-not-aligned -Wno-tautological-compare \
20 -Werror-implicit-function-declaration \
21 -Wno-format-security \
22 -std=gnu89
23--
241.8.3.1
25