summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq.inc
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-06-30 15:28:04 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit74b810c4d5aabc6ef2d2bbd2b82dc1f6e283a434 (patch)
treec551db6cac52892e30de1363125b3e01336c1d31 /recipes-kernel/linux/linux-qoriq.inc
parentcfafc51d74e7af329098cb5f721c9951ec5ce997 (diff)
downloadmeta-freescale-74b810c4d5aabc6ef2d2bbd2b82dc1f6e283a434.tar.gz
linux-qoriq: merge .inc and .bb file
No code change. Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq.inc')
-rw-r--r--recipes-kernel/linux/linux-qoriq.inc56
1 files changed, 0 insertions, 56 deletions
diff --git a/recipes-kernel/linux/linux-qoriq.inc b/recipes-kernel/linux/linux-qoriq.inc
deleted file mode 100644
index a01798e1..00000000
--- a/recipes-kernel/linux/linux-qoriq.inc
+++ /dev/null
@@ -1,56 +0,0 @@
1inherit kernel kernel-arch qoriq_build_64bit_kernel
2inherit fsl-kernel-localversion
3require recipes-kernel/linux/linux-dtb.inc
4
5DESCRIPTION = "Linux kernel for Freescale platforms"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
8
9S = "${WORKDIR}/git"
10
11DEPENDS_append = " libgcc"
12# not put uImage into /boot of rootfs, install kernel-image if needed
13RDEPENDS_kernel-base = ""
14
15KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
16KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
17
18KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT}"
19ZIMAGE_BASE_NAME = "zImage-${PKGE}-${PKGV}-${PKGR}-${MACHINE}-${DATETIME}"
20ZIMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
21
22SCMVERSION ?= "y"
23LOCALVERSION = ""
24DELTA_KERNEL_DEFCONFIG ?= ""
25
26do_configure_prepend() {
27 # copy desired defconfig so we pick it up for the real kernel_do_configure
28 cp ${KERNEL_DEFCONFIG} .config
29 # add config fragments
30 for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
31 if [ -f "${deltacfg}" ]; then
32 ${S}/scripts/kconfig/merge_config.sh -m .config ${deltacfg}
33 elif [ -f "${WORKDIR}/${deltacfg}" ]; then
34 ${S}/scripts/kconfig/merge_config.sh -m .config ${WORKDIR}/${deltacfg}
35 elif [ -f "${S}/arch/${ARCH}/configs/${deltacfg}" ]; then
36 ${S}/scripts/kconfig/merge_config.sh -m .config \
37 ${S}/arch/powerpc/configs/${deltacfg}
38 fi
39 done
40 cp .config ${WORKDIR}/defconfig
41}
42
43do_install_append_qoriq-arm() {
44 install -m 0644 arch/${ARCH}/boot/zImage ${D}/boot/zImage-${KERNEL_VERSION}
45}
46
47do_deploy_append_qoriq-arm() {
48 install -m 0644 arch/${ARCH}/boot/zImage ${DEPLOYDIR}/${ZIMAGE_BASE_NAME}.bin
49 ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage-${MACHINE}.bin
50 ln -sf ${ZIMAGE_BASE_NAME}.bin ${DEPLOYDIR}/zImage
51}
52
53FILES_kernel-image += "/boot/zImage*"
54
55# make everything compatible for the time being
56COMPATIBLE_MACHINE = "(qoriq)"