summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_5.15.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-02 11:38:59 -0500
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-05-05 17:21:28 +0000
commit7d4566f9239278192bc51cc8bb76e5cf640498f9 (patch)
treef225e49e5d20367bbb0d2345d1385b48152b1abc /recipes-kernel/linux/linux-imx_5.15.bb
parent2fb1ce365338126aad365012ebb913b3e4a9f1be (diff)
downloadmeta-freescale-7d4566f9239278192bc51cc8bb76e5cf640498f9.tar.gz
linux-imx: Upgrade to 5.15.5
For i.MX 6 & 7, replace imx-nxp-bsp/defconfig from kernel source arch/arm/configs/imx_v7_defconfig: ``` ae1a8f7eeab2 LF-5139 arm32: imx_v7_defconfig: enable Kernel TLS support. acf0667c42b2 LF-5146-5 ARM: config: imx_v7_defconfig: remove rpmsg_input driver 0d35a6e32c17 LF-5146-2 ARM: config: imx_v7_defocnfig: build module for rpmsg iio pedometer 13c7c5411c99 arm: imx_v7_defconfig: enable AF_ALG interface to Kernel crypto. 575132709617 LF-4742-2 ARM: imx_v7_defconfig: enable xxhash and blake2 crypto algorithms fcac26ee3297 LF-4616-1 ARM: defconfig: add imx_v7_defconfig ``` For i.MX 8, replace mx8-nxp-bsp/defconfig from kernel source arch/arm64/configs/imx_v8_defconfig: ``` 664882f1914d LF-5139 arm64: imx_v8_defconfig: enable Kernel TLS support. 85db0a72028f MLK-25749-7: arch: arm64: configs: saving defconfig for HDCP f4f12d7be427 LF-5144-9: arm64: imx_v8_defconfig: Use newly added config symbols to enable SOF 262d0a690292 LF-5015-4 arm64: imx_v8_defconfig: Build in Rocktech Himax8394f MIPI DSI panel drm driver c52e7d279c56 hotfix: arm64: imx_v8_defconfig: update defconfig b04de7fd94dd LF-4748-1 arm64: imx_v8_defconfig: keep wm8960 as a module d448544fe874 hotfix: imx_v8_defconfig: add missing CONFIG_VIDEO_IMX8_JPEG f5374c5a5161 MGS-6358: arm64: imx_v8_defconfig: enable xz compression and freezer b04c02b2bdff LF-4616-2 arm64: defconfig: add imx_v8_defconfig ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 8dab2cfab2b333ec36e508a5a0068683f99c861f)
Diffstat (limited to 'recipes-kernel/linux/linux-imx_5.15.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_5.15.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_5.15.bb b/recipes-kernel/linux/linux-imx_5.15.bb
new file mode 100644
index 00000000..751e4c9f
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_5.15.bb
@@ -0,0 +1,39 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2021 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15LICENSE = "GPL-2.0-only"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18DEPENDS += "lzop-native bc-native"
19
20# UPGRADE NOTE:
21# The linux-imx kernel build uses a defconfig maintained in the layer. That
22# defconfig is a copy of a defconfig maintained by NXP in the source.
23# | defconfig in layer | copied from NXP kernel source |
24# | linux-imx/imx-nxp-bsp/defconfig | arch/arm/configs/imx_v7_defconfig |
25# | linux-imx/mx8-nxp-bsp/defconfig | arch/arm64/configs/imx_v8_defconfig |
26SRCBRANCH = "lf-5.15.y"
27LOCALVERSION = "-5.15.5_1.0.0"
28SRCREV = "c1084c2773fc1005ed140db625399d5334d94a28"
29
30# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
31# required by kernel-yocto.bbclass.
32#
33# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
34# should be updated once patchlevel is merged.
35LINUX_VERSION = "5.15.5"
36
37DEFAULT_PREFERENCE = "1"
38
39COMPATIBLE_MACHINE = "(imx-nxp-bsp)"