summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_5.10.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-06-29 14:59:14 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-07-02 08:05:13 -0500
commit6b9ab6ab5a375f4bd169f6e308169d3b14dbf820 (patch)
treefe316b950acd199ffd4778a892447df4622c0c38 /recipes-kernel/linux/linux-imx_5.10.bb
parente453ee3a8d0ca76b78c46d5bad9b1b9384c57849 (diff)
downloadmeta-freescale-6b9ab6ab5a375f4bd169f6e308169d3b14dbf820.tar.gz
linux-imx*: Upgrade to 5.10.35
Upgrade kernel, headers, and mfgtool for NXP BSP. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-kernel/linux/linux-imx_5.10.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_5.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_5.10.bb b/recipes-kernel/linux/linux-imx_5.10.bb
new file mode 100644
index 00000000..68344e4e
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx_5.10.bb
@@ -0,0 +1,33 @@
1# Copyright 2013-2016 (C) Freescale Semiconductor
2# Copyright 2017-2021 (C) NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5#
6# SPDX-License-Identifier: MIT
7#
8
9SUMMARY = "Linux Kernel provided and supported by NXP"
10DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
11i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
12
13require recipes-kernel/linux/linux-imx.inc
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
17
18DEPENDS += "lzop-native bc-native"
19
20SRCBRANCH = "lf-5.10.y"
21LOCALVERSION = "-5.10.35-2.0.0"
22SRCREV = "ef3f2cfc6010c13feb40cfb7fd7490832cf86f45"
23
24# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
25# required by kernel-yocto.bbclass.
26#
27# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
28# should be updated once patchlevel is merged.
29LINUX_VERSION = "5.10.35"
30
31DEFAULT_PREFERENCE = "1"
32
33COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"