summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc/mxs/defconfig
diff options
context:
space:
mode:
authorJitesh Pramodray <jiteshprm@gmail.com>2021-02-26 21:52:18 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2021-03-09 08:29:10 -0300
commit97d2ea43c86121c301360596a351a9cd5ea467fb (patch)
treea88fd0e21644687625ddf0e1eeab2399fffbd39e /recipes-kernel/linux/linux-fslc/mxs/defconfig
parent2c5429f00e5b9b717cddd9e13e1302f7bdea57e1 (diff)
downloadmeta-freescale-97d2ea43c86121c301360596a351a9cd5ea467fb.tar.gz
linux-fslc: Fix build issue when compiling LTTng
Fix compile error when building lttng using bitbake by: Enable kprobes configuration enabled from menuconfig Run diffconfig Copy the resulting diff contents into all the linux-fslc defconfig files Add end of line in defconfig Built the kernel with no warnings from do_kernel_configcheck task Add correct defconfig configuration for armv8a Tested on master branch from 3rd March 2021 Error: riotboard/fsl-community-bsp/build/tmp/work/ imx6dl_riotboard-fslc-linux-gnueabi/lttng-modules/2.12.4-r0/ lttng-modules-2.12.4/wrapper/kallsyms.c:20:3: error: 20 | # error "LTTng-modules requires CONFIG_KPROBES on kernels >= 5.7.0" | ^~~~~ make[3]: *** [riotboard/fsl-community-bsp/build/tmp/work-shared/ imx6dl-riotboard/kernel-source/scripts/Makefile.build:279: riotboard/fsl-community-bsp/build/tmp/work/ imx6dl_riotboard-fslc-linux-gnueabi/lttng-modules/2.12.4-r0/ lttng-modules-2.12.4/wrapper/kallsyms.o] Error 1 Compile flags: cd ~/riotboard/fsl-community-bsp MACHINE=imx6dl-riotboard DISTRO=fslc-framebuffer source setup-environment build bitbake fsl-image-machine-test Signed-off-by: Jitesh Pramodray <jiteshprm@gmail.com>
Diffstat (limited to 'recipes-kernel/linux/linux-fslc/mxs/defconfig')
-rw-r--r--recipes-kernel/linux/linux-fslc/mxs/defconfig6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc/mxs/defconfig b/recipes-kernel/linux/linux-fslc/mxs/defconfig
index a9c6f32a..a913c0dd 100644
--- a/recipes-kernel/linux/linux-fslc/mxs/defconfig
+++ b/recipes-kernel/linux/linux-fslc/mxs/defconfig
@@ -172,3 +172,9 @@ CONFIG_PROVE_LOCKING=y
172CONFIG_BLK_DEV_IO_TRACE=y 172CONFIG_BLK_DEV_IO_TRACE=y
173CONFIG_STRICT_DEVMEM=y 173CONFIG_STRICT_DEVMEM=y
174CONFIG_DEBUG_USER=y 174CONFIG_DEBUG_USER=y
175CONFIG_KPROBES=y
176CONFIG_OPTPROBES=y
177CONFIG_KRETPROBES=y
178# CONFIG_ARM_KPROBES_TEST is not set
179# CONFIG_KPROBES_SANITY_TEST is not set
180