summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_5.10.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-09-29 09:18:49 +0000
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2021-09-29 11:39:56 +0000
commiteaa21ad315f6cc7f0a8ecd922573ab3283948902 (patch)
treed9cf734a60bd0a6f51dc6f49f3a1b179bdf0e95c /recipes-kernel/linux/linux-fslc-imx_5.10.bb
parent02430d3fdf6f38b189449fb448216e5fe3f52be6 (diff)
downloadmeta-freescale-eaa21ad315f6cc7f0a8ecd922573ab3283948902.tar.gz
linux-fslc-imx: upgrade to lf-5.10.52-2.1.0 from NXP
Kernel repository has a new branch introduced, which is based on NXP release lf-5.10.52-2.1.0 and has latest stable patchlevel applied to it. Current version of up-merged kernel is 5.10.69. Update kernel recipe to include new kernel version and align kernel config files based on following NXP configurations: - imx_v8_defconfig used for i.MX8 family - i.MX6/7 families kernel config file did not require any additional sync, it matches to the imx_v7_defconfig Configuration file sync point in NXP linux-imx tree: a11753a89ec6 ("LF-4558-2 input: touch: goodix: change the i2c data length to a small one") Tracking information in recipe is updated to include new branch, tag and cherry-picks from NXP branch, together with patches applied from various sources. Patches already applied upstream are dropped from the list. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> (cherry picked from commit 32cbd69284318ffec757feff476cdfae63d35d7e)
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_5.10.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.10.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.10.bb b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
new file mode 100644
index 00000000..66fcbd6b
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
@@ -0,0 +1,73 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2#
3# SPDX-License-Identifier: MIT
4#
5
6SUMMARY = "Linux Kernel provided by NXP and supported by Community"
7DESCRIPTION = "Linux Kernel provided by NXP as the part of release distribution. \
8Main focus is set on i.MX Family Reference Boards. \
9It includes support for many NXP Proprietary IPs (GPU, VPU, IPU). \
10Latest stable Kernel patchlevel is applied and maintained by Community."
11
12###############################################################################
13# This recipe (and corresponding kernel repository and branch) receives updates
14# from 3 different sources:
15# 1. Stable [linux-5.10.y] branch updates of korg;
16# 2. NXP-specific updates via branch [5.10-2.1.x-imx] shared via CodeAurora forum;
17# 3. Critical patches, which are not (yet) integrated into either of 2 above
18# sources, but are required to be applied to the kernel tree.
19#
20# Therefore, there is a need to keep track on the patches which are introduced
21# from every source. This could be achieved in this recipe by filling the
22# below list with the information once the update is performed from any source.
23#
24# Once the critical patch gets merged into the stable branch, or NXP-specific
25# patches would be covered by the tag - individual entries from sections below
26# could be removed.
27#
28# ------------------------------------------------------------------------------
29# 1. Stable (tag or SHA(s))
30# ------------------------------------------------------------------------------
31# tag: v5.10.69
32#
33# ------------------------------------------------------------------------------
34# 2. NXP-specific (tag or SHA(s))
35# ------------------------------------------------------------------------------
36# tag: lf-5.10.52-2.1.0
37#
38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------
41# fb3e7593ee84 ("irq-imx-irqsteer: fix compile error if CONFIG_PM_SLEEP is not set")
42# 96613ac4e960 ("arm: imx: include i.MX6SX DDR freq implementation for i.MX6UL")
43# 36fea22d04f4 ("arm: imx: do not include smp_wfe_imx6.S for i.MX6SX")
44# f86c8a4736f2 ("arm: imx: enable HAVE_IMX_BUSFREQ for i.MX6")
45# 05f7280c8648 ("arm: imx: do not build busfreq without HAVE_IMX_BUSFREQ")
46#
47# NOTE to upgraders:
48# This recipe should NOT collect individual patches, they should be applied to
49# the linux-fslc kernel tree on the corresponding branch, and tracking
50# information should be properly filled in above.
51###############################################################################
52
53include linux-fslc.inc
54
55LICENSE = "GPLv2"
56LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
57
58KBRANCH = "5.10-2.1.x-imx"
59SRCREV = "54bd61ba352bffaf33ee2c956f140a565c9e2201"
60
61# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
62# required by kernel-yocto.bbclass.
63#
64# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
65# should be updated once patchlevel is merged.
66LINUX_VERSION = "5.10.69"
67
68# Local version indicates the branch name in the NXP kernel tree where patches are collected from.
69LOCALVERSION = "-5.10.52-2.1.0"
70
71DEFAULT_PREFERENCE = "1"
72
73COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"