diff options
author | Cristinel Panfir <cristinel.panfir@nxp.com> | 2019-12-06 14:23:16 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2020-01-07 18:48:07 -0300 |
commit | 90091a89c0c2a6d7a9a636768a13c913228417e5 (patch) | |
tree | 6fc270396af585a2795fb72ff40b9d5b8c0b49bd /recipes-kernel/kernel-modules | |
parent | 8857d481765c7d7d07c572d5be3e59cf449feb0f (diff) | |
download | meta-freescale-90091a89c0c2a6d7a9a636768a13c913228417e5.tar.gz |
kernel-module: Upgrade qca6174 and qca9377 to version 3.0
Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch | 91 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb (renamed from recipes-kernel/kernel-modules/kernel-module-qca6174_2.1.bb) | 2 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qca9377_3.0.bb (renamed from recipes-kernel/kernel-modules/kernel-module-qca9377_2.1.bb) | 0 | ||||
-rw-r--r-- | recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc | 4 |
4 files changed, 2 insertions, 95 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch b/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch deleted file mode 100644 index 2c8bce3b..00000000 --- a/recipes-kernel/kernel-modules/kernel-module-qca6174/0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch +++ /dev/null | |||
@@ -1,91 +0,0 @@ | |||
1 | From 16573cbb9c82218f93741a9bc873242c012ac061 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hangtian Zhu <hangtian@qti.qualcomm.com> | ||
3 | Date: Thu, 14 Jun 2018 11:10:05 +0800 | ||
4 | Subject: [PATCH 22/23] MLK-18491-02 qcacld-2.0: fix the overflow of bounce | ||
5 | buffer | ||
6 | |||
7 | Patch a41baa51cbc5("MLK-18491 qcacld-2.0: avoid overflow of bounce buffer") | ||
8 | is not reasonable to fix overflow of bounce buffer issue. | ||
9 | |||
10 | The patch is released by Qualcomm to fix the issue. | ||
11 | (Case Number:03515221) | ||
12 | |||
13 | Signed-off-by: Hangtian Zhu <hangtian@qti.qualcomm.com> | ||
14 | --- | ||
15 | CORE/SERVICES/HTC/htc.c | 2 +- | ||
16 | CORE/SERVICES/HTC/htc_send.c | 28 ++++++++++++++-------------- | ||
17 | 2 files changed, 15 insertions(+), 15 deletions(-) | ||
18 | |||
19 | diff --git a/CORE/SERVICES/HTC/htc.c b/CORE/SERVICES/HTC/htc.c | ||
20 | index 1e2450d..09936a0 100644 | ||
21 | --- a/CORE/SERVICES/HTC/htc.c | ||
22 | +++ b/CORE/SERVICES/HTC/htc.c | ||
23 | @@ -657,7 +657,7 @@ static void ResetEndpointStates(HTC_TARGET *target) | ||
24 | INIT_HTC_PACKET_QUEUE(&pEndpoint->RxBufferHoldQueue); | ||
25 | pEndpoint->target = target; | ||
26 | //pEndpoint->TxCreditFlowEnabled = (A_BOOL)htc_credit_flow; | ||
27 | - pEndpoint->TxCreditFlowEnabled = (A_BOOL)0; | ||
28 | + pEndpoint->TxCreditFlowEnabled = (A_BOOL)1; | ||
29 | adf_os_atomic_init(&pEndpoint->TxProcessCount); | ||
30 | } | ||
31 | } | ||
32 | diff --git a/CORE/SERVICES/HTC/htc_send.c b/CORE/SERVICES/HTC/htc_send.c | ||
33 | index 1a3dd28..19d8065 100644 | ||
34 | --- a/CORE/SERVICES/HTC/htc_send.c | ||
35 | +++ b/CORE/SERVICES/HTC/htc_send.c | ||
36 | @@ -105,12 +105,12 @@ void HTCGetControlEndpointTxHostCredits(HTC_HANDLE HTCHandle, int *credits) | ||
37 | |||
38 | static INLINE void RestoreTxPacket(HTC_TARGET *target, HTC_PACKET *pPacket) | ||
39 | { | ||
40 | + adf_nbuf_t netbuf = GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket); | ||
41 | if (pPacket->PktInfo.AsTx.Flags & HTC_TX_PACKET_FLAG_FIXUP_NETBUF) { | ||
42 | - adf_nbuf_t netbuf = GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket); | ||
43 | adf_nbuf_unmap(target->osdev, netbuf, ADF_OS_DMA_TO_DEVICE); | ||
44 | - adf_nbuf_pull_head(netbuf, sizeof(HTC_FRAME_HDR)); | ||
45 | pPacket->PktInfo.AsTx.Flags &= ~HTC_TX_PACKET_FLAG_FIXUP_NETBUF; | ||
46 | } | ||
47 | + adf_nbuf_pull_head(netbuf, sizeof(HTC_FRAME_HDR)); | ||
48 | |||
49 | } | ||
50 | |||
51 | @@ -641,12 +641,11 @@ static A_STATUS HTCIssuePackets(HTC_TARGET *target, | ||
52 | * that is already mapped, or a non-data netbuf that needs to be | ||
53 | * mapped. | ||
54 | */ | ||
55 | - if (pPacket->PktInfo.AsTx.Flags & HTC_TX_PACKET_FLAG_FIXUP_NETBUF) { | ||
56 | - adf_nbuf_map( | ||
57 | - target->osdev, | ||
58 | - GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket), | ||
59 | - ADF_OS_DMA_TO_DEVICE); | ||
60 | - } | ||
61 | + pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF; | ||
62 | + adf_nbuf_map( | ||
63 | + target->osdev, | ||
64 | + GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket), | ||
65 | + ADF_OS_DMA_TO_DEVICE); | ||
66 | } | ||
67 | LOCK_HTC_TX(target); | ||
68 | /* store in look up queue to match completions */ | ||
69 | @@ -1261,12 +1260,13 @@ A_STATUS HTCSendPktsMultiple(HTC_HANDLE HTCHandle, HTC_PACKET_QUEUE *pPktQueue) | ||
70 | * mapped. This only applies to non-data frames, since data frames | ||
71 | * were already mapped as they entered into the driver. | ||
72 | */ | ||
73 | - adf_nbuf_map( | ||
74 | - target->osdev, | ||
75 | - GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket), | ||
76 | - ADF_OS_DMA_TO_DEVICE); | ||
77 | - | ||
78 | - pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF; | ||
79 | + if(!IS_TX_CREDIT_FLOW_ENABLED(pEndpoint)) { | ||
80 | + pPacket->PktInfo.AsTx.Flags |= HTC_TX_PACKET_FLAG_FIXUP_NETBUF; | ||
81 | + adf_nbuf_map( | ||
82 | + target->osdev, | ||
83 | + GET_HTC_PACKET_NET_BUF_CONTEXT(pPacket), | ||
84 | + ADF_OS_DMA_TO_DEVICE); | ||
85 | + } | ||
86 | } HTC_PACKET_QUEUE_ITERATE_END; | ||
87 | |||
88 | HTCTrySend(target,pEndpoint,pPktQueue); | ||
89 | -- | ||
90 | 1.9.1 | ||
91 | |||
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca6174_2.1.bb b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb index 3bc18124..c59e23f5 100644 --- a/recipes-kernel/kernel-modules/kernel-module-qca6174_2.1.bb +++ b/recipes-kernel/kernel-modules/kernel-module-qca6174_3.0.bb | |||
@@ -2,8 +2,6 @@ require kernel-module-qcacld-lea.inc | |||
2 | 2 | ||
3 | SUMMARY = "Qualcomm WiFi driver for QCA module 6174" | 3 | SUMMARY = "Qualcomm WiFi driver for QCA module 6174" |
4 | 4 | ||
5 | SRC_URI += "file://0001-MLK-18491-02-qcacld-2.0-fix-the-overflow-of-bounce-b.patch" | ||
6 | |||
7 | EXTRA_OEMAKE += " \ | 5 | EXTRA_OEMAKE += " \ |
8 | CONFIG_ROME_IF=pci \ | 6 | CONFIG_ROME_IF=pci \ |
9 | CONFIG_WLAN_FEATURE_11W=y \ | 7 | CONFIG_WLAN_FEATURE_11W=y \ |
diff --git a/recipes-kernel/kernel-modules/kernel-module-qca9377_2.1.bb b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.0.bb index fbc87ea2..fbc87ea2 100644 --- a/recipes-kernel/kernel-modules/kernel-module-qca9377_2.1.bb +++ b/recipes-kernel/kernel-modules/kernel-module-qca9377_3.0.bb | |||
diff --git a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc index 662975aa..dc48bc5d 100644 --- a/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc +++ b/recipes-kernel/kernel-modules/kernel-module-qcacld-lea.inc | |||
@@ -3,8 +3,8 @@ LICENSE = "BSD & GPLv2" | |||
3 | LIC_FILES_CHKSUM = "file://CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=ec8d62116b13db773825ebf7cf91be1d;" | 3 | LIC_FILES_CHKSUM = "file://CORE/HDD/src/wlan_hdd_main.c;beginline=1;endline=20;md5=ec8d62116b13db773825ebf7cf91be1d;" |
4 | 4 | ||
5 | QCACLD_SRC ?= "git://source.codeaurora.org/external/imx/qcacld-2.0-imx.git;protocol=https" | 5 | QCACLD_SRC ?= "git://source.codeaurora.org/external/imx/qcacld-2.0-imx.git;protocol=https" |
6 | SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_2.0" | 6 | SRC_URI = "${QCACLD_SRC};branch=IMX_CNSS.LEA.NRT_3.0" |
7 | SRCREV = "e008d2578b09f1f593f65ede48529a52312e3957" | 7 | SRCREV = "2f4ae376ce3db65c3270a4bf7e804f3e86052c8c" |
8 | 8 | ||
9 | S = "${WORKDIR}/git" | 9 | S = "${WORKDIR}/git" |
10 | 10 | ||