summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/kernel-modules
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-28 18:36:52 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:16 -0300
commitdd2894a5cd0ee27a755ac577df27ed2d13eeed2d (patch)
treeb93ec13a065154e619ed3a6518510b396df0da3e /recipes-kernel/kernel-modules
parent832db3af971cfce8d31442081486c3363b3f7f71 (diff)
downloadmeta-freescale-dd2894a5cd0ee27a755ac577df27ed2d13eeed2d.tar.gz
rename asf to kernel-module-asf and move bb to kernel-modules subdir
* rename asf to kernel-module-asf * move bb file to the common kernel-modules subdirectory Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/kernel-modules')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-asf_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-asf_git.bb b/recipes-kernel/kernel-modules/kernel-module-asf_git.bb
new file mode 100644
index 00000000..a9624e49
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-asf_git.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9RDEPENDS_${PN} += "ipsec-tools"
10
11inherit module qoriq_build_64bit_kernel
12
13S = "${WORKDIR}/git/asfmodule"
14
15EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
16export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
17
18INHIBIT_PACKAGE_STRIP = "1"
19
20do_configure[depends] += "virtual/kernel:do_shared_workdir"
21do_configure_prepend () {
22 find ${S} -name Makefile -exec \
23 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
24}
25
26do_install(){
27 install -d ${D}/${libexecdir}
28 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
30 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
31 cp -rf ${S}/../scripts ${D}/${libexecdir}/
32}
33
34FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
35
36COMPATIBLE_MACHINE = "(qoriq)"